aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-01-24 11:54:20 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-01-24 11:54:20 +0000
commitdb021968e3411b659e079e540742896abe4193f1 (patch)
treead7f282ff1e254cc6c54bfc24d23efee0af4d12e /converters
parent93028a155ae531c7c9a6c723a6d465b49a90e9df (diff)
downloadports-db021968e3411b659e079e540742896abe4193f1.tar.gz
ports-db021968e3411b659e079e540742896abe4193f1.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/php71-iconv/Makefile9
-rw-r--r--converters/php71-mbstring/Makefile9
-rw-r--r--converters/php71-mbstring/files/patch-config.m451
-rw-r--r--converters/php71-recode/Makefile9
4 files changed, 78 insertions, 0 deletions
diff --git a/converters/php71-iconv/Makefile b/converters/php71-iconv/Makefile
new file mode 100644
index 000000000000..0f5ed83c3272
--- /dev/null
+++ b/converters/php71-iconv/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -iconv
+
+.include "${MASTERDIR}/Makefile"
diff --git a/converters/php71-mbstring/Makefile b/converters/php71-mbstring/Makefile
new file mode 100644
index 000000000000..4674db771e06
--- /dev/null
+++ b/converters/php71-mbstring/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -mbstring
+
+.include "${MASTERDIR}/Makefile"
diff --git a/converters/php71-mbstring/files/patch-config.m4 b/converters/php71-mbstring/files/patch-config.m4
new file mode 100644
index 000000000000..026798f26a5a
--- /dev/null
+++ b/converters/php71-mbstring/files/patch-config.m4
@@ -0,0 +1,51 @@
+--- config.m4.orig 2009-11-25 02:30:06.000000000 +0100
++++ config.m4 2010-04-12 09:59:54.000000000 +0200
+@@ -43,6 +43,30 @@
+ PHP_ADD_INCLUDE([$ext_builddir/$dir])
+ done
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ if test "$ext_shared" = "no"; then
+ PHP_ADD_SOURCES(PHP_EXT_DIR(mbstring), $PHP_MBSTRING_BASE_SOURCES)
+ out="php_config.h"
+@@ -80,7 +104,6 @@
+ int foo(int x, ...) {
+ va_list va;
+ va_start(va, x);
+- va_arg(va, int);
+ va_arg(va, char *);
+ va_arg(va, double);
+ return 0;
+@@ -347,6 +370,9 @@
+ [ --with-onig[=DIR] MBSTRING: Use external oniguruma. DIR is the oniguruma install prefix.
+ If DIR is not set, the bundled oniguruma will be used], no, no)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir MBSTRING: pcre install prefix], no, no)
++
+ if test "$PHP_MBSTRING" != "no"; then
+ AC_DEFINE([HAVE_MBSTRING],1,[whether to have multibyte string support])
+
diff --git a/converters/php71-recode/Makefile b/converters/php71-recode/Makefile
new file mode 100644
index 000000000000..bc38fc9ca78f
--- /dev/null
+++ b/converters/php71-recode/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -recode
+
+.include "${MASTERDIR}/Makefile"