aboutsummaryrefslogtreecommitdiff
path: root/databases/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2020-12-02 21:48:25 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2020-12-02 21:48:25 +0000
commit274299c72d5c168f22eddece175d40c4d70c0b4d (patch)
treec0256b6928a287377b29dd377e5a8eb3a6f658a9 /databases/Makefile
parent04d2ea8a9e85e1f814fdd914b77a7b61e9eace7a (diff)
downloadports-274299c72d5c168f22eddece175d40c4d70c0b4d.tar.gz
ports-274299c72d5c168f22eddece175d40c4d70c0b4d.zip
- Add databases/py-aesqlapius
So you don't want to use ORM, and want to organize your SQL queries in a convenient way. Don't mix them with your python code, don't write `execute` and `fetchrow`s by hand for each query. With aesqlapius: - Store your SQL queries separate from the code, in a dedicated file or directory hierarchy - Annotate each query with python-like function definition specifying input arguments and output types and patterns aesqlapius builds a class out of this, where you can call your queries as plain methods. It handles arguments (pass positional or keyword arguments as you like, default values are also handled) and output types and patterns (you may specify whether a method returns iterator, list, dict of rows, or a single row, where row may be represented as a tuple, list, dict, single value or a custom type such as a dataclass). WWW: https://pypi.org/project/aesqlapius/
Notes
Notes: svn path=/head/; revision=556856
Diffstat (limited to 'databases/Makefile')
-rw-r--r--databases/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 9709c8c661f1..4957d433a45c 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -746,6 +746,7 @@
SUBDIR += py-MySQLdb
SUBDIR += py-PyGreSQL
SUBDIR += py-Pyrseas
+ SUBDIR += py-aesqlapius
SUBDIR += py-agate-sql
SUBDIR += py-aiopg
SUBDIR += py-aioredis