aboutsummaryrefslogtreecommitdiff
path: root/databases/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-08-10 19:35:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-08-10 19:35:17 +0000
commitc242443a3866a61f0c98d0d9bdc2e7f0daa82f18 (patch)
treeed8f97110526dcf1d695e38955ba6ade2c6a2c4a /databases/Makefile
parentc3ef35dcd4e8a9c1e323f5d74370c409d3d1a73c (diff)
downloadports-c242443a3866a61f0c98d0d9bdc2e7f0daa82f18.tar.gz
ports-c242443a3866a61f0c98d0d9bdc2e7f0daa82f18.zip
psycopg2 is a PostgreSQL database adapter for the Python programming language.
It was written from scratch with the aim of being small, fast and stable. It supports the full Python DBAPI-2.0 and is thread safe. psycopg2 is different from the other database adapter because it was designed for heavily multi-threaded applications that create and destroy lots of cursors and make a conspicuous number of concurrent INSERTs or UPDATEs. Every open Python connection keeps a pool of real (UNIX or TCP/IP) connections to the database. Every time a new cursor is created, a new connection does not need to be opened; instead one of the unused connections from the pool is used. That makes psycopg very fast in typical client-server applications that create a servicing thread every time a client request arrives. WWW: http://initd.org/projects/psycopg2 Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=170291
Diffstat (limited to 'databases/Makefile')
-rw-r--r--databases/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index b2c4034d4be7..5c4f0f4d47f0 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -393,6 +393,7 @@
SUBDIR += py-mssql
SUBDIR += py-oops
SUBDIR += py-psycopg
+ SUBDIR += py-psycopg2
SUBDIR += py-pyPgSQL
SUBDIR += py-sqlite3
SUBDIR += py-sqlobject