aboutsummaryrefslogtreecommitdiff
path: root/databases/apq
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-03-26 01:39:57 +0000
committerJohn Marino <marino@FreeBSD.org>2014-03-26 01:39:57 +0000
commitbfd732afd7e5ebd4fb636845884b8e51cd208b2f (patch)
tree8b291352de64db2aec3f84bd64d02e1c1eb92603 /databases/apq
parentdad71c4cc3163f9e2975fa3dae0b5ac82bc34488 (diff)
downloadports-bfd732afd7e5ebd4fb636845884b8e51cd208b2f.tar.gz
ports-bfd732afd7e5ebd4fb636845884b8e51cd208b2f.zip
APQ ports: apq, apq-mysql, apq-pgsql, apq-odbc
Without direction, GPRconfig will create a cgpr file at the standard $PREFIX/lib/gnat repository. This is the cause of the builder failures because it touches a part of the userland it's not supposed to. GPRconfig should be modified not to do this; it is never desirable. In the meantime, the fix for APQ is to specify .cgpr targets which do not exist so GPRconfig creates them there instead of $PREFIX/lib/gnat. Reported by: swills
Notes
Notes: svn path=/head/; revision=349205
Diffstat (limited to 'databases/apq')
-rw-r--r--databases/apq/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/databases/apq/Makefile b/databases/apq/Makefile
index 6af614939a30..7657892c073a 100644
--- a/databases/apq/Makefile
+++ b/databases/apq/Makefile
@@ -32,6 +32,10 @@ OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e '/for Object_Dir/d' ${WRKSRC}/gnat/apq.gpr.in
+ ${REINPLACE_CMD} -e 's|processors=2|gprbuild_params="--autoconf=apq.cgpr"|' \
+ ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|-ws|-ws --autoconf=dummy.cgpr|' \
+ ${WRKSRC}/scripts/buildutil.sh
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/gnat \