aboutsummaryrefslogtreecommitdiff
path: root/databases/ateam_mysql57_ldap_auth
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-30 08:54:04 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-30 08:54:04 +0000
commit247c7858c15b3318e38b43a48920ca7cbc69f737 (patch)
treeb7f2eb39ef33b837f7ae374588e1e903614c97cf /databases/ateam_mysql57_ldap_auth
parentcbb089518eefd538f1c59669906a19dd90e9dfb5 (diff)
downloadports-247c7858c15b3318e38b43a48920ca7cbc69f737.tar.gz
ports-247c7858c15b3318e38b43a48920ca7cbc69f737.zip
databases/ateam_mysql57_ldap_auth: fix build on GCC architectures
Use C11 compiler: /usr/local/include/mysql/my_global.h:212: error: redefinition of typedef 'my_socket' /usr/local/include/mysql/mysql.h:64: error: previous declaration of 'my_socket' was here
Notes
Notes: svn path=/head/; revision=543719
Diffstat (limited to 'databases/ateam_mysql57_ldap_auth')
-rw-r--r--databases/ateam_mysql57_ldap_auth/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/databases/ateam_mysql57_ldap_auth/Makefile b/databases/ateam_mysql57_ldap_auth/Makefile
index ebf1492ef1c9..633ab453e292 100644
--- a/databases/ateam_mysql57_ldap_auth/Makefile
+++ b/databases/ateam_mysql57_ldap_auth/Makefile
@@ -15,7 +15,7 @@ IGNORE_WITH_MYSQL= 56 80 101m 102m 103m
LIB_DEPENDS= libconfig.so:devel/libconfig
-USES= gmake mysql:client,server
+USES= compiler:c++11-lang gmake mysql:client,server
USE_OPENLDAP= yes
USE_GITHUB= yes
@@ -30,6 +30,8 @@ OPTIONS_DEFINE= DOCS
SUB_FILES= pkg-message
+MAKE_ARGS= CC="${CC}"
+
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/mysql/plugin
${INSTALL_PROGRAM} ${WRKSRC}/src/auth_ldap.so \