aboutsummaryrefslogtreecommitdiff
path: root/databases/autobackupmysql
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-03 13:22:25 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-03 13:22:25 +0000
commit820d4024b933651f9ed141f9edb30d87a98bafd9 (patch)
tree44ea9dffcf474fdd6dc3ca4b618e3f61820821e4 /databases/autobackupmysql
parenta2f44201a83701f5e19fae997baf229577add904 (diff)
downloadports-820d4024b933651f9ed141f9edb30d87a98bafd9.tar.gz
ports-820d4024b933651f9ed141f9edb30d87a98bafd9.zip
Support staging
Notes
Notes: svn path=/head/; revision=346896
Diffstat (limited to 'databases/autobackupmysql')
-rw-r--r--databases/autobackupmysql/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/databases/autobackupmysql/Makefile b/databases/autobackupmysql/Makefile
index ec82e73ecf78..f2779ba73582 100644
--- a/databases/autobackupmysql/Makefile
+++ b/databases/autobackupmysql/Makefile
@@ -16,16 +16,17 @@ RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
NO_BUILD= yes
PLIST_FILES= sbin/autobackupmysql.sh
-NO_STAGE= yes
do-extract:
- ${MKDIR} ${WRKSRC}
- ${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/autobackupmysql.sh
- @${REINPLACE_CMD} -e 's|${LOCALBASE}/etc|${PREFIX}/etc|g' ${WRKSRC}/autobackupmysql.sh
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/autobackupmysql.sh
+ @${REINPLACE_CMD} -e 's|${LOCALBASE}/etc|${PREFIX}/etc|g' \
+ ${WRKSRC}/autobackupmysql.sh
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.sh ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/sbin
.include <bsd.port.mk>