aboutsummaryrefslogtreecommitdiff
path: root/databases/beansdb
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2010-04-05 21:44:57 +0000
committerXin LI <delphij@FreeBSD.org>2010-04-05 21:44:57 +0000
commit5d19afdad9d688faeaebcdfaedec5913d8685306 (patch)
tree6ce7882f75bdd0c473f7ce074133dc1414dfd280 /databases/beansdb
parentba4e8e9c128099f33f0de34b08cf33ad9a9b5b3f (diff)
downloadports-5d19afdad9d688faeaebcdfaedec5913d8685306.tar.gz
ports-5d19afdad9d688faeaebcdfaedec5913d8685306.zip
Notes
Diffstat (limited to 'databases/beansdb')
-rw-r--r--databases/beansdb/Makefile32
-rw-r--r--databases/beansdb/distinfo3
-rw-r--r--databases/beansdb/pkg-descr6
3 files changed, 41 insertions, 0 deletions
diff --git a/databases/beansdb/Makefile b/databases/beansdb/Makefile
new file mode 100644
index 000000000000..ecad773ed414
--- /dev/null
+++ b/databases/beansdb/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: beansdb
+# Date created: 2010-03-27
+# Whom: Qing Feng <qingfeng@me.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= beansdb
+PORTVERSION= 0.3.0
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= qingfeng@me.com
+COMMENT= Yet anonther distributed key-value storage system from Douban Inc
+
+BUILD_DEPENDS= tokyocabinet>=1.4.30:${PORTSDIR}/databases/tokyocabinet
+LIB_DEPENDS= tokyocabinet:${PORTSDIR}/databases/tokyocabinet
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+
+MAN1= beansdb.1
+PLIST_FILES= bin/beansdb bin/convert
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|#include <mcheck.h>||g' \
+ ${WRKSRC}/*.c
+ ${REINPLACE_CMD} -e 's|#include <mcheck.h>||g' \
+ ${WRKSRC}/tools/*.c
+
+.include <bsd.port.mk>
diff --git a/databases/beansdb/distinfo b/databases/beansdb/distinfo
new file mode 100644
index 000000000000..834364b14550
--- /dev/null
+++ b/databases/beansdb/distinfo
@@ -0,0 +1,3 @@
+MD5 (beansdb-0.3.0.tar.gz) = ff55f36753123578098ce16b0fd7d627
+SHA256 (beansdb-0.3.0.tar.gz) = 99eb3b14614ef74f9763690227ca0d22fe8742337e7cd56b46c6ac32aa9e61e7
+SIZE (beansdb-0.3.0.tar.gz) = 131510
diff --git a/databases/beansdb/pkg-descr b/databases/beansdb/pkg-descr
new file mode 100644
index 000000000000..67b20a285ab8
--- /dev/null
+++ b/databases/beansdb/pkg-descr
@@ -0,0 +1,6 @@
+BeansDB is a major amount of data for large, high-availability storage systems
+distributed KeyValue using HashTree and simplified version number to
+quickly synchronize to ensure consistency in the final (weak),
+a simplified version of the Dynamo.
+
+WWW: http://code.google.com/p/beansdb/