aboutsummaryrefslogtreecommitdiff
path: root/databases/cassandra-cpp-driver
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /databases/cassandra-cpp-driver
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'databases/cassandra-cpp-driver')
-rw-r--r--databases/cassandra-cpp-driver/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/databases/cassandra-cpp-driver/Makefile b/databases/cassandra-cpp-driver/Makefile
index 6c94989fa436..c8efb184653a 100644
--- a/databases/cassandra-cpp-driver/Makefile
+++ b/databases/cassandra-cpp-driver/Makefile
@@ -13,13 +13,15 @@ LICENSE= APACHE20
LIB_DEPENDS= libuv.so:devel/libuv
-USES= cmake:outsource compiler:c++11-lang pkgconfig pathfix ssl
+USES= cmake compiler:c++11-lang pkgconfig pathfix ssl
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= datastax
GH_PROJECT= cpp-driver
-CMAKE_ARGS= -DCMAKE_INSTALL_LIBDIR:STRING=lib -DCASS_BUILD_STATIC:BOOL=ON
+USES= cmake pkgconfig pathfix ssl
+CMAKE_ARGS= -DCMAKE_INSTALL_LIBDIR:STRING=lib \
+ -DCASS_BUILD_STATIC:BOOL=ON
PLIST_FILES= include/cassandra.h \
lib/libcassandra.so \