aboutsummaryrefslogtreecommitdiff
path: root/databases/cppdb
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-06 11:46:14 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-06 12:30:35 +0000
commitc468513b79f4bee21bfdbf6eef12441c0e8bc7ee (patch)
tree974dc1301742f13e92ea1dcaee0aca37f7704967 /databases/cppdb
parent068ee48598fc9b38fe5deb62df85b3f2a2b31006 (diff)
downloadports-c468513b79f4bee21bfdbf6eef12441c0e8bc7ee.tar.gz
ports-c468513b79f4bee21bfdbf6eef12441c0e8bc7ee.zip
databases/cppdb: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'databases/cppdb')
-rw-r--r--databases/cppdb/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/databases/cppdb/Makefile b/databases/cppdb/Makefile
index b7d273ead16e..f4cacbc35aa6 100644
--- a/databases/cppdb/Makefile
+++ b/databases/cppdb/Makefile
@@ -12,6 +12,10 @@ LICENSE= BSL MIT
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/copyright.txt
+USES= cmake tar:bzip2
+USE_CXXSTD= c++14
+USE_LDCONFIG= yes
+
NO_OPTIONS_SORT= yes
OPTIONS_SINGLE= SQLITE3 PGSQL MYSQL ODBC
OPTIONS_SINGLE_MYSQL= MYSQL_DISABLE MYSQL_INTERNAL MYSQL_MODULE
@@ -38,9 +42,6 @@ SQLITE3_DISABLE_DESC= Disable SQLite 3 backend
SQLITE3_INTERNAL_DESC= Link SQLite 3 backend into CppDB
SQLITE3_MODULE_DESC= Build SQLite 3 backend as a CppDB module
-USE_LDCONFIG= yes
-USES= cmake tar:bzip2
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMYSQL_DISABLE}