aboutsummaryrefslogtreecommitdiff
path: root/databases/cutelyst-asql
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2020-10-26 15:36:38 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2020-10-26 15:36:38 +0000
commit24eb38a64021bad1aaa51de34d6b1458d6ff5954 (patch)
tree14be6cd82425ad849e5fe0422bf893171abb92b7 /databases/cutelyst-asql
parent3d6ae75995e4aefb65fe1a628ef0e6937cac9fb6 (diff)
downloadports-24eb38a64021bad1aaa51de34d6b1458d6ff5954.tar.gz
ports-24eb38a64021bad1aaa51de34d6b1458d6ff5954.zip
New port: database/cutelyst-asql
asql is an asynchronous, C++11-native, Qt5 based SQL Query library. You can use it to write async queries with natural C++-lambda and Qt5-slots style code. Right now there is only a PostgreSQL backend, but others are planned (and then the port will grow OPTIONS). This comes from the cutelyst project, and it would conflict with www/asql is named the "obvious" way, so name it something inbetween.
Notes
Notes: svn path=/head/; revision=553357
Diffstat (limited to 'databases/cutelyst-asql')
-rw-r--r--databases/cutelyst-asql/Makefile27
-rw-r--r--databases/cutelyst-asql/distinfo3
-rw-r--r--databases/cutelyst-asql/pkg-descr12
-rw-r--r--databases/cutelyst-asql/pkg-plist18
4 files changed, 60 insertions, 0 deletions
diff --git a/databases/cutelyst-asql/Makefile b/databases/cutelyst-asql/Makefile
new file mode 100644
index 000000000000..c07d1254193c
--- /dev/null
+++ b/databases/cutelyst-asql/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= asql
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.19.0
+CATEGORIES= databases
+PKGNAMEPREFIX= cutelyst-
+
+MAINTAINER= adridg@FreeBSD.org
+COMMENT= Qt async SQL library (for Postgres)
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+# TODO: once there are multiple (selectable) backends, introduce
+# OPTIONS to toggle them, so we're not always depending on pgsql
+USES= cmake compiler:c++11-lang localbase pgsql qt:5
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+USE_QT= qmake_build buildtools_build \
+ core
+
+GH_ACCOUNT= cutelyst
+
+PLIST_SUB= SOVER=${DISTVERSION}
+
+.include <bsd.port.mk>
diff --git a/databases/cutelyst-asql/distinfo b/databases/cutelyst-asql/distinfo
new file mode 100644
index 000000000000..306db72eab41
--- /dev/null
+++ b/databases/cutelyst-asql/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1603716850
+SHA256 (cutelyst-asql-v0.19.0_GH0.tar.gz) = f514fbefeb17a7055ede68e545f935ecce7e7acd50e2a2115f3e7f6886eb0af7
+SIZE (cutelyst-asql-v0.19.0_GH0.tar.gz) = 28477
diff --git a/databases/cutelyst-asql/pkg-descr b/databases/cutelyst-asql/pkg-descr
new file mode 100644
index 000000000000..7018b4d5ea7b
--- /dev/null
+++ b/databases/cutelyst-asql/pkg-descr
@@ -0,0 +1,12 @@
+Qt Async Sql library
+
+* Thread local Connection pool
+* Scoped transactions objects
+* Navigate on your data with iterators
+* Prepared queries
+* Cancellable queries
+* Notifications
+
+Supports database migrations and queries both as JSON and QVariantHash.
+
+WWW: https://github.com/cutelyst/asql
diff --git a/databases/cutelyst-asql/pkg-plist b/databases/cutelyst-asql/pkg-plist
new file mode 100644
index 000000000000..834ae0044267
--- /dev/null
+++ b/databases/cutelyst-asql/pkg-plist
@@ -0,0 +1,18 @@
+bin/asql-migration
+include/asql-qt5/ASql/acache.h
+include/asql-qt5/ASql/adatabase.h
+include/asql-qt5/ASql/adriver.h
+include/asql-qt5/ASql/amigrations.h
+include/asql-qt5/ASql/apool.h
+include/asql-qt5/ASql/apreparedquery.h
+include/asql-qt5/ASql/aqsqlexports.h
+include/asql-qt5/ASql/aresult.h
+include/asql-qt5/ASql/atransaction.h
+lib/cmake/ASqlQt5/ASql0Qt5Targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/ASqlQt5/ASql0Qt5Targets.cmake
+lib/cmake/ASqlQt5/ASqlQt5Config.cmake
+lib/cmake/ASqlQt5/ASqlQt5ConfigVersion.cmake
+lib/libASqlQt5.so
+lib/libASqlQt5.so.0
+lib/libASqlQt5.so.%%SOVER%%
+libdata/pkgconfig/ASqlQt5.pc