aboutsummaryrefslogtreecommitdiff
path: root/databases/db5/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2018-08-02 16:05:16 +0000
committerMatthias Andree <mandree@FreeBSD.org>2018-08-02 16:05:16 +0000
commit105a8b5ab2a39e90e27e87da96d46bd629ca950f (patch)
treeeaad4568b319b0e7cf195e125754239a37583f01 /databases/db5/Makefile
parentf20b287af6701b3796516fa7aae5e0cd91992bc0 (diff)
downloadports-105a8b5ab2a39e90e27e87da96d46bd629ca950f.tar.gz
ports-105a8b5ab2a39e90e27e87da96d46bd629ca950f.zip
databases/db5, db6: enable DBM compatibility
Enable DBM API. [1] Reorder license information of db5/Makefile to fix portlint warning. [1] Bump PORTREVISON. [1] Add command creating symbolic link such as ${PREFIX}/lib/libdb-6.so to post-install target of db6/Makefile. [1] Instead of USE_GCC, patch src/dbinc/db.in to not expose the store() macro under C++. Mark db6 broken on MIPS64 for now, we do not have a workable MUTEX implementation. Unbreak build on AARCH64, where the db6 autoconfiguration chooses the wrong MUTEX. PR: 230191 Submitted by: Yasuhiro Kimura
Notes
Notes: svn path=/head/; revision=476241
Diffstat (limited to 'databases/db5/Makefile')
-rw-r--r--databases/db5/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/databases/db5/Makefile b/databases/db5/Makefile
index 04193f4842ab..1ebcc15dd841 100644
--- a/databases/db5/Makefile
+++ b/databases/db5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= db5
PORTVERSION= 5.3.28
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= databases java
MASTER_SITES= http://download.oracle.com/berkeley-db/
PKGNAMEPREFIX?=
@@ -16,14 +16,14 @@ MAINTAINER= mandree@FreeBSD.org
COMMENT= Oracle Berkeley DB, revision ${BDBVER}
LICENSE= SLEEPYCAT
+LICENSE_GROUPS= FSF GPL OSI
LICENSE_NAME= Sleepycat
-LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LICENSE_FILE= ${WRKSRC}/../LICENSE
-LICENSE_GROUPS= FSF GPL OSI
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BDBVER= ${PORTVERSION:R}
BDBMAJ= ${BDBVER:R}
-CONFIGURE_ARGS= --enable-cxx --enable-stl \
+CONFIGURE_ARGS= --enable-cxx --enable-stl --enable-dbm \
--enable-compat185 --enable-dump185 \
--includedir=${PREFIX}/include/${PORTNAME} \
--libdir=${PREFIX}/lib/${PORTNAME} \