aboutsummaryrefslogtreecommitdiff
path: root/databases/db5/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2016-05-24 21:26:12 +0000
committerMatthias Andree <mandree@FreeBSD.org>2016-05-24 21:26:12 +0000
commita59f1e5a96e7443958f3f56de0dacaacf86ba5f8 (patch)
treef3ad09d7bc5dd43aa924f6c914aa16922966ca5f /databases/db5/Makefile
parent9f0bacf50c50c38f2199470a5ee6eb02162d5e9f (diff)
downloadports-a59f1e5a96e7443958f3f56de0dacaacf86ba5f8.tar.gz
ports-a59f1e5a96e7443958f3f56de0dacaacf86ba5f8.zip
Notes
Diffstat (limited to 'databases/db5/Makefile')
-rw-r--r--databases/db5/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/databases/db5/Makefile b/databases/db5/Makefile
index c3cfebca4177..63cc87b417d8 100644
--- a/databases/db5/Makefile
+++ b/databases/db5/Makefile
@@ -32,8 +32,9 @@ PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
USE_LDCONFIG= yes
PLIST_SUB= BDBMAJ=${BDBMAJ} BDBVER=${BDBVER}
MAKE_ARGS+= docdir=${DOCSDIR}
+CFLAGS+= -Wall -Wextra
-OPTIONS_DEFINE= CRYPTO L10N SQL JAVA DOCS
+OPTIONS_DEFINE= CRYPTO L10N SQL JAVA DOCS TCL
# WARNING: DO NOT ADD TCL TO OPTIONS:
# On FreeBSD 10.3 this causes a heap of warnings of the following kind
# and is deemed unsafe.
@@ -60,10 +61,10 @@ JAVA_VARS= DBLIBS+=libdb_java JAVA_VERSION="1.6 1.7"
JAVA_CONFIGURE_ENABLE= java
JAVA_CPPFLAGS= -I"${JAVA_HOME}/include"
JAVA_CONFIGURE_ENV= JAVAC="${JAVAC}" JAR="${JAR}" JAVA="${JAVA}" JAVACFLAGS="-Xlint:unchecked"
-#TCL_CONFIGURE_ENABLE= tcl
-#TCL_USES= tcl:85+
-#TCL_CONFIGURE_WITH= tcl=${TCL_LIBDIR}
-#TCL_VARS= DBLIBS+=libdb_tcl
+TCL_CONFIGURE_ENABLE= tcl
+TCL_USES= tcl:85+
+TCL_CONFIGURE_WITH= tcl=${TCL_LIBDIR}
+TCL_VARS= DBLIBS+=libdb_tcl
DOCS_INSTALL_TARGET= install_docs
.include <bsd.port.options.mk>