aboutsummaryrefslogtreecommitdiff
path: root/databases/db5
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2016-10-07 18:47:35 +0000
committerMatthias Andree <mandree@FreeBSD.org>2016-10-07 18:47:35 +0000
commit4a54da758dce3a1fbadd860a03925a056d2d8a41 (patch)
treedb9ba0760cc5c475237bfd9f3e9e6995a6bf5fa8 /databases/db5
parent1832bf4af73774c18042de0be35a3c126aab0256 (diff)
downloadports-4a54da758dce3a1fbadd860a03925a056d2d8a41.tar.gz
ports-4a54da758dce3a1fbadd860a03925a056d2d8a41.zip
Clean up, modernize, add LICENSE.
The clean up drops an obsolete comment (overcome by a patch), drops the --disable-tcl that is overridden anyhow, and replaces a few .if empty(PORT_OPTIONS:Mfoo) by post-install-FOO-{on|off}: targets. This is to get the port closer to db6.
Notes
Notes: svn path=/head/; revision=423478
Diffstat (limited to 'databases/db5')
-rw-r--r--databases/db5/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/databases/db5/Makefile b/databases/db5/Makefile
index 63cc87b417d8..c4bafe99a598 100644
--- a/databases/db5/Makefile
+++ b/databases/db5/Makefile
@@ -15,11 +15,13 @@ DIST_SUBDIR= bdb
MAINTAINER= mandree@FreeBSD.org
COMMENT= Oracle Berkeley DB, revision ${BDBVER}
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/../LICENSE
+
BDBVER= ${PORTVERSION:R}
BDBMAJ= ${BDBVER:R}
CONFIGURE_ARGS= --enable-cxx --enable-stl \
--enable-compat185 --enable-dump185 \
- --disable-tcl \
--includedir=${PREFIX}/include/${PORTNAME} \
--libdir=${PREFIX}/lib/${PORTNAME} \
--bindir=${PREFIX}/bin/${PORTNAME}
@@ -34,11 +36,7 @@ PLIST_SUB= BDBMAJ=${BDBMAJ} BDBVER=${BDBVER}
MAKE_ARGS+= docdir=${DOCSDIR}
CFLAGS+= -Wall -Wextra
-OPTIONS_DEFINE= CRYPTO L10N SQL JAVA DOCS TCL
-# WARNING: DO NOT ADD TCL TO OPTIONS:
-# On FreeBSD 10.3 this causes a heap of warnings of the following kind
-# and is deemed unsafe.
-# ./lang/tcl/tcl_*.c:*:*: warning: the value of the size argument in 'strncat' is too large, might lead to a buffer overflow [-Wstrncat-size]
+OPTIONS_DEFINE= CRYPTO L10N SQL JAVA TCL DOCS
OPTIONS_DEFAULT=CRYPTO
OPTIONS_SUB= yes
CRYPTO_DESC= Cryptography support
@@ -91,23 +89,24 @@ post-install:
cd ${STAGEDIR}${PREFIX}/bin/${PORTNAME}; \
for i in *; do ${LN} -s -f ${PORTNAME}/$$i ../$$i-${BDBVER} ; \
${LN} -s -f ${PORTNAME}/$$i ../$$i-${BDBMAJ} ; done
-.if empty(PORT_OPTIONS:MJAVA)
+
+post-install-JAVA-off:
${RM} -r -f ${STAGEDIR}${DOCSDIR}/java
.for i in gsg gsg_db_rep gsg_txn
${RM} -r -f ${STAGEDIR}${DOCSDIR}/${i}/JAVA
.endfor
-.endif
-.if empty(PORT_OPTIONS:MSQL)
+
+post-install-SQL-off:
${RM} -r -f ${STAGEDIR}${DOCSDIR}/bdb-sql
-.endif
-.if !empty(PORT_OPTIONS:MTCL)
+
+post-install-TCL-on:
echo "package ifneeded Db_tcl ${BDBVER} \
[list load [file join $$dir libdb_tcl-${BDBVER}.so]] \
" > ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/pkgIndex.tcl
-.else
+
+post-install-TCL-off:
.for i in api_reference/TCL
${RM} -r -f ${STAGEDIR}${DOCSDIR}/${i}
.endfor
-.endif
.include <bsd.port.mk>