aboutsummaryrefslogtreecommitdiff
path: root/databases/dbtool
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2014-08-21 22:50:29 +0000
committerMatthias Andree <mandree@FreeBSD.org>2014-08-21 22:50:29 +0000
commitb50a4b0708948c5766fb92a70bfc082efa53857b (patch)
tree5f9e6219e9207f083ae5e2fff1302ed5967538ef /databases/dbtool
parent6724089b21de676c367bbc41cca5651958d1b0f3 (diff)
downloadports-b50a4b0708948c5766fb92a70bfc082efa53857b.tar.gz
ports-b50a4b0708948c5766fb92a70bfc082efa53857b.zip
Berkeley DB cleanup, remove versions 4.0 ... 4.7.
- Mk/bsd.database.mk rewrite, new default to db5. - db6 is eligible by default only if installed on the system. - Bump PORTREVISION of all ports that directly depend on BerkeleyDB or where USE_BDB is found in the port's directory - Patch a few ports such that they will pick up or work with newer versions. - Add UPDATING entry - Drive-by format fix for pks - Drop BerkeleyDB option from mail/popular for now, requires more work. - Exp-run logs linked from the PR below. - Ports that do not build (IGNORE, BROKEN, etc.) have pro-forma changes for new Berkeley DB, but are untested. NOTE: please read UPDATING and the Wiki page before proceeding! Announcement: http://lists.freebsd.org/pipermail/freebsd-ports-announce/2014-August/000090.html Wiki reference: https://wiki.freebsd.org/Ports/BerkeleyDBCleanup PR: 192690 Approved by: portmgr (implicit, PORTREVISION bump on unstaged ports)
Notes
Notes: svn path=/head/; revision=365599
Diffstat (limited to 'databases/dbtool')
-rw-r--r--databases/dbtool/Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/databases/dbtool/Makefile b/databases/dbtool/Makefile
index 097f47eecf80..780708267f04 100644
--- a/databases/dbtool/Makefile
+++ b/databases/dbtool/Makefile
@@ -14,11 +14,6 @@ LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
OPTIONS_DEFINE= BDB EXAMPLES
-BDB_LIB_DEPENDS= libdb3.so:${PORTSDIR}/databases/db3
-BDB_CPPFLAGS= -I${LOCALBASE}/include/db3
-BDB_CONFIGURE_ON= --with-berkeley
-BDB_LIB_DEPENDS_OFF= libgdbm.so:${PORTSDIR}/databases/gdbm
-
EXAMPLES_RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
LICENSE= GPLv2
@@ -35,17 +30,27 @@ UB2PFX= samples/locate/locate samples/locate/updatedb
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MBDB}
+USE_BDB= 48+
+CPPFLAGS+= -I${BDB_INCLUDE_DIR}
+LIBS+= -L${BDB_LIB_DIR} -l${BDB_LIB_NAME}
+CONFIGURE_ARGS+= --with-berkeley
+.else
+LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm
+CONFIGURE_ARGS+= --without-berkeley
+.endif
+
post-patch:
+ ${REINPLACE_CMD} -e 's,==,=,g' ${WRKSRC}/configure
.for file in dbtool.cc engine.cc engine.h
- @${REINPLACE_CMD} -e "s,stdin,input,g" ${WRKSRC}/${file}
+ ${REINPLACE_CMD} -e "s,stdin,input,g" ${WRKSRC}/${file}
.endfor
- @${REINPLACE_CMD} -e "s,==,=,g" ${WRKSRC}/configure
.if ${PORT_OPTIONS:MEXAMPLES}
.for file in ${SH2BASH}
- @${REINPLACE_CMD} -e "s|/bin/sh|${LOCALBASE}/bin/bash|" ${WRKSRC}/${file}
+ ${REINPLACE_CMD} -e "s|/bin/sh|${LOCALBASE}/bin/bash|" ${WRKSRC}/${file}
.endfor
.for file in ${UB2PFX}
- @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/${file}
+ ${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/${file}
@${RM} ${WRKSRC}/${file}.orig
@${RM} ${WRKSRC}/${file}~
.endfor
@@ -53,6 +58,6 @@ post-patch:
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @${CP} -Rp ${WRKSRC}/samples/* ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} -Rp ${WRKSRC}/samples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>