aboutsummaryrefslogtreecommitdiff
path: root/databases/dbview
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-06-06 16:59:26 +0000
committerSteve Price <steve@FreeBSD.org>1999-06-06 16:59:26 +0000
commit68ae0701fdb6f28e473ac6e84a4f38181d9e01ec (patch)
treeb597fe8625f6fe1c2a4440db243230cb96ce36ba /databases/dbview
parentf8c6ebf7e7b65bba6ddabf60c0586f035cc30c4f (diff)
downloadports-68ae0701fdb6f28e473ac6e84a4f38181d9e01ec.tar.gz
ports-68ae0701fdb6f28e473ac6e84a4f38181d9e01ec.zip
Initial import of dbview version 1.0.3.
A program for viewing dBase III files. PR: 11603 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Notes
Notes: svn path=/head/; revision=19251
Diffstat (limited to 'databases/dbview')
-rw-r--r--databases/dbview/Makefile32
-rw-r--r--databases/dbview/distinfo1
-rw-r--r--databases/dbview/files/patch-aa57
-rw-r--r--databases/dbview/pkg-comment1
-rw-r--r--databases/dbview/pkg-descr7
-rw-r--r--databases/dbview/pkg-plist4
6 files changed, 102 insertions, 0 deletions
diff --git a/databases/dbview/Makefile b/databases/dbview/Makefile
new file mode 100644
index 000000000000..e79d02fb9148
--- /dev/null
+++ b/databases/dbview/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: dbview
+# Version required: 1.0.3
+# Date created: 7 May 1999
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= dbview-1.0.3
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+ ftp://ftp.infodrom.north.de/pub/Linux/Devel/dbview/
+MASTER_SITE_SUBDIR= apps/database/proprietary
+
+MAINTAINER= andy@icc.surw.chel.su
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+MAN1= dbview.1
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/dbview ${PREFIX}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/dbview.1 ${PREFIX}/man/man1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/dbview
+ @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/dbview
+ @ ${INSTALL_DATA} ${WRKSRC}/dBASE ${PREFIX}/share/doc/dbview
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/dbview/distinfo b/databases/dbview/distinfo
new file mode 100644
index 000000000000..d30fabd12809
--- /dev/null
+++ b/databases/dbview/distinfo
@@ -0,0 +1 @@
+MD5 (dbview-1.0.3.tar.gz) = 75521f1f3eb461e27481a6098b5da777
diff --git a/databases/dbview/files/patch-aa b/databases/dbview/files/patch-aa
new file mode 100644
index 000000000000..5687d78e79dc
--- /dev/null
+++ b/databases/dbview/files/patch-aa
@@ -0,0 +1,57 @@
+--- Makefile Fri Sep 27 00:05:30 1996
++++ /home/andy/tmp/wrk/Makefile Fri May 7 09:48:58 1999
+@@ -18,8 +18,8 @@
+
+ MAN=man
+
+-CC= gcc
+-CFLAGS= -O6 -fomit-frame-pointer -Wall -pipe
++#CC= gcc
++#CFLAGS= -O6 -fomit-frame-pointer -Wall -pipe
+ # CFLAGS= -g -fomit-frame-pointer -Wall -pipe
+
+ # Look where your install program is
+@@ -32,15 +32,15 @@
+ obj = db_dump.o dbview.o version.o
+
+ .c.o:
+- $(CC) ${CFLAGS} -c $*.c
++ $(CC) ${CFLAGS} -I$(LOCALBASE)/include -c $*.c
+
+ all: dbview
+
+ dbview: $(obj)
+- $(CC) $(CFLAGS) -o dbview $(obj)
++ $(CC) $(CFLAGS) -o dbview $(obj) -L$(LOCALBASE)/lib -lgnugetopt
+
+ depend:
+- makedepend *.c
++ makedepend -I$(LOCALBASE)/include *.c
+
+ install: all
+ $(INSTALL) -d -o root -g root -m 755 $(bindir)
+@@ -56,13 +56,14 @@
+
+ # DO NOT DELETE
+
+-db_dump.o: db_dump.h /usr/include/fcntl.h /usr/include/features.h
+-db_dump.o: /usr/include/sys/cdefs.h /usr/include/sys/types.h
+-db_dump.o: /usr/include/linux/types.h /usr/include/asm/types.h
+-db_dump.o: /usr/include/gnu/types.h /usr/include/linux/fcntl.h
+-db_dump.o: /usr/include/sys/stat.h /usr/include/linux/stat.h
+-db_dump.o: /usr/include/stdio.h /usr/include/libio.h /usr/include/_G_config.h
+-db_dump.o: /usr/include/unistd.h /usr/include/posix_opt.h
+-db_dump.o: /usr/include/confname.h /usr/include/malloc.h
+-dbview.o: version.h db_dump.h /usr/include/stdio.h /usr/include/libio.h
+-dbview.o: /usr/include/_G_config.h /usr/include/getopt.h
++db_dump.o: db_dump.h /usr/include/fcntl.h /usr/include/sys/types.h
++db_dump.o: /usr/include/sys/cdefs.h /usr/include/sys/inttypes.h
++db_dump.o: /usr/include/machine/ansi.h /usr/include/machine/types.h
++db_dump.o: /usr/include/machine/endian.h /usr/include/sys/stat.h
++db_dump.o: /usr/include/sys/time.h /usr/include/time.h
++db_dump.o: /usr/include/sys/_posix.h /usr/include/stdio.h
++db_dump.o: /usr/include/unistd.h /usr/include/sys/unistd.h
++db_dump.o: /usr/include/malloc.h /usr/include/stdlib.h /usr/include/ctype.h
++db_dump.o: /usr/include/runetype.h /usr/include/string.h
++dbview.o: version.h db_dump.h /usr/include/stdio.h /usr/include/sys/cdefs.h
++dbview.o: /usr/include/machine/ansi.h /usr/local/include/getopt.h
diff --git a/databases/dbview/pkg-comment b/databases/dbview/pkg-comment
new file mode 100644
index 000000000000..d72b090da3b9
--- /dev/null
+++ b/databases/dbview/pkg-comment
@@ -0,0 +1 @@
+View dBase III files
diff --git a/databases/dbview/pkg-descr b/databases/dbview/pkg-descr
new file mode 100644
index 000000000000..edb843d00b59
--- /dev/null
+++ b/databases/dbview/pkg-descr
@@ -0,0 +1,7 @@
+A little tool that will display dBase III files. You can also use
+it to convert your old .dbf files for further use with Unix. It should
+also work with dBase IV files, but this is mostly untested.
+
+dbview displays the contents of a dBase III or IV database file. This is
+done by displaying both the name of the field itself and its value. At
+the end of every record a newline is appended.
diff --git a/databases/dbview/pkg-plist b/databases/dbview/pkg-plist
new file mode 100644
index 000000000000..5ab97abc3a66
--- /dev/null
+++ b/databases/dbview/pkg-plist
@@ -0,0 +1,4 @@
+bin/dbview
+share/doc/dbview/README
+share/doc/dbview/dBASE
+@dirrm share/doc/dbview