aboutsummaryrefslogtreecommitdiff
path: root/databases/elixir-postgrex
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2015-07-02 13:08:26 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2015-07-02 13:08:26 +0000
commit31179490c3dff71edc16dfd000574f3323a2986d (patch)
tree4ce3cf90c42bb1c321e45d1464b802146515e9fa /databases/elixir-postgrex
parent70d01c16e6f7fb7c8ff401947a95677934488f9e (diff)
downloadports-31179490c3dff71edc16dfd000574f3323a2986d.tar.gz
ports-31179490c3dff71edc16dfd000574f3323a2986d.zip
Notes
Diffstat (limited to 'databases/elixir-postgrex')
-rw-r--r--databases/elixir-postgrex/Makefile22
-rw-r--r--databases/elixir-postgrex/distinfo2
-rw-r--r--databases/elixir-postgrex/files/patch-mix.exs13
-rw-r--r--databases/elixir-postgrex/pkg-descr3
-rw-r--r--databases/elixir-postgrex/pkg-plist37
5 files changed, 77 insertions, 0 deletions
diff --git a/databases/elixir-postgrex/Makefile b/databases/elixir-postgrex/Makefile
new file mode 100644
index 000000000000..d63904ab972e
--- /dev/null
+++ b/databases/elixir-postgrex/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= postgrex
+PORTVERSION= 0.8.4
+DISTVERSIONPREFIX= v
+CATEGORIES= databases
+PKGNAMEPREFIX= elixir-
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Database driver for PostgreSQL written in Elixir
+
+LICENSE= APACHE20
+
+USE_GITHUB= yes
+GH_ACCOUNT= ericmj
+
+MIX_BUILD_NAME= shared
+MIX_BUILD_DEPS= devel/elixir-decimal
+MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
+
+.include "${PORTSDIR}/lang/elixir/bsd.elixir.mk"
+.include <bsd.port.mk>
diff --git a/databases/elixir-postgrex/distinfo b/databases/elixir-postgrex/distinfo
new file mode 100644
index 000000000000..3cce1a19d0c9
--- /dev/null
+++ b/databases/elixir-postgrex/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ericmj-postgrex-v0.8.4_GH0.tar.gz) = fd7348323c303ddde8d047ecdf77615e3957ba269260434359499cf59dcf6561
+SIZE (ericmj-postgrex-v0.8.4_GH0.tar.gz) = 37961
diff --git a/databases/elixir-postgrex/files/patch-mix.exs b/databases/elixir-postgrex/files/patch-mix.exs
new file mode 100644
index 000000000000..4a3d54a7ac51
--- /dev/null
+++ b/databases/elixir-postgrex/files/patch-mix.exs
@@ -0,0 +1,13 @@
+--- mix.exs.orig 2015-07-02 10:57:08 UTC
++++ mix.exs
+@@ -23,9 +23,7 @@ defmodule Postgrex.Mixfile do
+ end
+
+ defp deps do
+- [{:ex_doc, only: :dev},
+- {:earmark, only: :dev},
+- {:decimal, "~> 1.0"}]
++ []
+ end
+
+ defp description do
diff --git a/databases/elixir-postgrex/pkg-descr b/databases/elixir-postgrex/pkg-descr
new file mode 100644
index 000000000000..4e86625d9e16
--- /dev/null
+++ b/databases/elixir-postgrex/pkg-descr
@@ -0,0 +1,3 @@
+A database driver for PostgreSQL written in pure Elixir.
+
+WWW: https://github.com/ericmj/postgrex
diff --git a/databases/elixir-postgrex/pkg-plist b/databases/elixir-postgrex/pkg-plist
new file mode 100644
index 000000000000..c6ccc85836c8
--- /dev/null
+++ b/databases/elixir-postgrex/pkg-plist
@@ -0,0 +1,37 @@
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.BinaryUtils.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.Connection.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.Date.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.Error.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.ErrorCode.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.Extension.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.Extensions.Binary.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.Extensions.JSON.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.Extensions.Text.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.Interval.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.Messages.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.Protocol.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.Range.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.Result.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.Time.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.Timestamp.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.TypeInfo.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.Types.beam
+lib/elixir/lib/postgrex/ebin/Elixir.Postgrex.Utils.beam
+lib/elixir/lib/postgrex/ebin/postgrex.app
+lib/elixir/lib/postgrex/lib/postgrex/binary_utils.ex
+lib/elixir/lib/postgrex/lib/postgrex/builtins.ex
+lib/elixir/lib/postgrex/lib/postgrex/connection.ex
+lib/elixir/lib/postgrex/lib/postgrex/errcodes.txt
+lib/elixir/lib/postgrex/lib/postgrex/error.ex
+lib/elixir/lib/postgrex/lib/postgrex/error_code.ex
+lib/elixir/lib/postgrex/lib/postgrex/extension.ex
+lib/elixir/lib/postgrex/lib/postgrex/extensions/binary.ex
+lib/elixir/lib/postgrex/lib/postgrex/extensions/json.ex
+lib/elixir/lib/postgrex/lib/postgrex/extensions/text.ex
+lib/elixir/lib/postgrex/lib/postgrex/messages.ex
+lib/elixir/lib/postgrex/lib/postgrex/protocol.ex
+lib/elixir/lib/postgrex/lib/postgrex/result.ex
+lib/elixir/lib/postgrex/lib/postgrex/type_info.ex
+lib/elixir/lib/postgrex/lib/postgrex/types.ex
+lib/elixir/lib/postgrex/lib/postgrex/utils.ex
+%%PORTDOCS%%%%DOCSDIR%%/README.md