aboutsummaryrefslogtreecommitdiff
path: root/databases/erlfdb
diff options
context:
space:
mode:
authorDave Cottlehuber <dch@FreeBSD.org>2020-01-28 08:22:52 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2020-01-28 08:22:52 +0000
commit758912c2e7fd036cc6863bae0398a532bf451b33 (patch)
treea94d94c5df0a7650d964458f6c733420d91b552d /databases/erlfdb
parent63880e7b3380d914cd027625f1d23148149592c3 (diff)
downloadports-758912c2e7fd036cc6863bae0398a532bf451b33.tar.gz
ports-758912c2e7fd036cc6863bae0398a532bf451b33.zip
databases/erlfdb: add new port
Native erlang NIF bindings to the FoundationDB C API, giving you distributed ACID transactions. Includes tuple and document layer support. Sponsored by: SkunkWerks, GmbH Differential Revision: https://reviews.freebsd.org/D23292
Notes
Notes: svn path=/head/; revision=524464
Diffstat (limited to 'databases/erlfdb')
-rw-r--r--databases/erlfdb/Makefile27
-rw-r--r--databases/erlfdb/distinfo3
-rw-r--r--databases/erlfdb/files/patch-rebar.config18
-rw-r--r--databases/erlfdb/files/patch-src_erlfdb__util.erl10
-rw-r--r--databases/erlfdb/pkg-descr5
-rw-r--r--databases/erlfdb/pkg-plist23
6 files changed, 86 insertions, 0 deletions
diff --git a/databases/erlfdb/Makefile b/databases/erlfdb/Makefile
new file mode 100644
index 000000000000..d56ca01a01ce
--- /dev/null
+++ b/databases/erlfdb/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= erlfdb
+PORTVERSION= 0.0.0
+CATEGORIES= databases
+
+MAINTAINER= dch@FreeBSD.org
+COMMENT= FoundationDB client in Erlang
+
+LICENSE= APACHE20
+
+LIB_DEPENDS= libfdb_c.so:databases/foundationdb-devel
+RUN_DEPENDS= erlang-runtime21>=0:lang/erlang-runtime21
+
+USES= erlang:rebar
+USE_GITHUB= yes
+GH_ACCOUNT= cloudant-labs
+GH_PROJECT= couchdb-${PORTNAME}
+GH_TAGNAME= c89b2d6
+
+MAKE_ENV= PATH=${LOCALBASE}/lib/erlang21/bin:${PATH}
+
+post-install:
+ @${FIND} -E ${STAGEDIR} -type f -name *.so \
+ -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>
diff --git a/databases/erlfdb/distinfo b/databases/erlfdb/distinfo
new file mode 100644
index 000000000000..ccf9d11c4c39
--- /dev/null
+++ b/databases/erlfdb/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1579559156
+SHA256 (cloudant-labs-couchdb-erlfdb-0.0.0-c89b2d6_GH0.tar.gz) = e81a9e686060f9c0e638e623e3c2d5efd9451be9b6c54948745d83a6998e1dbd
+SIZE (cloudant-labs-couchdb-erlfdb-0.0.0-c89b2d6_GH0.tar.gz) = 68922
diff --git a/databases/erlfdb/files/patch-rebar.config b/databases/erlfdb/files/patch-rebar.config
new file mode 100644
index 000000000000..ab59c3dba6aa
--- /dev/null
+++ b/databases/erlfdb/files/patch-rebar.config
@@ -0,0 +1,18 @@
+--- rebar.config.orig 2020-01-20 22:26:46 UTC
++++ rebar.config
+@@ -6,12 +6,12 @@
+
+ {port_env, [
+ {"(linux|solaris|freebsd|netbsd|openbsd|dragonfly|darwin|gnu)",
+- "CFLAGS", "$CFLAGS -Ic_src/ -g -Wall -Werror"},
++ "CFLAGS", "$CFLAGS -Ic_src/ -I /usr/local/include -g -Wall -Werror"},
+ {"(linux|solaris|freebsd|netbsd|openbsd|dragonfly|darwin|gnu)",
+- "CXXFLAGS", "$CXXFLAGS -Ic_src/ -g -Wall -Werror"},
++ "CXXFLAGS", "$CXXFLAGS -Ic_src/ -I /usr/local/include -g -Wall -Werror"},
+
+ {"(linux|solaris|freebsd|netbsd|openbsd|dragonfly|darwin|gnu)",
+- "LDFLAGS", "$LDFLAGS -lfdb_c"}
++ "LDFLAGS", "$LDFLAGS -lfdb_c -L /usr/local/lib"}
+ ]}.
+
+ {eunit_opts, [
diff --git a/databases/erlfdb/files/patch-src_erlfdb__util.erl b/databases/erlfdb/files/patch-src_erlfdb__util.erl
new file mode 100644
index 000000000000..cd300b68ef87
--- /dev/null
+++ b/databases/erlfdb/files/patch-src_erlfdb__util.erl
@@ -0,0 +1,10 @@
+--- src/erlfdb_util.erl.orig 2020-01-20 22:27:20 UTC
++++ src/erlfdb_util.erl
+@@ -177,6 +177,7 @@ find_fdbserver_bin(Options) ->
+ undefined ->
+ [
+ <<"/usr/sbin/fdbserver">>,
++ <<"/usr/local/bin/fdbserver">>,
+ <<"/usr/local/sbin/fdbserver">>,
+ <<"/usr/local/libexec/fdbserver">>
+ ];
diff --git a/databases/erlfdb/pkg-descr b/databases/erlfdb/pkg-descr
new file mode 100644
index 000000000000..73585f25c417
--- /dev/null
+++ b/databases/erlfdb/pkg-descr
@@ -0,0 +1,5 @@
+FoundationDB native Erlang bindings, a NIF wrapper for the FoundationDB
+C API, this project also provides a conforming implementation of the
+Tuple and Directory layers.
+
+WWW: https://github.com/cloudant-labs/couchdb-erlfdb
diff --git a/databases/erlfdb/pkg-plist b/databases/erlfdb/pkg-plist
new file mode 100644
index 000000000000..913c737f66c4
--- /dev/null
+++ b/databases/erlfdb/pkg-plist
@@ -0,0 +1,23 @@
+lib/erlang/lib/erlfdb-%%VERSION%%/ebin/erlfdb.app
+lib/erlang/lib/erlfdb-%%VERSION%%/ebin/erlfdb.beam
+lib/erlang/lib/erlfdb-%%VERSION%%/ebin/erlfdb_directory.beam
+lib/erlang/lib/erlfdb-%%VERSION%%/ebin/erlfdb_float.beam
+lib/erlang/lib/erlfdb-%%VERSION%%/ebin/erlfdb_hca.beam
+lib/erlang/lib/erlfdb-%%VERSION%%/ebin/erlfdb_key.beam
+lib/erlang/lib/erlfdb-%%VERSION%%/ebin/erlfdb_nif.beam
+lib/erlang/lib/erlfdb-%%VERSION%%/ebin/erlfdb_subspace.beam
+lib/erlang/lib/erlfdb-%%VERSION%%/ebin/erlfdb_tuple.beam
+lib/erlang/lib/erlfdb-%%VERSION%%/ebin/erlfdb_util.beam
+lib/erlang/lib/erlfdb-%%VERSION%%/include/erlfdb.hrl
+lib/erlang/lib/erlfdb-%%VERSION%%/priv/erlfdb_nif.so
+lib/erlang/lib/erlfdb-%%VERSION%%/priv/monitor.py
+lib/erlang/lib/erlfdb-%%VERSION%%/src/erlfdb.app.src
+lib/erlang/lib/erlfdb-%%VERSION%%/src/erlfdb.erl
+lib/erlang/lib/erlfdb-%%VERSION%%/src/erlfdb_directory.erl
+lib/erlang/lib/erlfdb-%%VERSION%%/src/erlfdb_float.erl
+lib/erlang/lib/erlfdb-%%VERSION%%/src/erlfdb_hca.erl
+lib/erlang/lib/erlfdb-%%VERSION%%/src/erlfdb_key.erl
+lib/erlang/lib/erlfdb-%%VERSION%%/src/erlfdb_nif.erl
+lib/erlang/lib/erlfdb-%%VERSION%%/src/erlfdb_subspace.erl
+lib/erlang/lib/erlfdb-%%VERSION%%/src/erlfdb_tuple.erl
+lib/erlang/lib/erlfdb-%%VERSION%%/src/erlfdb_util.erl