aboutsummaryrefslogtreecommitdiff
path: root/databases/fastdb/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-07 23:54:51 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-07 23:54:51 +0000
commit47e96a4d38456a6606ca1068e7141477966b9fd6 (patch)
treef3437eb55b262584fd8bcd81720f9cdd7ebb50fd /databases/fastdb/Makefile
parent26f5e61764502357edcceaf32c870c0d7681c780 (diff)
downloadports-47e96a4d38456a6606ca1068e7141477966b9fd6.tar.gz
ports-47e96a4d38456a6606ca1068e7141477966b9fd6.zip
Notes
Diffstat (limited to 'databases/fastdb/Makefile')
-rw-r--r--databases/fastdb/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/databases/fastdb/Makefile b/databases/fastdb/Makefile
index 4226a9437890..672d0d33ea7c 100644
--- a/databases/fastdb/Makefile
+++ b/databases/fastdb/Makefile
@@ -11,23 +11,21 @@ COMMENT= Main Memory Relational Database Management System
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_GMAKE= yes
+OPTIONS_DEFINE= DOCS
+
+USES= gmake dos2unix
+USE_GCC= any
MAKE_ENV= OSTYPE="${OPSYS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKEFILE= makefile
USE_LDCONFIG= yes
-USE_DOS2UNIX= ${MAKEFILE}
+DOS2UNIX_FILES= ${MAKEFILE}
PORTDOCS= FastDB.htm
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/FastDB.htm ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/FastDB.htm ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>