aboutsummaryrefslogtreecommitdiff
path: root/databases/fastdb/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-08-18 12:25:30 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-08-18 12:25:30 +0000
commit7f96118e09aa4bffa1663e575e1a4638e9a48b31 (patch)
tree799d291fa779c875e6eb52f445685bd729298cfd /databases/fastdb/Makefile
parent46c66481397d5bc47d1c94b22505de3e5ea92197 (diff)
downloadports-7f96118e09aa4bffa1663e575e1a4638e9a48b31.tar.gz
ports-7f96118e09aa4bffa1663e575e1a4638e9a48b31.zip
Explicitly pass -std=gnu++03 to the compiler.
This fixes the build with GCC 6, which defaults to -std=gnu++14. The port's code does not work with C++11 or later. PR: 219275
Notes
Notes: svn path=/head/; revision=448222
Diffstat (limited to 'databases/fastdb/Makefile')
-rw-r--r--databases/fastdb/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/databases/fastdb/Makefile b/databases/fastdb/Makefile
index 07d671c8e570..aac248ea930e 100644
--- a/databases/fastdb/Makefile
+++ b/databases/fastdb/Makefile
@@ -25,6 +25,9 @@ DOS2UNIX_FILES= ${MAKEFILE}
PORTDOCS= FastDB.htm
+# The port does not build with C++11 or later (bug 219275).
+USE_CXXSTD= gnu++03
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/FastDB.htm ${STAGEDIR}${DOCSDIR}