aboutsummaryrefslogtreecommitdiff
path: root/databases/firebird25-server
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-11-11 08:53:08 +0000
committerJohn Marino <marino@FreeBSD.org>2015-11-11 08:53:08 +0000
commit34502a32ff95b93393cfdfd60a3af62fdc52a989 (patch)
tree0b13c242c4d50eb8077ba9cbf079548d61e8b8cc /databases/firebird25-server
parent96ba52b78443c6c233a6386470882eac9a14714e (diff)
downloadports-34502a32ff95b93393cfdfd60a3af62fdc52a989.tar.gz
ports-34502a32ff95b93393cfdfd60a3af62fdc52a989.zip
databases/firebird25-(client|server): convert to USES=libedit
The -server port had to be bumped because libedit was listed as a BUILD_DEPENDS but libedit is linked dynamically so it has to be a LIB_DEPENDS. The error was masked by the fact the client is usually present which ensures libedit.so is available. While here, remove obsolete CONFLICT* definitions and unmask a bunch of installation commands.
Notes
Notes: svn path=/head/; revision=401229
Diffstat (limited to 'databases/firebird25-server')
-rw-r--r--databases/firebird25-server/Makefile22
1 files changed, 7 insertions, 15 deletions
diff --git a/databases/firebird25-server/Makefile b/databases/firebird25-server/Makefile
index b595dfba199b..edf8d3b20595 100644
--- a/databases/firebird25-server/Makefile
+++ b/databases/firebird25-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= firebird
PORTVERSION= 2.5.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= databases
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:S/.0//}-Release/
PKGNAMESUFFIX?= ${PORTVERSION:R:S/.//}-server
@@ -22,14 +22,9 @@ LICENSE_FILE_IPL= ${WRKSRC}/builds/install/misc/IPLicense.txt
LICENSE_PERMS_IDPL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LICENSE_PERMS_IPL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-CONFLICTS?= ${PORTNAME}20-client-* \
- ${PORTNAME}21-client-* \
- ${PORTNAME}20-server-* \
- ${PORTNAME}21-server-*
-
LIB_DEPENDS= libicuuc.so:${PORTSDIR}/devel/icu
-USES= gmake pkgconfig tar:bzip2
+USES= gmake libedit pkgconfig tar:bzip2
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
@@ -79,7 +74,6 @@ IGNORE= your system does not support sysvipc
.if !defined(CLIENT_ONLY)
# Server part stuff
-BUILD_DEPENDS= ${LOCALBASE}/lib/libedit.so:${PORTSDIR}/devel/libedit
LIB_DEPENDS+= libfbembed.so:${PORTSDIR}/databases/firebird25-client
CONFIGURE_ARGS+=--enable-superserver
@@ -98,8 +92,6 @@ UDF_SQL= src/extlib/ib_udf2.sql src/extlib/fbudf/fbudf.sql
PKGINSTALL?= ${PKGDIR}/pkg-install-server
.else
# Client part stuff
-LIB_DEPENDS+= libedit.so.0:${PORTSDIR}/devel/libedit
-
ALL_TARGET= firebird_basic libfbembed libfbclient embed_isql embed_gpre \
embed_gdef embed_qli extlib
@@ -211,11 +203,11 @@ do-install:
post-install-DOCS-on:
@${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
@${MKDIR} ${FB_DOCS_DIRS:S!^!${STAGEDIR}${DOCSDIR}/!}
- @${INSTALL_DATA} ${FB_DOCS_FILES:S!^!${WRKSRC}/doc/!} ${STAGEDIR}${DOCSDIR}
- @${LN} -sf ${DOCSDIR}/README.user ${STAGEDIR}${DOCSDIR}/README
- @${INSTALL_DATA} ${WRKSRC}/doc/sql.extensions/* ${STAGEDIR}${DOCSDIR}/sql.extensions
- @${INSTALL_DATA} ${WRKSRC}/doc/license/* ${STAGEDIR}${DOCSDIR}/license
- @${INSTALL_DATA} ${WRKSRC}/src/misc/upgrade/v2/* ${STAGEDIR}${DOCSDIR}/upgrade
+ ${INSTALL_DATA} ${FB_DOCS_FILES:S!^!${WRKSRC}/doc/!} ${STAGEDIR}${DOCSDIR}
+ ${LN} -sf ${DOCSDIR}/README.user ${STAGEDIR}${DOCSDIR}/README
+ ${INSTALL_DATA} ${WRKSRC}/doc/sql.extensions/* ${STAGEDIR}${DOCSDIR}/sql.extensions
+ ${INSTALL_DATA} ${WRKSRC}/doc/license/* ${STAGEDIR}${DOCSDIR}/license
+ ${INSTALL_DATA} ${WRKSRC}/src/misc/upgrade/v2/* ${STAGEDIR}${DOCSDIR}/upgrade
.endif
.include <bsd.port.post.mk>