aboutsummaryrefslogtreecommitdiff
path: root/databases/firebird25-server
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2015-11-11 21:04:37 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2015-11-11 21:04:37 +0000
commitb4a7359c340c4ed72e2bcb0822d8e9398457cb88 (patch)
tree194c9493317711e091010dd247e11ec56a6f8461 /databases/firebird25-server
parenta2acb92cae517b447ff123e67a4a4bcd5c06ebfd (diff)
downloadports-b4a7359c340c4ed72e2bcb0822d8e9398457cb88.tar.gz
ports-b4a7359c340c4ed72e2bcb0822d8e9398457cb88.zip
Fix dependencies again since r401229 partially reverted r398897, which was
my attempt to remove redundant libedit.so from dependencies for server. However, it was incomplete because BUILD_DEPENDS was left for configure. Now firebird25-server does not directly require devel/libedit any more.
Notes
Notes: svn path=/head/; revision=401297
Diffstat (limited to 'databases/firebird25-server')
-rw-r--r--databases/firebird25-server/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/databases/firebird25-server/Makefile b/databases/firebird25-server/Makefile
index edf8d3b20595..46f270e0fb2b 100644
--- a/databases/firebird25-server/Makefile
+++ b/databases/firebird25-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= firebird
PORTVERSION= 2.5.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= databases
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:S/.0//}-Release/
PKGNAMESUFFIX?= ${PORTVERSION:R:S/.//}-server
@@ -24,12 +24,11 @@ LICENSE_PERMS_IPL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libicuuc.so:${PORTSDIR}/devel/icu
-USES= gmake libedit pkgconfig tar:bzip2
+USES= gmake pkgconfig tar:bzip2
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
-CONFIGURE_ARGS= --with-system-editline \
- --with-system-icu \
+CONFIGURE_ARGS= --with-system-icu \
--prefix=${LOCALSTATEDIR} \
--exec-prefix=${PREFIX} \
--with-fbconf=${PREFIX}/${CONFDIR} \
@@ -44,8 +43,7 @@ CONFIGURE_ARGS= --with-system-editline \
--with-fbudf=${LIBEXECDIR}/UDF
CONFIGURE_ENV+= PTHREAD_LIBS="-lpthread" \
ac_cv_header_atomic_ops_h="no" \
- ac_cv_lib_atomic_ops_main="no" \
- ac_cv_lib_edit_readline="yes"
+ ac_cv_lib_atomic_ops_main="no"
LOCALSTATEDIR= /var/db/firebird
CONFDIR= etc/firebird
@@ -76,7 +74,7 @@ IGNORE= your system does not support sysvipc
# Server part stuff
LIB_DEPENDS+= libfbembed.so:${PORTSDIR}/databases/firebird25-client
-CONFIGURE_ARGS+=--enable-superserver
+CONFIGURE_ARGS+=--enable-superserver --without-editline
ALL_TARGET= firebird_embedded firebird_server
@@ -92,6 +90,11 @@ UDF_SQL= src/extlib/ib_udf2.sql src/extlib/fbudf/fbudf.sql
PKGINSTALL?= ${PKGDIR}/pkg-install-server
.else
# Client part stuff
+LIB_DEPENDS+= libedit.so.0:${PORTSDIR}/devel/libedit
+
+CONFIGURE_ARGS+= --with-system-editline
+CONFIGURE_ENV+= ac_cv_lib_edit_readline="yes"
+
ALL_TARGET= firebird_basic libfbembed libfbclient embed_isql embed_gpre \
embed_gdef embed_qli extlib