aboutsummaryrefslogtreecommitdiff
path: root/databases/fortytwo-bdb
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-04-09 07:44:41 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-04-09 07:44:41 +0000
commit06f79b66f2eb028c4ab81977dcb1e010ef9cf946 (patch)
treeb7aed86ac84412d11603ce23b7893d46f0d7475b /databases/fortytwo-bdb
parent5c3f57fd49a53ee36e7a7bc6263e4dd1fd331c27 (diff)
downloadports-06f79b66f2eb028c4ab81977dcb1e010ef9cf946.tar.gz
ports-06f79b66f2eb028c4ab81977dcb1e010ef9cf946.zip
Convert bsd.gnustep.mk to USES=gnustep
Simplify gnustep ports Hook into the regular ports framework: - LIB_DEPENDS for library dependencies - Use regular USE_LDCONFIG Reuse USES=objc (automatic) USE_GNUSTEP is now a macro to set the dependencies and build feature needed. Accepted arguments: back base build gui Merge deskutils/preferencepanes into deskutils/systempreferences
Notes
Notes: svn path=/head/; revision=383626
Diffstat (limited to 'databases/fortytwo-bdb')
-rw-r--r--databases/fortytwo-bdb/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/databases/fortytwo-bdb/Makefile b/databases/fortytwo-bdb/Makefile
index 7923cd9cdb16..58989777eb68 100644
--- a/databases/fortytwo-bdb/Makefile
+++ b/databases/fortytwo-bdb/Makefile
@@ -14,22 +14,19 @@ COMMENT= Interface to Berkeley DB for GNUstep
LICENSE= LGPL21
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LOCAL_LIBS+= Encore:${ENCORE_PORT}
+USES= gnustep
+USE_GNUSTEP= back build
+
+LIB_DEPENDS= libEncore.so:${PORTSDIR}/devel/fortytwo-encore
DEFAULT_LIBVERSION= 0.1
-USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
+USE_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
USE_BDB= 43+
WRKSRC= ${WRKDIR}/BDB-${PORTVERSION}
DOCSDIR= ${GNUSTEP_PREFIX}/Local/Library/Documentation/BDB
-ADDITIONAL_OBJCFLAGS+= -I${BDB_INCLUDE_DIR}
+ADDITIONAL_OBJCFLAGS+= -I${BDB_INCLUDE_DIR} -I${GNUSTEP_PREFIX}/
ADDITIONAL_LDFLAGS+= -L${BDB_LIB_DIR}
-ENCORE_PORT?= devel/fortytwo-encore
-
OPTIONS_DEFINE= DOCS
post-install: