aboutsummaryrefslogtreecommitdiff
path: root/databases/fpc-odbc/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-16 00:49:36 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-16 00:49:36 +0000
commit3d90109deac69888eda897fe8492c901179055f4 (patch)
tree4a2f92090888ed15d9bd18edf30ef45d23608491 /databases/fpc-odbc/Makefile
parentaa99c82619e87b9d3d6a0475b3a5542157561fad (diff)
downloadports-3d90109deac69888eda897fe8492c901179055f4.tar.gz
ports-3d90109deac69888eda897fe8492c901179055f4.zip
Notes
Diffstat (limited to 'databases/fpc-odbc/Makefile')
-rw-r--r--databases/fpc-odbc/Makefile77
1 files changed, 77 insertions, 0 deletions
diff --git a/databases/fpc-odbc/Makefile b/databases/fpc-odbc/Makefile
new file mode 100644
index 000000000000..0cd5815e9c30
--- /dev/null
+++ b/databases/fpc-odbc/Makefile
@@ -0,0 +1,77 @@
+# New ports collection makefile for: Free Pascal Compiler
+# Date created: 8 January 2004
+# Whom: John Merryweather Cooper
+#
+# $FreeBSD$
+#
+
+PORTNAME= odbc
+PORTVERSION= 1.0.10
+CATEGORIES= databases
+MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ http://planetmirror.com/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.jp.freepascal.org/mirror/fpc/dist/FreeBSD/ \
+ ftp://freepascal.stack.nl/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.no.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.us.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= freepascal
+PKGNAMEPREFIX= fpc-
+DISTNAME= fpc-${PORTVERSION}.ELF
+EXTRACT_SUFX= .tar
+
+MAINTAINER= coop9211@uidaho.edu
+COMMENT= Free Pascal interface to ODBC
+
+.include <bsd.port.pre.mk>
+
+LIB_DEPENDS= odbc.1:${PORTSDIR}/databases/unixODBC
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.if ${OSVERSION} >= 500000
+LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
+.endif
+.if ${OSVERSION} < 470000
+EXTRACT_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
+TAR= ${LOCALBASE}/bin/gtar
+.endif
+USE_GMAKE= yes
+USE_REINPLACE= yes
+ONLY_FOR_ARCHS= i386
+
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+MAKE_ENV+= PATH=${LOCALBASE}/bin:$$PATH \
+ FPC=${LOCALBASE}/bin/ppc386 \
+ INSTALL_BASEDIR=${PREFIX}/lib/fpc/${PORTVERSION} \
+ INSTALL_BINDIR=${PREFIX}/bin \
+ GCCLIBDIR=/usr/lib \
+ RELEASE=1
+
+do-extract:
+# unpack distribution
+ @${MKDIR} ${WRKSRC}
+ @${TAR} xf ${DISTDIR}/${DISTNAME}.tar --directory ${WRKSRC}
+# unpack sources distribution
+ @${MKDIR} ${WRKSRC}/sources
+ @${TAR} xf ${WRKSRC}/sources.tar --directory ${WRKSRC}/sources
+# further extract base sources
+#
+# odbc sources
+ @${TAR} zxf ${WRKSRC}/sources/unitsodbcsrc.tar.gz \
+ --directory ${WRKSRC}
+
+post-patch:
+# change to alter amount of optimization
+ @${FIND} ${WRKSRC}/share/src/fpc-${PORTVERSION} -name \
+ "Makefile*" | ${XARGS} ${REINPLACE_CMD} 's|-OG2p3|-OG2p1|g'
+
+do-build:
+ cd ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/odbc && \
+ ${GMAKE} ${MAKE_ENV} all
+
+do-install:
+ cd ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/odbc && \
+ ${GMAKE} ${MAKE_ENV} install
+
+.include <bsd.port.post.mk>