aboutsummaryrefslogtreecommitdiff
path: root/databases/frontbase-jdbc
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-06-13 04:25:26 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-06-13 04:25:26 +0000
commit5ebd7f32c87986a43f9a095607336473e92ac294 (patch)
tree37ad1be95a6de3724ec63837e5a4b1f8f9bc8770 /databases/frontbase-jdbc
parentc8993663c028fbc4aee60d10dc1139194fc8f4e9 (diff)
downloadports-5ebd7f32c87986a43f9a095607336473e92ac294.tar.gz
ports-5ebd7f32c87986a43f9a095607336473e92ac294.zip
[NEW PORTS] www/webobjects(+) Apple WebObjects ports bundle
This is a bundle of several ports covering many typical requirements for building an Apple WebObjects deployment environment. Each port is or has a dependancy with some other port in the bundle, and have therefore been lodged collectively. databases/frontbase-jdbc: This is the official implementation of JDBC, the Java Database Connectivity API, for accessing FrontBase databases from Java. WWW: http://www.frontbase.com/ PR: ports/117299 Submitted by: Quinton Dolan <q@onthenet.com.au>
Notes
Notes: svn path=/head/; revision=214746
Diffstat (limited to 'databases/frontbase-jdbc')
-rw-r--r--databases/frontbase-jdbc/Makefile37
-rw-r--r--databases/frontbase-jdbc/distinfo3
-rw-r--r--databases/frontbase-jdbc/files/pkg-message.in7
-rw-r--r--databases/frontbase-jdbc/pkg-descr4
4 files changed, 51 insertions, 0 deletions
diff --git a/databases/frontbase-jdbc/Makefile b/databases/frontbase-jdbc/Makefile
new file mode 100644
index 000000000000..9b69850c3ea2
--- /dev/null
+++ b/databases/frontbase-jdbc/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: frontbase-jdbc
+# Date created: Mon Apr 16 07:07:22 EST 2007
+# Whom: Quinton Dolan <q@onthenet.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= frontbase
+PORTVERSION= 2.5.6
+CATEGORIES= databases java
+MASTER_SITES+= http://www.frontbase.com/download/JDBC/
+PKGNAMESUFFIX= -jdbc
+DISTNAME= FrontBaseJDBC-${PORTVERSION}
+EXTRACT_SUFX= .tar
+
+MAINTAINER?= q@onthenet.com.au
+COMMENT= The Java JDBC implementation for FrontBase
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+
+NO_BUILD= yes
+JARFILE= frontbasejdbc.jar
+PLIST_FILES= %%JAVAJARDIR%%/${JARFILE}
+
+SUB_FILES+= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/${JARFILE} ${JAVAJARDIR}/${JARFILE}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/databases/frontbase-jdbc/distinfo b/databases/frontbase-jdbc/distinfo
new file mode 100644
index 000000000000..5671430ff591
--- /dev/null
+++ b/databases/frontbase-jdbc/distinfo
@@ -0,0 +1,3 @@
+MD5 (FrontBaseJDBC-2.5.6.tar) = 8e9c798a1029f0bf88f8d4f69ac092c8
+SHA256 (FrontBaseJDBC-2.5.6.tar) = 823cdb6951b70f9d1a8efd05fd281d5f87572f44fbcb844c53dc77c96fe289f3
+SIZE (FrontBaseJDBC-2.5.6.tar) = 542720
diff --git a/databases/frontbase-jdbc/files/pkg-message.in b/databases/frontbase-jdbc/files/pkg-message.in
new file mode 100644
index 000000000000..0b41043f102c
--- /dev/null
+++ b/databases/frontbase-jdbc/files/pkg-message.in
@@ -0,0 +1,7 @@
+
+FrontBase JDBC support installed!
+
+frontbasejdbc.jar resides in
+%%JAVAJARDIR%%/frontbasejdbc.jar
+Add this to your CLASSPATH!
+
diff --git a/databases/frontbase-jdbc/pkg-descr b/databases/frontbase-jdbc/pkg-descr
new file mode 100644
index 000000000000..105c396e58cd
--- /dev/null
+++ b/databases/frontbase-jdbc/pkg-descr
@@ -0,0 +1,4 @@
+This is the official implementation of JDBC, the Java Database
+Connectivity API, for accessing FrontBase databases from Java.
+
+WWW: http://www.frontbase.com/