aboutsummaryrefslogtreecommitdiff
path: root/databases/galera
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2017-06-07 08:43:26 +0000
committerVasil Dimov <vd@FreeBSD.org>2017-06-07 08:43:26 +0000
commit2ec0579d59e528340a89297aef6879a30e2cd3d1 (patch)
treeb03bf2e162a5d799e2b1c0155a9a5ebec6721b9b /databases/galera
parentf1dcab1078c266597045b458a753ab7f07ab41f6 (diff)
downloadports-2ec0579d59e528340a89297aef6879a30e2cd3d1.tar.gz
ports-2ec0579d59e528340a89297aef6879a30e2cd3d1.zip
Notes
Diffstat (limited to 'databases/galera')
-rw-r--r--databases/galera/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/databases/galera/Makefile b/databases/galera/Makefile
index a911728ec05e..f2e1bc0be469 100644
--- a/databases/galera/Makefile
+++ b/databases/galera/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= galera
-PORTVERSION= 25.3.20
-PORTREVISION= 2
+PORTVERSION?= 25.3.20
+PORTREVISION?= 2
CATEGORIES= databases
MAINTAINER= devel@galeracluster.com
@@ -15,7 +15,6 @@ BUILD_DEPENDS= checkmk:devel/check \
${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
-BROKEN_powerpc64= fails to compile: gu_atomic.h: This GCC version does not support 8-byte atomics on this platform. Use GCC >= 4.7.x
NOT_FOR_ARCHS= i386
# On i386 older versions of clang produce:
# cannot compile this atomic library call yet ... __atomic_add_fetch
@@ -33,7 +32,7 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= codership
-GH_TAGNAME= release_${DISTVERSION}
+GH_TAGNAME?= release_${DISTVERSION}
LDFLAGS+= -lboost_program_options -lboost_system
MAKE_ARGS+= --config=force \
@@ -54,6 +53,11 @@ BPOSTATIC_DESC= Use static boost_program_options
.include <bsd.port.pre.mk>
+# COMPILER_TYPE could be empty on older FreeBSD versions.
+.if "${COMPILER_TYPE}" == gcc || ${OSVERSION} < 1000000
+USE_GCC= 4.8+
+.endif
+
.if ${PORT_OPTIONS:MBOOSTPOOL}
MAKE_ARGS+= boost_pool=1
.endif