aboutsummaryrefslogtreecommitdiff
path: root/databases/gauche-gdbm/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-09-09 19:25:33 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-09-09 19:25:33 +0000
commit0bdb4b602f313304a25c25200daebdb6ca9e073b (patch)
tree5ae0289b612897b4401a3d0dd2cacfa200e627bd /databases/gauche-gdbm/Makefile
parent60ae9fcc27fe78cebe544f78020867c61ef241c3 (diff)
Notes
Diffstat (limited to 'databases/gauche-gdbm/Makefile')
-rw-r--r--databases/gauche-gdbm/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/databases/gauche-gdbm/Makefile b/databases/gauche-gdbm/Makefile
new file mode 100644
index 000000000000..2ce8c96598a7
--- /dev/null
+++ b/databases/gauche-gdbm/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: gauche-gdbm
+# Date created: 9 September 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdbm
+PORTVERSION= 0.6.2
+CATEGORIES= databases
+MASTER_SITES= # none
+PKGNAMEPREFIX= gauche-
+DISTFILES= # none
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= gosh:${PORTSDIR}/${GAUCHE_PORT} \
+ ${NONEXISTENT}:${PORTSDIR}/${GAUCHE_PORT}:configure
+LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm
+RUN_DEPENDS= gosh:${PORTSDIR}/${GAUCHE_PORT}
+
+GAUCHE_PORT= lang/gauche
+
+WRKSRC= ${WRKDIR}/dbm
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_ARGS= GOSH=gosh \
+ OPTFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+PLIST_SUB= VERSION="${PORTVERSION}" \
+ TARGET="${CONFIGURE_TARGET}"
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${LN} -sf `cd ${PORTSDIR}/${GAUCHE_PORT}; ${MAKE} -V WRKSRC`/ext/dbm ${WRKDIR}/
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/gdbm.scm `gauche-config --syslibdir`/dbm/
+ ${INSTALL_DATA} ${WRKSRC}/gdbm.so `gauche-config --sysarchdir`/
+
+.include <bsd.port.mk>