aboutsummaryrefslogtreecommitdiff
path: root/databases/gdbm
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-08-08 08:11:09 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-08-08 08:11:09 +0000
commitb70a31b4c2326db5a384a3bdfab9557aea139204 (patch)
treeaa6752adb7799effc697d157f785fdc39ad3ccfb /databases/gdbm
parentd73388c5ad917bae8a550a1fb99ed1d132c68644 (diff)
downloadports-b70a31b4c2326db5a384a3bdfab9557aea139204.tar.gz
ports-b70a31b4c2326db5a384a3bdfab9557aea139204.zip
- Eliminate a patch
- Respect DESTDIR PR: 101567 Submitted by: gabor (maintainer)
Notes
Notes: svn path=/head/; revision=170079
Diffstat (limited to 'databases/gdbm')
-rw-r--r--databases/gdbm/Makefile7
-rw-r--r--databases/gdbm/files/patch-ab20
2 files changed, 7 insertions, 20 deletions
diff --git a/databases/gdbm/Makefile b/databases/gdbm/Makefile
index 90ae49ebe453..e8d6f97bd5c3 100644
--- a/databases/gdbm/Makefile
+++ b/databases/gdbm/Makefile
@@ -38,4 +38,11 @@ pre-everything::
@${ECHO_MSG}
.endif
+post-patch:
+ @${REINPLACE_CMD} "s|prefix = @prefix@|prefix = ${TARGETDIR}|" \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|LIBS = @LIBS@ -lc|LIBS = @LIBS@|" \
+ -e "s|libgdbm.la libgdbm_compat.la|libgdbm.la libgdbm_compat.la gdbm.info|" \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>
diff --git a/databases/gdbm/files/patch-ab b/databases/gdbm/files/patch-ab
deleted file mode 100644
index 5d19eaf34fa7..000000000000
--- a/databases/gdbm/files/patch-ab
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.in.orig Wed Oct 9 01:09:12 2002
-+++ Makefile.in Tue Oct 22 22:19:59 2002
-@@ -24,7 +24,7 @@
- DEFS =
-
- # Where the system [n]dbm routines are...
--LIBS = @LIBS@ -lc
-+LIBS = @LIBS@
-
- CFLAGS = @CFLAGS@
- LDFLAGS = @LDFLAGS@
-@@ -122,7 +122,7 @@
-
- DISTFILES = $(SRCS) $(HDRS) $(MSCFILES)
-
--all: libgdbm.la libgdbm_compat.la
-+all: libgdbm.la libgdbm_compat.la gdbm.info
-
- progs: $(PROGS)
-