aboutsummaryrefslogtreecommitdiff
path: root/databases/glom
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /databases/glom
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'databases/glom')
-rw-r--r--databases/glom/Makefile61
-rw-r--r--databases/glom/distinfo4
-rw-r--r--databases/glom/files/patch-glom_frame-glom.cc11
-rw-r--r--databases/glom/files/patch-glom_main.cc32
-rw-r--r--databases/glom/files/patch-glom_mode-design_fields_box-db-table-definition.cc13
-rw-r--r--databases/glom/files/patch-glom_mode-design_layout_layout-item-dialogs_box-formatting.cc13
-rw-r--r--databases/glom/pkg-plist250
7 files changed, 199 insertions, 185 deletions
diff --git a/databases/glom/Makefile b/databases/glom/Makefile
index 6415b1ed608a..aadc085e137b 100644
--- a/databases/glom/Makefile
+++ b/databases/glom/Makefile
@@ -1,45 +1,62 @@
# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/databases/glom/Makefile,v 1.30 2010/11/04 15:57:03 kwm Exp $
+# $MCom: ports/trunk/databases/glom/Makefile 19822 2014-08-20 08:57:46Z gusi $
PORTNAME= glom
-PORTVERSION= 1.12.2
-PORTREVISION= 10
+PORTVERSION= 1.24.0
+PORTREVISION= 1
CATEGORIES= databases gnome
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome3
MAINTAINER= kwm@FreeBSD.org
COMMENT= GNOME database designer and user interface
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-LIB_DEPENDS= libgdamm-4.0.so:${PORTSDIR}/databases/libgdamm \
- libgconfmm-2.6.so:${PORTSDIR}/devel/gconfmm26 \
- libgtksourceviewmm-2.0.so:${PORTSDIR}/x11-toolkits/libgtksourceviewmm \
- libavahi-ui.so:${PORTSDIR}/net/avahi-gtk \
+BUILD_DEPENDS= iso-codes>=0:${PORTSDIR}/misc/iso-codes \
+ libepc>=0.4.0:${PORTSDIR}/www/libepc \
+ libgda5-mysql>=0:${PORTSDIR}/databases/libgda5-mysql \
+ libgda5-postgresql>=0:${PORTSDIR}/databases/libgda5-postgresql
+LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs \
libepc-1.0.so:${PORTSDIR}/www/libepc \
- libgoocanvasmm-1.0.so:${PORTSDIR}/graphics/goocanvasmm
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
- ${LOCALBASE}/libdata/pkgconfig/libgda-postgres-4.0.pc:${PORTSDIR}/databases/libgda4-postgresql
-RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
- ${LOCALBASE}/libdata/pkgconfig/libgda-postgres-4.0.pc:${PORTSDIR}/databases/libgda4-postgresql
+ libgoocanvasmm-2.0.so:${PORTSDIR}/graphics/goocanvasmm2 \
+ libevview3.so:${PORTSDIR}/graphics/evince
+RUN_DEPENDS= iso-codes>=0:${PORTSDIR}/misc/iso-codes \
+ libgda5-mysql>=0:${PORTSDIR}/databases/libgda5-mysql \
+ libgda5-postgresql>=0:${PORTSDIR}/databases/libgda5-postgresql
GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
USES= desktop-file-utils gettext gmake libtool pathfix \
- pgsql pkgconfig python shared-mime-info tar:bzip2
-USE_GNOME= gnomedocutils gnomeprefix pygnomeextras
+ pgsql pkgconfig python shared-mime-info tar:xz
+USE_GNOME= gnomedocutils gnomeprefix intlhack pygobject3 libxml2 \
+ gtksourceviewmm3 libgdamm5
USE_LDCONFIG= yes
INSTALLS_OMF= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --with-postgres-utils=${LOCALBASE}/bin
+INSTALL_TARGET= install-strip
+CONFIGURE_ARGS= --with-postgres-utils=${LOCALBASE}/bin \
+ --disable-documentation
INSTALLS_ICONS= yes
+.include <bsd.port.options.mk>
+
+PLIST_SUB+= VERSION=${PORTVERSION:R}
+#PLIST_SUB+= VERSION=1.24
+
+# We need postgreSQL tools the server installs, and configure checks for these.
# Note: USE_PGSQL has already been set above.
-BUILD_DEPENDS+= postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER_NODOT}-server
-RUN_DEPENDS+= postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER_NODOT}-server
+BUILD_DEPENDS+= postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER:S/.//}-server
+RUN_DEPENDS+= postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER:S/.//}-server
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-update-mime-database|true|g' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|std::locale("")|std::locale()|g' \
+ ${WRKSRC}/glom/libglom/data_structure/glomconversions.cc \
+ ${WRKSRC}/glom/libglom/data_structure/glomconversions.h \
+ ${WRKSRC}/glom/libglom/utils.cc \
+ ${WRKSRC}/glom/mode_design/layout/layout_item_dialogs/comboentry_borderwidth.cc \
+ ${WRKSRC}/glom/mode_design/layout/layout_item_dialogs/dialog_group_by.cc \
+ ${WRKSRC}/glom/main.cc
.include <bsd.port.mk>
diff --git a/databases/glom/distinfo b/databases/glom/distinfo
index e2407a3e1344..226e52d95e4e 100644
--- a/databases/glom/distinfo
+++ b/databases/glom/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/glom-1.12.2.tar.bz2) = 5ce8bc49d9d6402db540d14c8c16a2407cbf7a588139a4e2942442ead1952992
-SIZE (gnome2/glom-1.12.2.tar.bz2) = 3239342
+SHA256 (gnome3/glom-1.24.0.tar.xz) = 83ff79610ffdede48536c0d07d5288ad84ec26c86aa2aa1db98b46abdebbdcc2
+SIZE (gnome3/glom-1.24.0.tar.xz) = 5463688
diff --git a/databases/glom/files/patch-glom_frame-glom.cc b/databases/glom/files/patch-glom_frame-glom.cc
deleted file mode 100644
index 361bfd1a8709..000000000000
--- a/databases/glom/files/patch-glom_frame-glom.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- glom/frame_glom.cc.orig 2014-03-06 22:06:42.000000000 +0100
-+++ glom/frame_glom.cc 2014-03-06 22:06:55.000000000 +0100
-@@ -1583,7 +1583,7 @@
- //Get the fields information from the database:
- Base_DB::type_vec_fields fieldsDatabase = Base_DB::get_fields_for_table_from_database(m_table_name);
-
-- Document* pDoc = dynamic_cast<const Document*>(get_document());
-+ Document* pDoc = dynamic_cast<Document*>(get_document());
- if(pDoc)
- {
- bool document_must_be_updated = false;
diff --git a/databases/glom/files/patch-glom_main.cc b/databases/glom/files/patch-glom_main.cc
deleted file mode 100644
index c9143bb8b24e..000000000000
--- a/databases/glom/files/patch-glom_main.cc
+++ /dev/null
@@ -1,32 +0,0 @@
---- glom/main.cc.orig 2009-03-16 14:53:55.000000000 +0100
-+++ glom/main.cc 2009-03-17 16:22:01.000000000 +0100
-@@ -100,18 +100,19 @@ OptionGroup::OptionGroup()
-
- } //namespace Glom
-
--#ifndef G_OS_WIN32
-+#ifdef __linux
- extern "C" void __libc_freeres(void);
- #endif
-
- int
- main(int argc, char* argv[])
- {
--#ifndef G_OS_WIN32
-+#ifdef __linux
- //Force some cleanup at exit,
- //to help valgrind to detect memory leaks:
- atexit(__libc_freeres);
- #else
-+# ifdef G_OS_WIN32
- WSADATA data;
- int errcode = WSAStartup(MAKEWORD(2, 0), &data);
- if(errcode != 0)
-@@ -123,6 +124,7 @@ main(int argc, char* argv[])
- gchar* installation_dir_c = g_win32_get_package_installation_directory_of_module(NULL);
- const std::string installation_dir(installation_dir_c);
- g_free(installation_dir_c);
-+# endif
- #endif
-
- // TODO: I am not sure why, but this does not work. PYTHONPATH is set
diff --git a/databases/glom/files/patch-glom_mode-design_fields_box-db-table-definition.cc b/databases/glom/files/patch-glom_mode-design_fields_box-db-table-definition.cc
deleted file mode 100644
index 54e4e181abb7..000000000000
--- a/databases/glom/files/patch-glom_mode-design_fields_box-db-table-definition.cc
+++ /dev/null
@@ -1,13 +0,0 @@
---- glom/mode_design/fields/box_db_table_definition.cc.orig 2014-03-06 22:10:39.000000000 +0100
-+++ glom/mode_design/fields/box_db_table_definition.cc 2014-03-06 22:16:25.000000000 +0100
-@@ -143,8 +143,8 @@
- const sharedptr<const Field>& field = *iter;
-
- //Name:
-- Gtk::TreeModel::iterator iter= m_AddDel.add_item(field->get_name());
-- fill_field_row(iter, field);
-+ Gtk::TreeModel::iterator tree_iter= m_AddDel.add_item(field->get_name());
-+ fill_field_row(tree_iter, field);
- }
-
- result = true;
diff --git a/databases/glom/files/patch-glom_mode-design_layout_layout-item-dialogs_box-formatting.cc b/databases/glom/files/patch-glom_mode-design_layout_layout-item-dialogs_box-formatting.cc
deleted file mode 100644
index 6f8068b40ff3..000000000000
--- a/databases/glom/files/patch-glom_mode-design_layout_layout-item-dialogs_box-formatting.cc
+++ /dev/null
@@ -1,13 +0,0 @@
---- glom/mode_design/layout/layout_item_dialogs/box_formatting.cc.orig 2014-03-06 22:26:17.000000000 +0100
-+++ glom/mode_design/layout/layout_item_dialogs/box_formatting.cc 2014-03-06 22:26:37.000000000 +0100
-@@ -187,8 +187,8 @@
- {
- //Display the value in the choices list as it would be displayed in the format:
- const Glib::ustring value_text = Conversions::get_text_for_gda_value(m_field->get_glom_type(), *iter, format.m_numeric_format);
-- Gtk::TreeModel::iterator iter = m_adddel_choices_custom->add_item(value_text);
-- m_adddel_choices_custom->set_value(iter, m_col_index_custom_choices, value_text);
-+ Gtk::TreeModel::iterator tree_iter = m_adddel_choices_custom->add_item(value_text);
-+ m_adddel_choices_custom->set_value(tree_iter, m_col_index_custom_choices, value_text);
- }
-
- m_radiobutton_choices_custom->set_active(format.get_has_custom_choices());
diff --git a/databases/glom/pkg-plist b/databases/glom/pkg-plist
index aceda92f6460..f2bff245ff55 100644
--- a/databases/glom/pkg-plist
+++ b/databases/glom/pkg-plist
@@ -1,58 +1,121 @@
bin/glom
-include/glom-1.12/libglom/appstate.h
-include/glom-1.12/libglom/data_structure/field.h
-include/glom-1.12/libglom/data_structure/fieldtypes.h
-include/glom-1.12/libglom/data_structure/foundset.h
-include/glom-1.12/libglom/data_structure/glomconversions.h
-include/glom-1.12/libglom/data_structure/groupinfo.h
-include/glom-1.12/libglom/data_structure/layout/custom_title.h
-include/glom-1.12/libglom/data_structure/layout/fieldformatting.h
-include/glom-1.12/libglom/data_structure/layout/layoutgroup.h
-include/glom-1.12/libglom/data_structure/layout/layoutitem.h
-include/glom-1.12/libglom/data_structure/layout/layoutitem_button.h
-include/glom-1.12/libglom/data_structure/layout/layoutitem_calendarportal.h
-include/glom-1.12/libglom/data_structure/layout/layoutitem_field.h
-include/glom-1.12/libglom/data_structure/layout/layoutitem_image.h
-include/glom-1.12/libglom/data_structure/layout/layoutitem_line.h
-include/glom-1.12/libglom/data_structure/layout/layoutitem_notebook.h
-include/glom-1.12/libglom/data_structure/layout/layoutitem_placeholder.h
-include/glom-1.12/libglom/data_structure/layout/layoutitem_portal.h
-include/glom-1.12/libglom/data_structure/layout/layoutitem_text.h
-include/glom-1.12/libglom/data_structure/layout/report_parts/layoutitem_fieldsummary.h
-include/glom-1.12/libglom/data_structure/layout/report_parts/layoutitem_footer.h
-include/glom-1.12/libglom/data_structure/layout/report_parts/layoutitem_groupby.h
-include/glom-1.12/libglom/data_structure/layout/report_parts/layoutitem_header.h
-include/glom-1.12/libglom/data_structure/layout/report_parts/layoutitem_summary.h
-include/glom-1.12/libglom/data_structure/layout/report_parts/layoutitem_verticalgroup.h
-include/glom-1.12/libglom/data_structure/layout/usesrelationship.h
-include/glom-1.12/libglom/data_structure/numeric_format.h
-include/glom-1.12/libglom/data_structure/parameternamegenerator.h
-include/glom-1.12/libglom/data_structure/print_layout.h
-include/glom-1.12/libglom/data_structure/privileges.h
-include/glom-1.12/libglom/data_structure/relationship.h
-include/glom-1.12/libglom/data_structure/report.h
-include/glom-1.12/libglom/data_structure/system_prefs.h
-include/glom-1.12/libglom/data_structure/tableinfo.h
-include/glom-1.12/libglom/data_structure/translatable_item.h
-include/glom-1.12/libglom/document/bakery/document.h
-include/glom-1.12/libglom/document/bakery/document_xml.h
-include/glom-1.12/libglom/document/bakery/view/view.h
-include/glom-1.12/libglom/document/bakery/view/view_composite.h
-include/glom-1.12/libglom/document/bakery/view/viewbase.h
-include/glom-1.12/libglom/document/document.h
-include/glom-1.12/libglom/document/view.h
-include/glom-1.12/libglom/init.h
-include/glom-1.12/libglom/libglom_config.h
-include/glom-1.12/libglom/sharedptr.h
-include/glom-1.12/libglom/standard_table_prefs_fields.h
-lib/libglom-1.12.so
-lib/libglom-1.12.so.0
-lib/libglom-1.12.so.0.0.0
-%%PYTHON_SITELIBDIR%%/glom_1_12.so
-libdata/pkgconfig/glom-1.12.pc
+bin/glom_create_from_example
+bin/glom_export_po
+bin/glom_export_po_all
+bin/glom_import_po_all
+bin/glom_test_connection
+include/glom-%%VERSION%%/libglom/appstate.h
+include/glom-%%VERSION%%/libglom/data_structure/choicevalue.h
+include/glom-%%VERSION%%/libglom/data_structure/database_title.h
+include/glom-%%VERSION%%/libglom/data_structure/field.h
+include/glom-%%VERSION%%/libglom/data_structure/fieldtypes.h
+include/glom-%%VERSION%%/libglom/data_structure/foundset.h
+include/glom-%%VERSION%%/libglom/data_structure/glomconversions.h
+include/glom-%%VERSION%%/libglom/data_structure/groupinfo.h
+include/glom-%%VERSION%%/libglom/data_structure/has_title_singular.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/custom_title.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/formatting.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/layoutgroup.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/layoutitem.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/layoutitem_button.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/layoutitem_calendarportal.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/layoutitem_field.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/layoutitem_image.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/layoutitem_line.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/layoutitem_notebook.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/layoutitem_placeholder.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/layoutitem_portal.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/layoutitem_text.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/layoutitem_withformatting.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/report_parts/layoutitem_fieldsummary.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/report_parts/layoutitem_footer.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/report_parts/layoutitem_groupby.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/report_parts/layoutitem_header.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/report_parts/layoutitem_summary.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/report_parts/layoutitem_verticalgroup.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/static_text.h
+include/glom-%%VERSION%%/libglom/data_structure/layout/usesrelationship.h
+include/glom-%%VERSION%%/libglom/data_structure/numeric_format.h
+include/glom-%%VERSION%%/libglom/data_structure/print_layout.h
+include/glom-%%VERSION%%/libglom/data_structure/privileges.h
+include/glom-%%VERSION%%/libglom/data_structure/relationship.h
+include/glom-%%VERSION%%/libglom/data_structure/report.h
+include/glom-%%VERSION%%/libglom/data_structure/system_prefs.h
+include/glom-%%VERSION%%/libglom/data_structure/tableinfo.h
+include/glom-%%VERSION%%/libglom/data_structure/translatable_item.h
+include/glom-%%VERSION%%/libglom/translations_po.h
+include/glom-%%VERSION%%/libglom/db_utils.h
+include/glom-%%VERSION%%/libglom/document/bakery/document.h
+include/glom-%%VERSION%%/libglom/document/bakery/document_xml.h
+include/glom-%%VERSION%%/libglom/document/bakery/view/view.h
+include/glom-%%VERSION%%/libglom/document/bakery/view/view_composite.h
+include/glom-%%VERSION%%/libglom/document/bakery/view/viewbase.h
+include/glom-%%VERSION%%/libglom/document/document.h
+include/glom-%%VERSION%%/libglom/document/view.h
+include/glom-%%VERSION%%/libglom/init.h
+include/glom-%%VERSION%%/libglom/libglom_config.h
+include/glom-%%VERSION%%/libglom/report_builder.h
+include/glom-%%VERSION%%/libglom/sharedptr.h
+include/glom-%%VERSION%%/libglom/standard_table_prefs_fields.h
+include/glom-%%VERSION%%/libglom/utils.h
+lib/libglom-%%VERSION%%.so
+lib/libglom-%%VERSION%%.so.0
+lib/libglom-%%VERSION%%.so.0.0.0
+%%PYTHON_SITELIBDIR%%/glom_1_24.so
+libdata/pkgconfig/glom-%%VERSION%%.pc
share/applications/glom.desktop
-%%DATADIR%%/glade/glom_developer.glade
-%%DATADIR%%/glade/glom.glade
+%%DATADIR%%/glade/developer/box_formatting.glade
+%%DATADIR%%/glade/developer/box_print_layouts.glade
+%%DATADIR%%/glade/developer/box_reports.glade
+%%DATADIR%%/glade/developer/dialog_add_related_table.glade
+%%DATADIR%%/glade/developer/dialog_change_language.glade
+%%DATADIR%%/glade/developer/dialog_choose_field.glade
+%%DATADIR%%/glade/developer/dialog_choose_relationship.glade
+%%DATADIR%%/glade/developer/dialog_choose_user.glade
+%%DATADIR%%/glade/developer/dialog_database_preferences.glade
+%%DATADIR%%/glade/developer/dialog_error_create_database.glade
+%%DATADIR%%/glade/developer/dialog_field_summary.glade
+%%DATADIR%%/glade/developer/dialog_fieldslist.glade
+%%DATADIR%%/glade/developer/dialog_flowtable.glade
+%%DATADIR%%/glade/developer/dialog_group_by.glade
+%%DATADIR%%/glade/developer/dialog_initial_password.glade
+%%DATADIR%%/glade/developer/dialog_layout_field_properties.glade
+%%DATADIR%%/glade/developer/dialog_line.glade
+%%DATADIR%%/glade/developer/dialog_new_group.glade
+%%DATADIR%%/glade/developer/dialog_new_library_script.glade
+%%DATADIR%%/glade/developer/dialog_notebook.glade
+%%DATADIR%%/glade/developer/dialog_relationships_overview.glade
+%%DATADIR%%/glade/developer/dialog_script_library.glade
+%%DATADIR%%/glade/developer/dialog_sort_fields.glade
+%%DATADIR%%/glade/developer/dialog_translation_copy.glade
+%%DATADIR%%/glade/developer/dialog_translation_identify_original.glade
+%%DATADIR%%/glade/developer/dialog_user.glade
+%%DATADIR%%/glade/developer/window_button_script.glade
+%%DATADIR%%/glade/developer/window_data_layout.glade
+%%DATADIR%%/glade/developer/window_data_layout_export.glade
+%%DATADIR%%/glade/developer/window_design.glade
+%%DATADIR%%/glade/developer/window_field_calculation.glade
+%%DATADIR%%/glade/developer/window_field_definition_edit.glade
+%%DATADIR%%/glade/developer/window_groups.glade
+%%DATADIR%%/glade/developer/window_imageobject.glade
+%%DATADIR%%/glade/developer/window_print_layout_edit.glade
+%%DATADIR%%/glade/developer/window_report_layout.glade
+%%DATADIR%%/glade/developer/window_text_format.glade
+%%DATADIR%%/glade/developer/window_textobject.glade
+%%DATADIR%%/glade/developer/window_translations.glade
+%%DATADIR%%/glade/developer/window_users.glade
+%%DATADIR%%/glade/operator/box_navigation_tables.glade
+%%DATADIR%%/glade/operator/dialog_choose_date.glade
+%%DATADIR%%/glade/operator/dialog_connection.glade
+%%DATADIR%%/glade/operator/dialog_data_invalid_format.glade
+%%DATADIR%%/glade/operator/dialog_existing_or_new.glade
+%%DATADIR%%/glade/operator/dialog_find_id.glade
+%%DATADIR%%/glade/operator/dialog_image_load_progress.glade
+%%DATADIR%%/glade/operator/dialog_image_save_progress.glade
+%%DATADIR%%/glade/operator/dialog_import_csv.glade
+%%DATADIR%%/glade/operator/dialog_import_csv_progress.glade
+%%DATADIR%%/glade/operator/dialog_new_record.glade
+%%DATADIR%%/glade/operator/window_main.glade
%%DATADIR%%/glom_document.dtd
%%DATADIR%%/pixmaps/glom-button.png
%%DATADIR%%/pixmaps/glom-field.png
@@ -63,7 +126,6 @@ share/applications/glom.desktop
%%DATADIR%%/pixmaps/glom-notebook.png
%%DATADIR%%/pixmaps/glom-related-records.png
%%DATADIR%%/pixmaps/glom-text.png
-%%DATADIR%%/xslt/print_details_to_html.xsl
%%DATADIR%%/xslt/print_report_to_html.xsl
%%DOCSDIR%%/examples/README
%%DOCSDIR%%/examples/example_film_manager.glom
@@ -86,7 +148,8 @@ share/gnome/help/glom/C/figures/glom_import.png
share/gnome/help/glom/C/figures/glom_initial_dialog_local_network.png
share/gnome/help/glom/C/figures/glom_report_result.png
share/gnome/help/glom/C/figures/glom_tables.png
-share/gnome/help/glom/C/figures/start.png
+share/gnome/help/glom/C/figures/start_create.png
+share/gnome/help/glom/C/figures/start_open.png
share/gnome/help/glom/C/glom.xml
share/gnome/help/glom/C/legal.xml
share/gnome/help/glom/de/figures/glom_data_details.png
@@ -104,7 +167,8 @@ share/gnome/help/glom/de/figures/glom_import.png
share/gnome/help/glom/de/figures/glom_initial_dialog_local_network.png
share/gnome/help/glom/de/figures/glom_report_result.png
share/gnome/help/glom/de/figures/glom_tables.png
-share/gnome/help/glom/de/figures/start.png
+share/gnome/help/glom/de/figures/start_create.png
+share/gnome/help/glom/de/figures/start_open.png
share/gnome/help/glom/de/glom.xml
share/gnome/help/glom/de/legal.xml
share/gnome/help/glom/en_GB/figures/glom_data_details.png
@@ -122,7 +186,8 @@ share/gnome/help/glom/en_GB/figures/glom_import.png
share/gnome/help/glom/en_GB/figures/glom_initial_dialog_local_network.png
share/gnome/help/glom/en_GB/figures/glom_report_result.png
share/gnome/help/glom/en_GB/figures/glom_tables.png
-share/gnome/help/glom/en_GB/figures/start.png
+share/gnome/help/glom/en_GB/figures/start_create.png
+share/gnome/help/glom/en_GB/figures/start_open.png
share/gnome/help/glom/en_GB/glom.xml
share/gnome/help/glom/en_GB/legal.xml
share/gnome/help/glom/es/figures/glom_data_details.png
@@ -140,7 +205,8 @@ share/gnome/help/glom/es/figures/glom_import.png
share/gnome/help/glom/es/figures/glom_initial_dialog_local_network.png
share/gnome/help/glom/es/figures/glom_report_result.png
share/gnome/help/glom/es/figures/glom_tables.png
-share/gnome/help/glom/es/figures/start.png
+share/gnome/help/glom/es/figures/start_create.png
+share/gnome/help/glom/es/figures/start_open.png
share/gnome/help/glom/es/glom.xml
share/gnome/help/glom/es/legal.xml
share/gnome/help/glom/fr/figures/glom_data_details.png
@@ -158,9 +224,29 @@ share/gnome/help/glom/fr/figures/glom_import.png
share/gnome/help/glom/fr/figures/glom_initial_dialog_local_network.png
share/gnome/help/glom/fr/figures/glom_report_result.png
share/gnome/help/glom/fr/figures/glom_tables.png
-share/gnome/help/glom/fr/figures/start.png
+share/gnome/help/glom/fr/figures/start_create.png
+share/gnome/help/glom/fr/figures/start_open.png
share/gnome/help/glom/fr/glom.xml
share/gnome/help/glom/fr/legal.xml
+share/gnome/help/glom/sl/figures/glom_data_details.png
+share/gnome/help/glom/sl/figures/glom_data_list.png
+share/gnome/help/glom/sl/figures/glom_design_fields.png
+share/gnome/help/glom/sl/figures/glom_design_fields_dialog_calculated.png
+share/gnome/help/glom/sl/figures/glom_design_layout_details.png
+share/gnome/help/glom/sl/figures/glom_design_layout_list.png
+share/gnome/help/glom/sl/figures/glom_design_reports.png
+share/gnome/help/glom/sl/figures/glom_design_reports_details.png
+share/gnome/help/glom/sl/figures/glom_design_reports_group_by.png
+share/gnome/help/glom/sl/figures/glom_design_reports_vertical_group.png
+share/gnome/help/glom/sl/figures/glom_design_translations.png
+share/gnome/help/glom/sl/figures/glom_import.png
+share/gnome/help/glom/sl/figures/glom_initial_dialog_local_network.png
+share/gnome/help/glom/sl/figures/glom_report_result.png
+share/gnome/help/glom/sl/figures/glom_tables.png
+share/gnome/help/glom/sl/figures/start_create.png
+share/gnome/help/glom/sl/figures/start_open.png
+share/gnome/help/glom/sl/glom.xml
+share/gnome/help/glom/sl/legal.xml
share/gnome/help/glom/sv/figures/glom_data_details.png
share/gnome/help/glom/sv/figures/glom_data_list.png
share/gnome/help/glom/sv/figures/glom_design_fields.png
@@ -176,7 +262,8 @@ share/gnome/help/glom/sv/figures/glom_import.png
share/gnome/help/glom/sv/figures/glom_initial_dialog_local_network.png
share/gnome/help/glom/sv/figures/glom_report_result.png
share/gnome/help/glom/sv/figures/glom_tables.png
-share/gnome/help/glom/sv/figures/start.png
+share/gnome/help/glom/sv/figures/start_create.png
+share/gnome/help/glom/sv/figures/start_open.png
share/gnome/help/glom/sv/glom.xml
share/gnome/help/glom/sv/legal.xml
share/icons/hicolor/16x16/apps/glom.png
@@ -187,18 +274,24 @@ share/icons/hicolor/48x48/apps/glom.png
share/icons/hicolor/scalable/apps/glom.svg
share/locale/ar/LC_MESSAGES/glom.mo
share/locale/ca/LC_MESSAGES/glom.mo
+share/locale/ca@valencia/LC_MESSAGES/glom.mo
share/locale/cs/LC_MESSAGES/glom.mo
+share/locale/da/LC_MESSAGES/glom.mo
share/locale/de/LC_MESSAGES/glom.mo
share/locale/dz/LC_MESSAGES/glom.mo
+share/locale/el/LC_MESSAGES/glom.mo
share/locale/en_CA/LC_MESSAGES/glom.mo
share/locale/en_GB/LC_MESSAGES/glom.mo
+share/locale/eo/LC_MESSAGES/glom.mo
share/locale/es/LC_MESSAGES/glom.mo
share/locale/fi/LC_MESSAGES/glom.mo
share/locale/fr/LC_MESSAGES/glom.mo
share/locale/gl/LC_MESSAGES/glom.mo
share/locale/gu/LC_MESSAGES/glom.mo
share/locale/hu/LC_MESSAGES/glom.mo
+share/locale/id/LC_MESSAGES/glom.mo
share/locale/it/LC_MESSAGES/glom.mo
+share/locale/lv/LC_MESSAGES/glom.mo
share/locale/nb/LC_MESSAGES/glom.mo
share/locale/ne/LC_MESSAGES/glom.mo
share/locale/nl/LC_MESSAGES/glom.mo
@@ -207,7 +300,11 @@ share/locale/pa/LC_MESSAGES/glom.mo
share/locale/pt/LC_MESSAGES/glom.mo
share/locale/pt_BR/LC_MESSAGES/glom.mo
share/locale/rw/LC_MESSAGES/glom.mo
+share/locale/ru/LC_MESSAGES/glom.mo
+share/locale/sl/LC_MESSAGES/glom.mo
share/locale/sq/LC_MESSAGES/glom.mo
+share/locale/sr/LC_MESSAGES/glom.mo
+share/locale/sr@latin/LC_MESSAGES/glom.mo
share/locale/sv/LC_MESSAGES/glom.mo
share/locale/tr/LC_MESSAGES/glom.mo
share/locale/vi/LC_MESSAGES/glom.mo
@@ -218,36 +315,5 @@ share/omf/glom/glom-de.omf
share/omf/glom/glom-en_GB.omf
share/omf/glom/glom-es.omf
share/omf/glom/glom-fr.omf
+share/omf/glom/glom-sl.omf
share/omf/glom/glom-sv.omf
-@dirrm share/omf/glom
-@dirrm share/gnome/help/glom/sv/figures
-@dirrm share/gnome/help/glom/sv
-@dirrm share/gnome/help/glom/fr/figures
-@dirrm share/gnome/help/glom/fr
-@dirrm share/gnome/help/glom/es/figures
-@dirrm share/gnome/help/glom/es
-@dirrm share/gnome/help/glom/en_GB/figures
-@dirrm share/gnome/help/glom/en_GB
-@dirrm share/gnome/help/glom/de/figures
-@dirrm share/gnome/help/glom/de
-@dirrm share/gnome/help/glom/C/figures
-@dirrm share/gnome/help/glom/C
-@dirrm share/gnome/help/glom
-@dirrm %%DOCSDIR%%/examples
-@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/xslt
-@dirrm %%DATADIR%%/pixmaps
-@dirrm %%DATADIR%%/glade
-@dirrm %%DATADIR%%
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
-@dirrm include/glom-1.12/libglom/document/bakery/view
-@dirrm include/glom-1.12/libglom/document/bakery
-@dirrm include/glom-1.12/libglom/document
-@dirrm include/glom-1.12/libglom/data_structure/layout/report_parts
-@dirrm include/glom-1.12/libglom/data_structure/layout
-@dirrm include/glom-1.12/libglom/data_structure
-@dirrm include/glom-1.12/libglom
-@dirrm include/glom-1.12