aboutsummaryrefslogtreecommitdiff
path: root/databases/grass7/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-19 06:36:54 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-19 06:36:54 +0000
commite05167950ecc7be497091c0362ca572ac8077908 (patch)
treeab62a51dfe771983fc1261d36a40bc38fc14ce93 /databases/grass7/Makefile
parent6298478e5e6570f363b1b16fb74c43304093b514 (diff)
downloadports-e05167950ecc7be497091c0362ca572ac8077908.tar.gz
ports-e05167950ecc7be497091c0362ca572ac8077908.zip
Notes
Diffstat (limited to 'databases/grass7/Makefile')
-rw-r--r--databases/grass7/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/databases/grass7/Makefile b/databases/grass7/Makefile
index 51492a0634cb..15784c68fba0 100644
--- a/databases/grass7/Makefile
+++ b/databases/grass7/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= grass
-PORTVERSION= 7.2.2
-PORTREVISION= 7
+PORTVERSION= 7.4.0
CATEGORIES= databases geography
MASTER_SITES= http://grass.osgeo.org/%SUBDIR%/ \
http://grass.cict.fr/%SUBDIR%/ \
@@ -16,7 +15,7 @@ MASTER_SITES= http://grass.osgeo.org/%SUBDIR%/ \
http://pinus.gntech.ac.kr/grass/%SUBDIR%/ \
http://wgbis.ces.iisc.ernet.in/grass/%SUBDIR%/ \
http://wgrass.media.osaka-cu.ac.jp/grassh/%SUBDIR%/
-MASTER_SITE_SUBDIR= grass72/source
+MASTER_SITE_SUBDIR= grass74/source
PKGNAMESUFFIX= 7
MAINTAINER= lbartoletti@tuxfamily.org
@@ -48,7 +47,7 @@ USE_WX= 3.0
WX_COMPS= wx:build python:run
USE_GCC= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= PERL="${PERL}"
+
CONFIGURE_ARGS= --with-includes=${LOCALBASE}/include \
--with-libs=${LOCALBASE}/lib \
--with-opengl-includes=${LOCALBASE}/include/ \
@@ -70,8 +69,7 @@ CONFIGURE_ARGS= --with-includes=${LOCALBASE}/include \
ALL_TARGET= default
USE_LDCONFIG= ${PREFIX}/${GRASS_INST_DIR}/lib
-MAKE_JOBS_UNSAFE=yes
-MAKE_ENV+= TARGET="${CONFIGURE_TARGET}"
+MAKE_ENV+= TARGET="${CONFIGURE_TARGET}"
PLIST_SUB= GRASS_INST_DIR="${GRASS_INST_DIR}" \
VERSION="${PORTVERSION}" \
@@ -93,13 +91,13 @@ ATLAS_USES_OFF= blaslapack
DB_DESC= Database support
LAS_CONFIGURE_ON= --with-liblas=yes
LAS_LIB_DEPENDS= liblas.so:devel/liblas \
- libboost_program_options.so:devel/boost-libs \
- libboost_thread.so:devel/boost-libs \
- libgeotiff.so:graphics/libgeotiff
+ libboost_program_options.so:devel/boost-libs \
+ libboost_thread.so:devel/boost-libs \
+ libgeotiff.so:graphics/libgeotiff
MOTIF_USES= motif
MOTIF_USE= GL=glw
MOTIF_CONFIGURE_ON= --with-motif --with-glw
-MYSQL_USE= MYSQL=yes
+MYSQL_USES= mysql
MYSQL_CONFIGURE_ON= --with-mysql \
--with-mysql-includes=${LOCALBASE}/include/mysql \
--with-mysql-libs=${LOCALBASE}/lib/mysql