aboutsummaryrefslogtreecommitdiff
path: root/databases/grass7
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-11-29 08:39:00 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-11-29 08:39:00 +0000
commitd2fb6d6434d293d4bf6e491a6002c72118138949 (patch)
treeee8efe0dfcf77433726188ccc4d3c597759ae65d /databases/grass7
parentb1828130b0830012f95d3e4f72b31f29224d8de4 (diff)
downloadports-d2fb6d6434d293d4bf6e491a6002c72118138949.tar.gz
ports-d2fb6d6434d293d4bf6e491a6002c72118138949.zip
Notes
Diffstat (limited to 'databases/grass7')
-rw-r--r--databases/grass7/Makefile70
-rw-r--r--databases/grass7/distinfo6
-rw-r--r--databases/grass7/pkg-message16
-rw-r--r--databases/grass7/pkg-plist102
4 files changed, 107 insertions, 87 deletions
diff --git a/databases/grass7/Makefile b/databases/grass7/Makefile
index cbcce416895c..f1e91e078e9a 100644
--- a/databases/grass7/Makefile
+++ b/databases/grass7/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= grass
-PORTVERSION= 7.4.0
-PORTREVISION= 5
+PORTVERSION= 7.4.1
CATEGORIES= databases geography
MASTER_SITES= http://grass.osgeo.org/%SUBDIR%/ \
http://grass.cict.fr/%SUBDIR%/ \
@@ -25,7 +24,7 @@ COMMENT= Open source Geographical Information System (GIS)
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/GPL.TXT
-BROKEN= fails to package
+BROKEN_sparc64= Does not configure on sparc64
DEPRECATED= Broken for more than 6 months
EXPIRATION_DATE= 2018-12-19
@@ -40,8 +39,8 @@ LIB_DEPENDS= libgdal.so:graphics/gdal \
libgeos.so:graphics/geos
RUN_DEPENDS= bash:shells/bash
-USES= fortran gettext gmake iconv jpeg perl5 pkgconfig python:2.7 \
- readline shebangfix tk
+USES= blaslapack compiler:openmp fortran gettext gmake iconv \
+ jpeg perl5 pkgconfig python:2.7 readline shebangfix tk
SHEBANG_LANG= nviz
nviz_OLD_CMD= nviz
nviz_CMD= ${PREFIX}/${GRASS_INST_DIR}/bin/nviz
@@ -80,19 +79,22 @@ PLIST_SUB= GRASS_INST_DIR="${GRASS_INST_DIR}" \
VERSION="${PORTVERSION}" \
VER="${PORTVERSION:R:C/\.//}"
-BROKEN_sparc64= Does not configure on sparc64
-
-OPTIONS_DEFINE= ATLAS LAS MOTIF NETCDF PDAL
+OPTIONS_DEFINE= LAS MOTIF NETCDF PDAL
OPTIONS_MULTI= DB
OPTIONS_MULTI_DB= MYSQL ODBC PGSQL SQLITE
-OPTIONS_DEFAULT= LAS PDAL PGSQL SQLITE
+#OPTIONS_SINGLE= BLAS
+#OPTIONS_SINGLE_BLAS= ATLAS NETLIB GOTOBLAS OPENBLAS
+OPTIONS_DEFAULT= LAS PDAL PGSQL SQLITE NETLIB
OPTIONS_SUB= yes
-ATLAS_DESC= Use ATLAS for BLAS and LAPACK
+#BLAS_DESC= BLAS/LAPACK support
+#GOTOBLAS_DESC= GotoBLAS implementation
LAS_DESC= Enable LiDAR modules
PDAL_DESC= Enable points cloud data modules
-ATLAS_USES= blaslapack:atlas
-ATLAS_USES_OFF= blaslapack
+#ATLAS_USES= blaslapack:atlas
+#NETLIB_USES= blaslapack
+#GOTOBLAS_USES= blaslapack:gotoblas
+#OPENBLAS_USES= blaslapack:openblas
DB_DESC= Database support
LAS_CONFIGURE_ON= --with-liblas=yes
LAS_LIB_DEPENDS= liblas.so:devel/liblas \
@@ -127,11 +129,11 @@ GRASS_INST_DIR= ${PORTNAME}-${PORTVERSION}
MANDIRS= ${PREFIX}/grass-${PORTVERSION}/docs/man/man1
post-patch:
- @${REINPLACE_CMD} -e \
+ ${REINPLACE_CMD} -e \
's|-lblas|${BLASLIB}|g ; \
s|-llapack|${LAPACKLIB}|g ; \
s|g2c|f2c|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
+ ${REINPLACE_CMD} -e \
's|make -C|$$(MAKE) -C| ; \
/^BINDIR/s|=.*|= $${DESTDIR}$${UNIX_BIN}| ; \
/test /s| $$(INST_DIR)| $${DESTDIR}$${INST_DIR}|g ; \
@@ -142,38 +144,36 @@ post-patch:
/$$(MAKE) /s| $$(INST_DIR)| $${DESTDIR}$${INST_DIR}|g ; \
/^$$(INST_DIR)\//s|$$(INST_DIR)|$${DESTDIR}$${INST_DIR}|g ; \
s|> $$(INST_DIR)|> $${DESTDIR}$${INST_DIR}|' ${WRKSRC}/include/Make/Install.make
- @${REINPLACE_CMD} \
+ ${REINPLACE_CMD} \
's|= python|= ${PYTHON_CMD:T}|' ${WRKSRC}/include/Make/Platform.make.in
- @${REINPLACE_CMD} \
+ ${REINPLACE_CMD} \
"s|'make'|'gmake'|g" ${WRKSRC}/scripts/g.extension/g.extension.py
- @${REINPLACE_CMD} \
+ ${REINPLACE_CMD} \
's|$$(ARCH)|$$(TARGET)|g' ${WRKSRC}/include/Make/Grass.make
# Replace hardcoded python interpreter to PYTHON_CMD
- @${REINPLACE_CMD} -e 's|env python|env ${PYTHON_CMD}|g' \
- ${WRKSRC}/lib/gis/parser_script.c \
- ${WRKSRC}/general/g.parser/g.parser.html \
- ${WRKSRC}/lib/python/docs/src/script_intro.rst \
- ${WRKSRC}/lib/init/grass7.html \
- ${WRKSRC}/raster/r.solute.transport/r.solute.transport.html
- @${REINPLACE_CMD} "s|'GRASS_PYTHON', 'python'|'GRASS_PYTHON', \'${PYTHON_CMD}\'|g" \
+ ${REINPLACE_CMD} "s|'GRASS_PYTHON', 'python'|'GRASS_PYTHON', \'${PYTHON_CMD}\'|g" \
${WRKSRC}/scripts/wxpyimgview/wxpyimgview.py
- @${REINPLACE_CMD} 's|GRASS_PYTHON=python|GRASS_PYTHON=${PYTHON_CMD}|g' \
+ ${REINPLACE_CMD} 's|GRASS_PYTHON=python|GRASS_PYTHON=${PYTHON_CMD}|g' \
${WRKSRC}/lib/init/grass.sh
- @${REINPLACE_CMD} \
+ ${REINPLACE_CMD} \
"s|environ\['GRASS_PYTHON'\] = "'"python"'"|environ['GRASS_PYTHON'] = "'"${PYTHON_CMD}"'"|g" \
${WRKSRC}/lib/python/script/setup.py
- @${FIND} ${WRKSRC} -type f -name "*.py" | ${XARGS} ${REINPLACE_CMD} \
- 's|env python|env ${PYTHON_CMD}|g'
+ cd ${WRKSRC}; \
+ for i in `${FIND} . -type f -print`; do \
+ ${REINPLACE_CMD} \
+ 's|#!/usr/bin/env python|#!/usr/bin/env ${PYTHON_CMD}|' $$i; \
+ done
post-install:
- @${RM} -rf ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/demolocation/PERMANENT/.tmp/
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/bin/*
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/driver/db/*
+ ${RM} -rf ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/demolocation/PERMANENT/.tmp/
+ ${RM} -rf ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/docs/html/colortables/*bak.png
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/bin/*
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/driver/db/*
.for i in clean_temp current_time_s_ms echo i.find lock run r.watershed/seg r.watershed/ram
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/etc/${i}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/etc/${i}
.endfor
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/etc/lister/*
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/lib/libgrass_*.so
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/tools/g.echo
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/etc/lister/*
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/lib/libgrass_*.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/tools/g.echo
.include <bsd.port.mk>
diff --git a/databases/grass7/distinfo b/databases/grass7/distinfo
index fb83b24ff875..28267951fb86 100644
--- a/databases/grass7/distinfo
+++ b/databases/grass7/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1517513795
-SHA256 (grass-7.4.0.tar.gz) = cb6fa188e030a3a447fc5451fbe0ecbeb4069ee2fd1bf52ed8e40e9b89e293cc
-SIZE (grass-7.4.0.tar.gz) = 56329374
+TIMESTAMP = 1535826858
+SHA256 (grass-7.4.1.tar.gz) = 560b8669caaafa9e8dbd4bbf2b4b4bbab7dca1cc46ee828eaf26c744fe0635fc
+SIZE (grass-7.4.1.tar.gz) = 57969640
diff --git a/databases/grass7/pkg-message b/databases/grass7/pkg-message
new file mode 100644
index 000000000000..dc057708a2dc
--- /dev/null
+++ b/databases/grass7/pkg-message
@@ -0,0 +1,16 @@
+To run the wxpython based GUI:
+
+export GRASS_PYTHON=python2.7 (or your local python version)
+grass -gui
+
+To map gcc for numpy, add:
+
+libgcc_s.so.1 gcc6/libgcc_s.so.1
+libgomp.so.1 gcc6/libgomp.so.1
+libssp.so.0 gcc6/libssp.so.0
+libstdc++.so.6 gcc6/libstdc++.so.6
+
+to %%LOCALBASE%%/etc/libmap.d/gcc.conf. Use your local gcc version
+instead of gcc6.
+
+This is required for some modules using fortran.
diff --git a/databases/grass7/pkg-plist b/databases/grass7/pkg-plist
index 70bc4a294246..52372df3cfea 100644
--- a/databases/grass7/pkg-plist
+++ b/databases/grass7/pkg-plist
@@ -152,7 +152,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/bin/r.in.bin
%%GRASS_INST_DIR%%/bin/r.in.gdal
%%GRASS_INST_DIR%%/bin/r.in.gridatb
-%%LAS%%%%GRASS_INST_DIR%%/bin/r.in.lidar
%%GRASS_INST_DIR%%/bin/r.in.mat
%%GRASS_INST_DIR%%/bin/r.in.png
%%GRASS_INST_DIR%%/bin/r.in.poly
@@ -273,7 +272,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/bin/r3.gwflow
%%GRASS_INST_DIR%%/bin/r3.in.ascii
%%GRASS_INST_DIR%%/bin/r3.in.bin
-%%LAS%%%%GRASS_INST_DIR%%/bin/r3.in.lidar
%%GRASS_INST_DIR%%/bin/r3.in.v5d
%%GRASS_INST_DIR%%/bin/r3.info
%%GRASS_INST_DIR%%/bin/r3.mapcalc
@@ -283,7 +281,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/bin/r3.null
%%GRASS_INST_DIR%%/bin/r3.out.ascii
%%GRASS_INST_DIR%%/bin/r3.out.bin
-%%NETCDF%%%%GRASS_INST_DIR%%/bin/r3.out.netcdf
%%GRASS_INST_DIR%%/bin/r3.out.v5d
%%GRASS_INST_DIR%%/bin/r3.out.vtk
%%GRASS_INST_DIR%%/bin/r3.retile
@@ -320,7 +317,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/bin/v.in.ascii
%%GRASS_INST_DIR%%/bin/v.in.db
%%GRASS_INST_DIR%%/bin/v.in.dxf
-%%LAS%%%%GRASS_INST_DIR%%/bin/v.in.lidar
%%GRASS_INST_DIR%%/bin/v.in.ogr
%%GRASS_INST_DIR%%/bin/v.in.region
%%GRASS_INST_DIR%%/bin/v.info
@@ -356,9 +352,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/bin/v.normal
%%GRASS_INST_DIR%%/bin/v.out.ascii
%%GRASS_INST_DIR%%/bin/v.out.dxf
-%%LAS%%%%GRASS_INST_DIR%%/bin/v.out.lidar
%%GRASS_INST_DIR%%/bin/v.out.ogr
-%%PGSQL%%%%GRASS_INST_DIR%%/bin/v.out.postgis
%%GRASS_INST_DIR%%/bin/v.out.pov
%%GRASS_INST_DIR%%/bin/v.out.svg
%%GRASS_INST_DIR%%/bin/v.out.vtk
@@ -430,8 +424,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/demolocation/PERMANENT/vector/point/hist
%%GRASS_INST_DIR%%/demolocation/PERMANENT/vector/point/sidx
%%GRASS_INST_DIR%%/demolocation/PERMANENT/vector/point/topo
-%%GRASS_INST_DIR%%/docs/html/albedo_landsat5.png
-%%GRASS_INST_DIR%%/docs/html/albedo_landsat7.png
%%GRASS_INST_DIR%%/docs/html/aspect.png
%%GRASS_INST_DIR%%/docs/html/aspect_diagram.png
%%GRASS_INST_DIR%%/docs/html/barscales/arrow_ends.png
@@ -724,10 +716,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/gi_vector.jpg
%%GRASS_INST_DIR%%/docs/html/graphical_index.html
%%GRASS_INST_DIR%%/docs/html/grass-dbf.html
-%%MYSQL%%%%GRASS_INST_DIR%%/docs/html/grass-mysql.html
-%%ODBC%%%%GRASS_INST_DIR%%/docs/html/grass-odbc.html
%%GRASS_INST_DIR%%/docs/html/grass-ogr.html
-%%PGSQL%%%%GRASS_INST_DIR%%/docs/html/grass-pg.html
%%GRASS_INST_DIR%%/docs/html/grass-sqlite.html
%%GRASS_INST_DIR%%/docs/html/grass7.html
%%GRASS_INST_DIR%%/docs/html/grass7_arch.png
@@ -787,16 +776,25 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/i.topo.corr.html
%%GRASS_INST_DIR%%/docs/html/i.vi.html
%%GRASS_INST_DIR%%/docs/html/i.zc.html
-%%GRASS_INST_DIR%%/docs/html/i_col_enh_corr.jpg
-%%GRASS_INST_DIR%%/docs/html/i_col_enh_uncorr.jpg
+%%GRASS_INST_DIR%%/docs/html/i_albedo_landsat5.png
+%%GRASS_INST_DIR%%/docs/html/i_albedo_landsat7.png
+%%GRASS_INST_DIR%%/docs/html/i_atcorr_B02_atcorr.png
+%%GRASS_INST_DIR%%/docs/html/i_cluster_landsat_clustering.png
+%%GRASS_INST_DIR%%/docs/html/i_colors_enhance_corrected.jpg
+%%GRASS_INST_DIR%%/docs/html/i_colors_enhance_uncorrected.jpg
%%GRASS_INST_DIR%%/docs/html/i_maxlik_classes.png
%%GRASS_INST_DIR%%/docs/html/i_maxlik_rejection.png
%%GRASS_INST_DIR%%/docs/html/i_maxlik_rgb.png
+%%GRASS_INST_DIR%%/docs/html/i_ortho_camera.png
%%GRASS_INST_DIR%%/docs/html/i_ortho_photo_step1.png
%%GRASS_INST_DIR%%/docs/html/i_ortho_photo_step5.png
%%GRASS_INST_DIR%%/docs/html/i_ortho_photo_step6.png
%%GRASS_INST_DIR%%/docs/html/i_ortho_photo_step7.png
%%GRASS_INST_DIR%%/docs/html/i_ortho_photo_step8.png
+%%GRASS_INST_DIR%%/docs/html/i_pansharpen_rgb_brovey321.jpg
+%%GRASS_INST_DIR%%/docs/html/i_pansharpen_rgb_ihs321.jpg
+%%GRASS_INST_DIR%%/docs/html/i_pansharpen_rgb_landsat321.jpg
+%%GRASS_INST_DIR%%/docs/html/i_pansharpen_rgb_pca321.jpg
%%GRASS_INST_DIR%%/docs/html/i_pca_result.png
%%GRASS_INST_DIR%%/docs/html/i_segment_lsat7_pan.png
%%GRASS_INST_DIR%%/docs/html/i_segment_lsat7_seg_min100.png
@@ -805,6 +803,11 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/i_segment_ortho_segs_l1.jpg
%%GRASS_INST_DIR%%/docs/html/i_segment_ortho_segs_l2_l5.jpg
%%GRASS_INST_DIR%%/docs/html/i_spectral.png
+%%GRASS_INST_DIR%%/docs/html/i_tasscap_brightness.jpg
+%%GRASS_INST_DIR%%/docs/html/i_tasscap_greenness.jpg
+%%GRASS_INST_DIR%%/docs/html/i_tasscap_haze.jpg
+%%GRASS_INST_DIR%%/docs/html/i_tasscap_wetness.jpg
+%%GRASS_INST_DIR%%/docs/html/i_topo_corr_angles.png
%%GRASS_INST_DIR%%/docs/html/i_vi_arvi.png
%%GRASS_INST_DIR%%/docs/html/i_vi_gari.png
%%GRASS_INST_DIR%%/docs/html/i_vi_ndvi.png
@@ -966,7 +969,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/index.html
%%GRASS_INST_DIR%%/docs/html/jquery.fixedheadertable.min.js
%%GRASS_INST_DIR%%/docs/html/keywords.html
-%%GRASS_INST_DIR%%/docs/html/landsat_cluster.png
%%GRASS_INST_DIR%%/docs/html/legend.png
%%GRASS_INST_DIR%%/docs/html/lrs.html
%%GRASS_INST_DIR%%/docs/html/m.cogo.html
@@ -1002,7 +1004,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/parser_standard_options.html
%%GRASS_INST_DIR%%/docs/html/parser_standard_options.js
%%GRASS_INST_DIR%%/docs/html/pcurv.png
-%%GRASS_INST_DIR%%/docs/html/photo.camera.png
%%GRASS_INST_DIR%%/docs/html/pngdriver.html
%%GRASS_INST_DIR%%/docs/html/postscript.html
%%GRASS_INST_DIR%%/docs/html/postscript_graphical.html
@@ -1051,7 +1052,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/r.in.bin.html
%%GRASS_INST_DIR%%/docs/html/r.in.gdal.html
%%GRASS_INST_DIR%%/docs/html/r.in.gridatb.html
-%%LAS%%%%GRASS_INST_DIR%%/docs/html/r.in.lidar.html
%%GRASS_INST_DIR%%/docs/html/r.in.mat.html
%%GRASS_INST_DIR%%/docs/html/r.in.png.html
%%GRASS_INST_DIR%%/docs/html/r.in.poly.html
@@ -1187,7 +1187,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/r3.gwflow.html
%%GRASS_INST_DIR%%/docs/html/r3.in.ascii.html
%%GRASS_INST_DIR%%/docs/html/r3.in.bin.html
-%%LAS%%%%GRASS_INST_DIR%%/docs/html/r3.in.lidar.html
%%GRASS_INST_DIR%%/docs/html/r3.in.v5d.html
%%GRASS_INST_DIR%%/docs/html/r3.in.xyz.html
%%GRASS_INST_DIR%%/docs/html/r3.info.html
@@ -1198,7 +1197,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/r3.null.html
%%GRASS_INST_DIR%%/docs/html/r3.out.ascii.html
%%GRASS_INST_DIR%%/docs/html/r3.out.bin.html
-%%NETCDF%%%%GRASS_INST_DIR%%/docs/html/r3.out.netcdf.html
%%GRASS_INST_DIR%%/docs/html/r3.out.v5d.html
%%GRASS_INST_DIR%%/docs/html/r3.out.vtk.html
%%GRASS_INST_DIR%%/docs/html/r3.retile.html
@@ -1207,7 +1205,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/r3.timestamp.html
%%GRASS_INST_DIR%%/docs/html/r3.to.rast.html
%%GRASS_INST_DIR%%/docs/html/r3.to.rast.png
-%%LAS%%%%GRASS_INST_DIR%%/docs/html/r3_in_lidar.png
%%GRASS_INST_DIR%%/docs/html/r3.univar.html
%%GRASS_INST_DIR%%/docs/html/r3flow_flowlines.png
%%GRASS_INST_DIR%%/docs/html/r3flow_flowlines_color.png
@@ -1235,12 +1232,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/r_grow_distance_sea.png
%%GRASS_INST_DIR%%/docs/html/r_grow_distance_zoom.png
%%GRASS_INST_DIR%%/docs/html/r_gwflow_concept.png
-%%LAS%%%%GRASS_INST_DIR%%/docs/html/r_in_lidar.png
-%%LAS%%%%GRASS_INST_DIR%%/docs/html/r_in_lidar_base_raster.png
-%%LAS%%%%GRASS_INST_DIR%%/docs/html/r_in_lidar_binning_count.png
-%%LAS%%%%GRASS_INST_DIR%%/docs/html/r_in_lidar_binning_mean.png
-%%LAS%%%%GRASS_INST_DIR%%/docs/html/r_in_lidar_dem_mean3D.jpg
-%%LAS%%%%GRASS_INST_DIR%%/docs/html/r_in_lidar_zrange.png
%%GRASS_INST_DIR%%/docs/html/r_lake_lidar_dem.jpg
%%GRASS_INST_DIR%%/docs/html/r_li_dominance_formula.png
%%GRASS_INST_DIR%%/docs/html/r_li_edgedensity_formula_1.png
@@ -1288,10 +1279,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/raster_graphical.html
%%GRASS_INST_DIR%%/docs/html/rasterintro.html
%%GRASS_INST_DIR%%/docs/html/rcost_knightsmove.png
-%%GRASS_INST_DIR%%/docs/html/rgb_brovey321.jpg
-%%GRASS_INST_DIR%%/docs/html/rgb_ihs321.jpg
-%%GRASS_INST_DIR%%/docs/html/rgb_landsat321.jpg
-%%GRASS_INST_DIR%%/docs/html/rgb_pca321.jpg
%%GRASS_INST_DIR%%/docs/html/rhorizon_polar_plot.png
%%GRASS_INST_DIR%%/docs/html/rhorizon_shaded_dem_point.png
%%GRASS_INST_DIR%%/docs/html/rhorizon_singlepoint_plot.png
@@ -1361,15 +1348,10 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/t.vect.observe.strds.html
%%GRASS_INST_DIR%%/docs/html/t.vect.univar.html
%%GRASS_INST_DIR%%/docs/html/t.vect.what.strds.html
-%%GRASS_INST_DIR%%/docs/html/tasscap1.jpg
-%%GRASS_INST_DIR%%/docs/html/tasscap2.jpg
-%%GRASS_INST_DIR%%/docs/html/tasscap3.jpg
-%%GRASS_INST_DIR%%/docs/html/tasscap4.jpg
%%GRASS_INST_DIR%%/docs/html/tcurv.png
%%GRASS_INST_DIR%%/docs/html/temporal.html
%%GRASS_INST_DIR%%/docs/html/temporal_graphical.html
%%GRASS_INST_DIR%%/docs/html/temporalintro.html
-%%GRASS_INST_DIR%%/docs/html/terrain_correction.png
%%GRASS_INST_DIR%%/docs/html/test.r3flow.html
%%GRASS_INST_DIR%%/docs/html/test.raster3d.lib.html
%%GRASS_INST_DIR%%/docs/html/timeline_2D.jpg
@@ -1516,7 +1498,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/v.in.dxf.html
%%GRASS_INST_DIR%%/docs/html/v.in.e00.html
%%GRASS_INST_DIR%%/docs/html/v.in.geonames.html
-%%LAS%%%%GRASS_INST_DIR%%/docs/html/v.in.lidar.html
%%GRASS_INST_DIR%%/docs/html/v.in.lines.html
%%GRASS_INST_DIR%%/docs/html/v.in.mapgen.html
%%GRASS_INST_DIR%%/docs/html/v.in.ogr.html
@@ -1555,9 +1536,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/v.normal.html
%%GRASS_INST_DIR%%/docs/html/v.out.ascii.html
%%GRASS_INST_DIR%%/docs/html/v.out.dxf.html
-%%LAS%%%%GRASS_INST_DIR%%/docs/html/v.out.lidar.html
%%GRASS_INST_DIR%%/docs/html/v.out.ogr.html
-%%PGSQL%%%%GRASS_INST_DIR%%/docs/html/v.out.postgis.html
%%GRASS_INST_DIR%%/docs/html/v.out.pov.html
%%GRASS_INST_DIR%%/docs/html/v.out.svg.html
%%GRASS_INST_DIR%%/docs/html/v.out.vtk.html
@@ -1863,10 +1842,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/general_graphical.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/graphical_index.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/grass-dbf.1.gz
-%%MYSQL%%%%GRASS_INST_DIR%%/docs/man/man1/grass-mysql.1.gz
-%%ODBC%%%%GRASS_INST_DIR%%/docs/man/man1/grass-odbc.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/grass-ogr.1.gz
-%%PGSQL%%%%GRASS_INST_DIR%%/docs/man/man1/grass-pg.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/grass-sqlite.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/grass7.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/grass_database.1.gz
@@ -1979,7 +1955,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/r.in.bin.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.in.gdal.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.in.gridatb.1.gz
-%%LAS%%%%GRASS_INST_DIR%%/docs/man/man1/r.in.lidar.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.in.mat.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.in.png.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.in.poly.1.gz
@@ -2111,7 +2086,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/r3.gwflow.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r3.in.ascii.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r3.in.bin.1.gz
-%%LAS%%%%GRASS_INST_DIR%%/docs/man/man1/r3.in.lidar.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r3.in.v5d.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r3.in.xyz.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r3.info.1.gz
@@ -2122,7 +2096,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/r3.null.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r3.out.ascii.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r3.out.bin.1.gz
-%%NETCDF%%%%GRASS_INST_DIR%%/docs/man/man1/r3.out.netcdf.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r3.out.v5d.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r3.out.vtk.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r3.retile.1.gz
@@ -2334,7 +2307,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/v.in.dxf.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.in.e00.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.in.geonames.1.gz
-%%LAS%%%%GRASS_INST_DIR%%/docs/man/man1/v.in.lidar.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.in.lines.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.in.mapgen.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.in.ogr.1.gz
@@ -2373,9 +2345,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/v.normal.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.out.ascii.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.out.dxf.1.gz
-%%LAS%%%%GRASS_INST_DIR%%/docs/man/man1/v.out.lidar.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.out.ogr.1.gz
-%%PGSQL%%%%GRASS_INST_DIR%%/docs/man/man1/v.out.postgis.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.out.pov.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.out.svg.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.out.vtk.1.gz
@@ -2451,8 +2421,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/wxpyimgview.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/ximgview.1.gz
%%GRASS_INST_DIR%%/driver/db/dbf
-%%MYSQL%%%%GRASS_INST_DIR%%/driver/db/mysql
-%%ODBC%%%%GRASS_INST_DIR%%/driver/db/odbc
%%GRASS_INST_DIR%%/driver/db/ogr
%%GRASS_INST_DIR%%/driver/db/pg
%%GRASS_INST_DIR%%/driver/db/sqlite
@@ -4010,6 +3978,9 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/locale/fr/LC_MESSAGES/grasslibs.mo
%%GRASS_INST_DIR%%/locale/fr/LC_MESSAGES/grassmods.mo
%%GRASS_INST_DIR%%/locale/fr/LC_MESSAGES/grasswxpy.mo
+%%GRASS_INST_DIR%%/locale/hu/LC_MESSAGES/grasslibs.mo
+%%GRASS_INST_DIR%%/locale/hu/LC_MESSAGES/grassmods.mo
+%%GRASS_INST_DIR%%/locale/hu/LC_MESSAGES/grasswxpy.mo
%%GRASS_INST_DIR%%/locale/id_ID/LC_MESSAGES/grasslibs.mo
%%GRASS_INST_DIR%%/locale/id_ID/LC_MESSAGES/grassmods.mo
%%GRASS_INST_DIR%%/locale/id_ID/LC_MESSAGES/grasswxpy.mo
@@ -4204,7 +4175,6 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/scripts/v.what.strds
%%GRASS_INST_DIR%%/scripts/v.what.vect
%%GRASS_INST_DIR%%/scripts/wxpyimgview
-%%GRASS_INST_DIR%%/share/appdata/grass.appdata.xml
%%GRASS_INST_DIR%%/share/applications/grass.desktop
%%GRASS_INST_DIR%%/share/icons/hicolor/128x128/apps/grass.png
%%GRASS_INST_DIR%%/share/icons/hicolor/16x16/apps/grass.png
@@ -4222,6 +4192,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/share/icons/hicolor/8x8/apps/grass.png
%%GRASS_INST_DIR%%/share/icons/hicolor/96x96/apps/grass.png
%%GRASS_INST_DIR%%/share/icons/hicolor/scalable/apps/grass.svg
+%%GRASS_INST_DIR%%/share/metainfo/org.osgeo.grass.appdata.xml
%%GRASS_INST_DIR%%/tools/g.echo
%%GRASS_INST_DIR%%/tools/g.html2man.py
%%GRASS_INST_DIR%%/tools/ggroff.py
@@ -4231,6 +4202,39 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/tools/mkhtml.py
%%GRASS_INST_DIR%%/translation_status.json
%%GRASS_INST_DIR%%/translators.csv
+%%LAS%%%%GRASS_INST_DIR%%/bin/r.in.lidar
+%%LAS%%%%GRASS_INST_DIR%%/bin/r3.in.lidar
+%%LAS%%%%GRASS_INST_DIR%%/bin/v.in.lidar
+%%LAS%%%%GRASS_INST_DIR%%/bin/v.out.lidar
+%%LAS%%%%GRASS_INST_DIR%%/docs/html/r.in.lidar.html
+%%LAS%%%%GRASS_INST_DIR%%/docs/html/r3.in.lidar.html
+%%LAS%%%%GRASS_INST_DIR%%/docs/html/r3_in_lidar.png
+%%LAS%%%%GRASS_INST_DIR%%/docs/html/r_in_lidar.png
+%%LAS%%%%GRASS_INST_DIR%%/docs/html/r_in_lidar_base_raster.png
+%%LAS%%%%GRASS_INST_DIR%%/docs/html/r_in_lidar_binning_count.png
+%%LAS%%%%GRASS_INST_DIR%%/docs/html/r_in_lidar_binning_mean.png
+%%LAS%%%%GRASS_INST_DIR%%/docs/html/r_in_lidar_dem_mean3D.jpg
+%%LAS%%%%GRASS_INST_DIR%%/docs/html/r_in_lidar_zrange.png
+%%LAS%%%%GRASS_INST_DIR%%/docs/html/v.in.lidar.html
+%%LAS%%%%GRASS_INST_DIR%%/docs/html/v.out.lidar.html
+%%LAS%%%%GRASS_INST_DIR%%/docs/man/man1/r.in.lidar.1.gz
+%%LAS%%%%GRASS_INST_DIR%%/docs/man/man1/r3.in.lidar.1.gz
+%%LAS%%%%GRASS_INST_DIR%%/docs/man/man1/v.in.lidar.1.gz
+%%LAS%%%%GRASS_INST_DIR%%/docs/man/man1/v.out.lidar.1.gz
+%%MYSQL%%%%GRASS_INST_DIR%%/docs/html/grass-mysql.html
+%%MYSQL%%%%GRASS_INST_DIR%%/docs/man/man1/grass-mysql.1.gz
+%%MYSQL%%%%GRASS_INST_DIR%%/driver/db/mysql
+%%NETCDF%%%%GRASS_INST_DIR%%/bin/r3.out.netcdf
+%%NETCDF%%%%GRASS_INST_DIR%%/docs/html/r3.out.netcdf.html
+%%NETCDF%%%%GRASS_INST_DIR%%/docs/man/man1/r3.out.netcdf.1.gz
+%%ODBC%%%%GRASS_INST_DIR%%/docs/html/grass-odbc.html
+%%ODBC%%%%GRASS_INST_DIR%%/docs/man/man1/grass-odbc.1.gz
+%%ODBC%%%%GRASS_INST_DIR%%/driver/db/odbc
+%%PGSQL%%%%GRASS_INST_DIR%%/bin/v.out.postgis
+%%PGSQL%%%%GRASS_INST_DIR%%/docs/html/grass-pg.html
+%%PGSQL%%%%GRASS_INST_DIR%%/docs/html/v.out.postgis.html
+%%PGSQL%%%%GRASS_INST_DIR%%/docs/man/man1/grass-pg.1.gz
+%%PGSQL%%%%GRASS_INST_DIR%%/docs/man/man1/v.out.postgis.1.gz
@dir %%GRASS_INST_DIR%%/demolocation/PERMANENT/cats
@dir %%GRASS_INST_DIR%%/demolocation/PERMANENT/cell
@dir %%GRASS_INST_DIR%%/demolocation/PERMANENT/cell_misc