aboutsummaryrefslogtreecommitdiff
path: root/databases/grass7
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-06-19 04:48:55 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-06-19 04:48:55 +0000
commitd7eac4ef97beefdd5a66a41c492aba9cd45ce61a (patch)
treee49a7fdfa8429802f99f1376d6381b01f8f6bd87 /databases/grass7
parent8f23336f56fbe33137bfd5fd1370910e54116eb5 (diff)
downloadports-d7eac4ef97beefdd5a66a41c492aba9cd45ce61a.tar.gz
ports-d7eac4ef97beefdd5a66a41c492aba9cd45ce61a.zip
databases/grass7: unbreak on i386
It needs GCC to configure and build grass7 on i386. The v.in.pdal module is not available as some documentation pages. PR: 256055 Reported by: chris@crvintel.com Tested by: chris@crvintel.com
Diffstat (limited to 'databases/grass7')
-rw-r--r--databases/grass7/Makefile12
-rw-r--r--databases/grass7/pkg-plist26
2 files changed, 18 insertions, 20 deletions
diff --git a/databases/grass7/Makefile b/databases/grass7/Makefile
index 8369a075035b..7f42447a1759 100644
--- a/databases/grass7/Makefile
+++ b/databases/grass7/Makefile
@@ -25,7 +25,6 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/GPL.TXT
BROKEN_sparc64= Does not configure on sparc64
-BROKEN_i386= Does not configure on i386: Could not determine External PROJ major version
BUILD_DEPENDS= ${PY_NUMPY} \
${PYTHON_SITELIBDIR}/six.py:devel/py-six@${PY_FLAVOR}
@@ -135,12 +134,11 @@ ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386" && ${OSVERSION} < 1200000
-# clang 7.x and 8.x do not build properly on 11i386
-CPP= clang-cpp${LLVM_DEFAULT}
-CC= clang${LLVM_DEFAULT}
-CXX= clang++${LLVM_DEFAULT}
-BUILD_DEPENDS+= clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
+.if ${ARCH} == "i386"
+USE_GCC= yes
+PLIST_SUB+= NOTONI386="@comment "
+.else
+PLIST_SUB+= NOTONI386=""
.endif
.if !defined (GRASS_INST_DIR)
diff --git a/databases/grass7/pkg-plist b/databases/grass7/pkg-plist
index be992f74fad4..6d6e16aa8dc5 100644
--- a/databases/grass7/pkg-plist
+++ b/databases/grass7/pkg-plist
@@ -318,7 +318,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/bin/v.in.dxf
%%LAS%%%%GRASS_INST_DIR%%/bin/v.in.lidar
%%GRASS_INST_DIR%%/bin/v.in.ogr
-%%GRASS_INST_DIR%%/bin/v.in.pdal
+%%NOTONI386%%%%GRASS_INST_DIR%%/bin/v.in.pdal
%%GRASS_INST_DIR%%/bin/v.in.region
%%GRASS_INST_DIR%%/bin/v.info
%%GRASS_INST_DIR%%/bin/v.kcv
@@ -750,7 +750,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/htmldriver.html
%%GRASS_INST_DIR%%/docs/html/i_albedo_landsat5.png
%%GRASS_INST_DIR%%/docs/html/i_albedo_landsat7.png
-%%GRASS_INST_DIR%%/docs/html/i.atcorr.html
+%%NOTONI386%%%%GRASS_INST_DIR%%/docs/html/i.atcorr.html
%%GRASS_INST_DIR%%/docs/html/i_atcorr_B02_atcorr.png
%%GRASS_INST_DIR%%/docs/html/i_cluster_landsat_clustering.png
%%GRASS_INST_DIR%%/docs/html/i_colors_enhance_corrected.jpg
@@ -1259,7 +1259,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/r.surf.gauss.html
%%GRASS_INST_DIR%%/docs/html/r.surf.idw.html
%%GRASS_INST_DIR%%/docs/html/r.surf.random.html
-%%GRASS_INST_DIR%%/docs/html/r.terraflow.html
+%%NOTONI386%%%%GRASS_INST_DIR%%/docs/html/r.terraflow.html
%%GRASS_INST_DIR%%/docs/html/r.texture.html
%%GRASS_INST_DIR%%/docs/html/r.thin.html
%%GRASS_INST_DIR%%/docs/html/r.tile.html
@@ -1277,7 +1277,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/r.unpack.html
%%GRASS_INST_DIR%%/docs/html/r.uslek.html
%%GRASS_INST_DIR%%/docs/html/r.usler.html
-%%GRASS_INST_DIR%%/docs/html/r.viewshed.html
+%%NOTONI386%%%%GRASS_INST_DIR%%/docs/html/r.viewshed.html
%%GRASS_INST_DIR%%/docs/html/r.viewshed.png
%%GRASS_INST_DIR%%/docs/html/r.volume.html
%%GRASS_INST_DIR%%/docs/html/r.walk.html
@@ -1408,7 +1408,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/topic_aggregation.html
%%GRASS_INST_DIR%%/docs/html/topic_albedo.html
%%GRASS_INST_DIR%%/docs/html/topic_algebra.html
-%%GRASS_INST_DIR%%/docs/html/topic_atmospheric_correction.html
+%%NOTONI386%%%%GRASS_INST_DIR%%/docs/html/topic_atmospheric_correction.html
%%GRASS_INST_DIR%%/docs/html/topic_attribute_table.html
%%GRASS_INST_DIR%%/docs/html/topic_biomass.html
%%GRASS_INST_DIR%%/docs/html/topic_buffer.html
@@ -1500,7 +1500,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/topic_unit_test.html
%%GRASS_INST_DIR%%/docs/html/topic_vector.html
%%GRASS_INST_DIR%%/docs/html/topic_vegetation_index.html
-%%GRASS_INST_DIR%%/docs/html/topic_viewshed.html
+%%NOTONI386%%%%GRASS_INST_DIR%%/docs/html/topic_viewshed.html
%%GRASS_INST_DIR%%/docs/html/topic_visualization.html
%%GRASS_INST_DIR%%/docs/html/topic_volume.html
%%GRASS_INST_DIR%%/docs/html/topic_voxel.html
@@ -1630,7 +1630,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/v.in.lines.html
%%GRASS_INST_DIR%%/docs/html/v.in.mapgen.html
%%GRASS_INST_DIR%%/docs/html/v.in.ogr.html
-%%GRASS_INST_DIR%%/docs/html/v.in.pdal.html
+%%NOTONI386%%%%GRASS_INST_DIR%%/docs/html/v.in.pdal.html
%%GRASS_INST_DIR%%/docs/html/v.in.region.html
%%GRASS_INST_DIR%%/docs/html/v.in.wfs.html
%%GRASS_INST_DIR%%/docs/html/v.info.html
@@ -1911,7 +1911,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/htmldriver.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/i.albedo.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/i.aster.toar.1.gz
-%%GRASS_INST_DIR%%/docs/man/man1/i.atcorr.1.gz
+%%NOTONI386%%%%GRASS_INST_DIR%%/docs/man/man1/i.atcorr.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/i.biomass.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/i.cca.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/i.cluster.1.gz
@@ -2125,7 +2125,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/r.surf.gauss.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.surf.idw.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.surf.random.1.gz
-%%GRASS_INST_DIR%%/docs/man/man1/r.terraflow.1.gz
+%%NOTONI386%%%%GRASS_INST_DIR%%/docs/man/man1/r.terraflow.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.texture.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.thin.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.tile.1.gz
@@ -2141,7 +2141,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/r.unpack.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.uslek.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.usler.1.gz
-%%GRASS_INST_DIR%%/docs/man/man1/r.viewshed.1.gz
+%%NOTONI386%%%%GRASS_INST_DIR%%/docs/man/man1/r.viewshed.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.volume.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.walk.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.water.outlet.1.gz
@@ -2242,7 +2242,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/topic_aggregation.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_albedo.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_algebra.1.gz
-%%GRASS_INST_DIR%%/docs/man/man1/topic_atmospheric_correction.1.gz
+%%NOTONI386%%%%GRASS_INST_DIR%%/docs/man/man1/topic_atmospheric_correction.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_attribute_table.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_biomass.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_buffer.1.gz
@@ -2334,7 +2334,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/topic_unit_test.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_vector.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_vegetation_index.1.gz
-%%GRASS_INST_DIR%%/docs/man/man1/topic_viewshed.1.gz
+%%NOTONI386%%%%GRASS_INST_DIR%%/docs/man/man1/topic_viewshed.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_visualization.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_volume.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_voxel.1.gz
@@ -2385,7 +2385,7 @@ bin/grass%%VER%%
%%LAS%%%%GRASS_INST_DIR%%/docs/man/man1/v.in.lidar.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.in.mapgen.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.in.ogr.1.gz
-%%GRASS_INST_DIR%%/docs/man/man1/v.in.pdal.1.gz
+%%NOTONI386%%%%GRASS_INST_DIR%%/docs/man/man1/v.in.pdal.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.in.region.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.in.wfs.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.info.1.gz