aboutsummaryrefslogtreecommitdiff
path: root/databases/grass7
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-06-27 05:00:32 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-06-27 05:00:32 +0000
commitfe38b49addd2782e33be5fce1be8d196762c4e8e (patch)
treeea8f3a402ee0da453ab06ba2c13834fe658299e4 /databases/grass7
parentd65c9e396f4fb2be960279acb188212ab991a737 (diff)
downloadports-fe38b49addd2782e33be5fce1be8d196762c4e8e.tar.gz
ports-fe38b49addd2782e33be5fce1be8d196762c4e8e.zip
databases/grass7: Fix build on aarch64 and update to 7.8.3
- update to 7.8.3 - add patches to remove some noise from ctype - fix build on aarch64 (only r.terraflow module is problematic on aarch64) Reported by: mikael (aarch64) Approved by: tcberner (mentor), mikael (aarch64) Differential Revision: https://reviews.freebsd.org/D25331
Notes
Notes: svn path=/head/; revision=540559
Diffstat (limited to 'databases/grass7')
-rw-r--r--databases/grass7/Makefile40
-rw-r--r--databases/grass7/distinfo6
-rw-r--r--databases/grass7/files/patch-lib_python_ctypes_Makefile11
-rw-r--r--databases/grass7/files/patch-lib_python_ctypes_ctypesgencore_parser_preprocessor.py12
-rw-r--r--databases/grass7/pkg-plist15
5 files changed, 64 insertions, 20 deletions
diff --git a/databases/grass7/Makefile b/databases/grass7/Makefile
index 0021b463d29d..235485e9e0e1 100644
--- a/databases/grass7/Makefile
+++ b/databases/grass7/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= grass
-PORTVERSION= 7.8.2
-PORTREVISION= 2
+PORTVERSION= 7.8.3
CATEGORIES= databases geography
MASTER_SITES= https://grass.osgeo.org/%SUBDIR%/ \
http://grass.cict.fr/%SUBDIR%/ \
@@ -40,8 +39,8 @@ LIB_DEPENDS= libgdal.so:graphics/gdal \
RUN_DEPENDS= ${PY_NUMPY} \
${PYTHON_SITELIBDIR}/six.py:devel/py-six@${PY_FLAVOR}
-USES= blaslapack compiler:openmp fortran gl gmake gnome iconv \
- jpeg perl5 pkgconfig python:3.6+ readline shebangfix tk xorg
+USES= blaslapack compiler:c11 gl gmake gnome iconv \
+ jpeg perl5 pkgconfig python:3.6+ readline shebangfix xorg
SHEBANG_GLOB= *.py
SHEBANG_LANG= nviz
nviz_OLD_CMD= nviz
@@ -69,7 +68,11 @@ CONFIGURE_ARGS= --with-includes=${LOCALBASE}/include \
--with-geos=${LOCALBASE}/bin/geos-config \
--with-gdal=${LOCALBASE}/bin/gdal-config \
--with-pthread=yes \
- --with-openmp
+ --with-openmp \
+ --prefix=${LOCALBASE} \
+ --exec-prefix=${LOCALBASE}
+
+CFLAGS+= -std=c11
SUB_FILES= pkg-message
SUB_LIST= PYTHON_CMD=${PYTHON_CMD}
@@ -126,8 +129,14 @@ SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_F
ZSTD_CONFIGURE_WITH= zstd
ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "aarch64" || ${ARCH} == "riscv64"
+PLIST_SUB+= WOSBRK="@comment "
+.else
+PLIST_SUB+= WOSBRK=""
+.endif
.if !defined (GRASS_INST_DIR)
GRASS_INST_DIR= ${PORTNAME}${VER}
.endif
@@ -135,10 +144,10 @@ GRASS_INST_DIR= ${PORTNAME}${VER}
MANDIRS= ${PREFIX}/grass${VER}/docs/man/man1
post-patch:
- ${REINPLACE_CMD} -e \
- 's|-lblas|${BLASLIB}|g ; \
- s|-llapack|${LAPACKLIB}|g ; \
- s|g2c|f2c|g' ${WRKSRC}/configure
+# ${REINPLACE_CMD} -e \
+# 's|-lblas|${BLASLIB}|g ; \
+# s|-llapack|${LAPACKLIB}|g ; \
+# s|g2c|f2c|g' ${WRKSRC}/configure
${REINPLACE_CMD} -e \
's|make -C|$$(MAKE) -C| ; \
/^BINDIR/s|=.*|= $${DESTDIR}$${UNIX_BIN}| ; \
@@ -149,11 +158,13 @@ post-patch:
/rm /s| $$(INST_DIR)| $${DESTDIR}$${INST_DIR}|g ; \
/$$(MAKE) /s| $$(INST_DIR)| $${DESTDIR}$${INST_DIR}|g ; \
/^$$(INST_DIR)\//s|$$(INST_DIR)|$${DESTDIR}$${INST_DIR}|g ; \
- s|> $$(INST_DIR)|> $${DESTDIR}$${INST_DIR}|' ${WRKSRC}/include/Make/Install.make
+ s|> $$(INST_DIR)|> $${DESTDIR}$${INST_DIR}|' \
+ ${WRKSRC}/include/Make/Install.make
${REINPLACE_CMD} \
's|= python3|= ${PYTHON_CMD:T}|' ${WRKSRC}/include/Make/Platform.make.in
- ${REINPLACE_CMD} \
- "s|'make'|'gmake'|g" ${WRKSRC}/scripts/g.extension/g.extension.py
+ ${REINPLACE_CMD} -e \
+ "s|'make'|'gmake'|g; \
+ s|gcc|${CC}|" ${WRKSRC}/scripts/g.extension/g.extension.py
${REINPLACE_CMD} \
's|$$(ARCH)|$$(TARGET)|g' ${WRKSRC}/include/Make/Grass.make
# Replace hardcoded python interpreter to PYTHON_CMD
@@ -185,9 +196,6 @@ post-install:
for i in `${FIND} ${WRKSRC}/imagery -type f \( -name *jpg -o -name *png -o -name *gxm \) -print`; do \
${INSTALL_DATA} $$i ${STAGEDIR}${LOCALBASE}/${PORTNAME}${VER}/docs/html; \
done
-.for file in wms_base.py wms_drv.py wms_gdal_drv.py wms_cap_parsers.py srs.py
- ${INSTALL_SCRIPT} ${WRKSRC}/scripts/r.in.wms/${file} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/etc/r.in.wms/${file}
-.endfor
${INSTALL_SCRIPT} ${WRKSRC}/scripts/wxpyimgview/wxpyimgview_gui.py ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/etc/wxpyimgview_gui.py
${MKDIR} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/etc/d.polar
${INSTALL_DATA} ${WRKSRC}/scripts/d.polar/ps_defs.eps ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/etc/d.polar
diff --git a/databases/grass7/distinfo b/databases/grass7/distinfo
index ace71b10610d..7cadd6f064c4 100644
--- a/databases/grass7/distinfo
+++ b/databases/grass7/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1583004075
-SHA256 (grass-7.8.2.tar.gz) = 33576f7078f805b39ca20c2fa416ac79c64260c0581072a6dc7d813f53aa9abb
-SIZE (grass-7.8.2.tar.gz) = 60563736
+TIMESTAMP = 1591171725
+SHA256 (grass-7.8.3.tar.gz) = 25e79a0d513927b4f783a871f4f4bb7cd43c87ab4abd5523348b32411356a95b
+SIZE (grass-7.8.3.tar.gz) = 60292787
diff --git a/databases/grass7/files/patch-lib_python_ctypes_Makefile b/databases/grass7/files/patch-lib_python_ctypes_Makefile
new file mode 100644
index 000000000000..844ec4ead152
--- /dev/null
+++ b/databases/grass7/files/patch-lib_python_ctypes_Makefile
@@ -0,0 +1,11 @@
+--- lib/python/ctypes/Makefile.orig 2020-06-03 13:29:15 UTC
++++ lib/python/ctypes/Makefile
+@@ -63,7 +63,7 @@ endif
+
+ SED = sed
+ CTYPESGEN = ./ctypesgen.py
+-CTYPESFLAGS = --cpp "$(CC) -E $(CPPFLAGS) $(LFS_CFLAGS) $(MAC_FLAGS) $(EXTRA_CFLAGS) $(NLS_CFLAGS) $(DEFS) $(EXTRA_INC) $(INC) -D__GLIBC_HAVE_LONG_LONG"
++CTYPESFLAGS = --cpp "$(CC) -E $(CPPFLAGS) $(LFS_CFLAGS) $(MAC_FLAGS) $(EXTRA_CFLAGS) $(NLS_CFLAGS) $(DEFS) $(EXTRA_INC) $(INC) -D__GLIBC_HAVE_LONG_LONG -D__GNUCLIKE_BUILTIN_VARARGS -D__GNUCLIKE_BUILTIN_STDARG"
+ EXTRA_CLEAN_FILES := $(wildcard ctypesgencore/*.pyc) $(wildcard ctypesgencore/*/*.pyc)
+
+ ifneq ($(MINGW),)
diff --git a/databases/grass7/files/patch-lib_python_ctypes_ctypesgencore_parser_preprocessor.py b/databases/grass7/files/patch-lib_python_ctypes_ctypesgencore_parser_preprocessor.py
new file mode 100644
index 000000000000..11b8c047c88c
--- /dev/null
+++ b/databases/grass7/files/patch-lib_python_ctypes_ctypesgencore_parser_preprocessor.py
@@ -0,0 +1,12 @@
+--- lib/python/ctypes/ctypesgencore/parser/preprocessor.py.orig 2020-06-03 13:26:22 UTC
++++ lib/python/ctypes/ctypesgencore/parser/preprocessor.py
+@@ -123,7 +123,8 @@ class PreprocessorParser(object):
+ def __init__(self, options, cparser):
+ self.defines = ["inline=", "__inline__=", "__extension__=",
+ "_Bool=uint8_t", "__const=const", "__asm__(x)=",
+- "__asm(x)=", "CTYPESGEN=1"]
++ "__asm(x)=", "CTYPESGEN=1",
++ "__attribute__(x)=", "__aligned(x)=", "_Noreturn="]
+
+ # On OSX, explicitly add these defines to keep from getting syntax
+ # errors in the OSX standard headers.
diff --git a/databases/grass7/pkg-plist b/databases/grass7/pkg-plist
index 0e2dfff5b99b..4e788ffcb3ff 100644
--- a/databases/grass7/pkg-plist
+++ b/databases/grass7/pkg-plist
@@ -240,7 +240,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/bin/r.surf.gauss
%%GRASS_INST_DIR%%/bin/r.surf.idw
%%GRASS_INST_DIR%%/bin/r.surf.random
-%%GRASS_INST_DIR%%/bin/r.terraflow
+%%WOSBRK%%%%GRASS_INST_DIR%%/bin/r.terraflow
%%GRASS_INST_DIR%%/bin/r.texture
%%GRASS_INST_DIR%%/bin/r.thin
%%GRASS_INST_DIR%%/bin/r.tile
@@ -318,6 +318,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/bin/v.in.dxf
%%LAS%%%%GRASS_INST_DIR%%/bin/v.in.lidar
%%GRASS_INST_DIR%%/bin/v.in.ogr
+%%GRASS_INST_DIR%%/bin/v.in.pdal
%%GRASS_INST_DIR%%/bin/v.in.region
%%GRASS_INST_DIR%%/bin/v.info
%%GRASS_INST_DIR%%/bin/v.kcv
@@ -747,6 +748,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/htmldriver.html
%%GRASS_INST_DIR%%/docs/html/i_albedo_landsat5.png
%%GRASS_INST_DIR%%/docs/html/i_albedo_landsat7.png
+%%GRASS_INST_DIR%%/docs/html/i.atcorr.html
%%GRASS_INST_DIR%%/docs/html/i_atcorr_B02_atcorr.png
%%GRASS_INST_DIR%%/docs/html/i_cluster_landsat_clustering.png
%%GRASS_INST_DIR%%/docs/html/i_colors_enhance_corrected.jpg
@@ -1251,6 +1253,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/r.surf.gauss.html
%%GRASS_INST_DIR%%/docs/html/r.surf.idw.html
%%GRASS_INST_DIR%%/docs/html/r.surf.random.html
+%%GRASS_INST_DIR%%/docs/html/r.terraflow.html
%%GRASS_INST_DIR%%/docs/html/r.texture.html
%%GRASS_INST_DIR%%/docs/html/r.thin.html
%%GRASS_INST_DIR%%/docs/html/r.tile.html
@@ -1268,6 +1271,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/r.unpack.html
%%GRASS_INST_DIR%%/docs/html/r.uslek.html
%%GRASS_INST_DIR%%/docs/html/r.usler.html
+%%GRASS_INST_DIR%%/docs/html/r.viewshed.html
%%GRASS_INST_DIR%%/docs/html/r.viewshed.png
%%GRASS_INST_DIR%%/docs/html/r.volume.html
%%GRASS_INST_DIR%%/docs/html/r.walk.html
@@ -1399,6 +1403,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/topic_aggregation.html
%%GRASS_INST_DIR%%/docs/html/topic_albedo.html
%%GRASS_INST_DIR%%/docs/html/topic_algebra.html
+%%GRASS_INST_DIR%%/docs/html/topic_atmospheric_correction.html
%%GRASS_INST_DIR%%/docs/html/topic_attribute_table.html
%%GRASS_INST_DIR%%/docs/html/topic_biomass.html
%%GRASS_INST_DIR%%/docs/html/topic_buffer.html
@@ -1490,6 +1495,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/topic_unit_test.html
%%GRASS_INST_DIR%%/docs/html/topic_vector.html
%%GRASS_INST_DIR%%/docs/html/topic_vegetation_index.html
+%%GRASS_INST_DIR%%/docs/html/topic_viewshed.html
%%GRASS_INST_DIR%%/docs/html/topic_visualization.html
%%GRASS_INST_DIR%%/docs/html/topic_volume.html
%%GRASS_INST_DIR%%/docs/html/topic_voxel.html
@@ -1619,6 +1625,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/html/v.in.lines.html
%%GRASS_INST_DIR%%/docs/html/v.in.mapgen.html
%%GRASS_INST_DIR%%/docs/html/v.in.ogr.html
+%%GRASS_INST_DIR%%/docs/html/v.in.pdal.html
%%GRASS_INST_DIR%%/docs/html/v.in.region.html
%%GRASS_INST_DIR%%/docs/html/v.in.wfs.html
%%GRASS_INST_DIR%%/docs/html/v.info.html
@@ -1899,6 +1906,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/htmldriver.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/i.albedo.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/i.aster.toar.1.gz
+%%GRASS_INST_DIR%%/docs/man/man1/i.atcorr.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/i.biomass.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/i.cca.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/i.cluster.1.gz
@@ -2112,6 +2120,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/r.surf.gauss.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.surf.idw.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.surf.random.1.gz
+%%GRASS_INST_DIR%%/docs/man/man1/r.terraflow.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.texture.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.thin.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.tile.1.gz
@@ -2127,6 +2136,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/r.unpack.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.uslek.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.usler.1.gz
+%%GRASS_INST_DIR%%/docs/man/man1/r.viewshed.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.volume.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.walk.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/r.water.outlet.1.gz
@@ -2228,6 +2238,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/topic_aggregation.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_albedo.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_algebra.1.gz
+%%GRASS_INST_DIR%%/docs/man/man1/topic_atmospheric_correction.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_attribute_table.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_biomass.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_buffer.1.gz
@@ -2319,6 +2330,7 @@ bin/grass%%VER%%
%%GRASS_INST_DIR%%/docs/man/man1/topic_unit_test.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_vector.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_vegetation_index.1.gz
+%%GRASS_INST_DIR%%/docs/man/man1/topic_viewshed.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_visualization.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_volume.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/topic_voxel.1.gz
@@ -2369,6 +2381,7 @@ bin/grass%%VER%%
%%LAS%%%%GRASS_INST_DIR%%/docs/man/man1/v.in.lidar.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.in.mapgen.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.in.ogr.1.gz
+%%GRASS_INST_DIR%%/docs/man/man1/v.in.pdal.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.in.region.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.in.wfs.1.gz
%%GRASS_INST_DIR%%/docs/man/man1/v.info.1.gz