aboutsummaryrefslogtreecommitdiff
path: root/databases/hbase
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2016-03-19 22:01:43 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2016-03-19 22:01:43 +0000
commit23717e3f645b42194848bbc53de19bbfbdc210d3 (patch)
tree15196ce2a4d7358a20045cc1bea9135e41e6f3ee /databases/hbase
parentd70ee611a231c6d2553ee23c42755a3f5cd5f501 (diff)
downloadports-23717e3f645b42194848bbc53de19bbfbdc210d3.tar.gz
ports-23717e3f645b42194848bbc53de19bbfbdc210d3.zip
Update to version 1.2.0
PR: 207549 Submitted by: Kevin Bowling <kbowling@freebsd.org>
Notes
Notes: svn path=/head/; revision=411424
Diffstat (limited to 'databases/hbase')
-rw-r--r--databases/hbase/Makefile12
-rw-r--r--databases/hbase/distinfo8
-rw-r--r--databases/hbase/files/extra-patch-hbase-annotations-pom.xml11
-rw-r--r--databases/hbase/pkg-plist33
4 files changed, 36 insertions, 28 deletions
diff --git a/databases/hbase/Makefile b/databases/hbase/Makefile
index e92cb01e16f2..8b8d898643a6 100644
--- a/databases/hbase/Makefile
+++ b/databases/hbase/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= hbase
-PORTVERSION= 1.1.2
+PORTVERSION= 1.2.0
CATEGORIES= databases java
MASTER_SITES= APACHE/${PORTNAME}/${PORTVERSION} \
LOCAL/demon/:maven
-DISTFILES= ${DISTNAME}-src${EXTRACT_SUFX} FreeBSD-hbase-${PORTVERSION}-maven-repository.tar.gz:maven
+DISTFILES= ${DISTNAME}-src${EXTRACT_SUFX} FreeBSD-${PORTNAME}-${PORTVERSION}-maven-repository.tar.gz:maven
DIST_SUBDIR= hadoop
MAINTAINER= demon@FreeBSD.org
@@ -55,8 +55,8 @@ PLIST_SUB= HBASE_USER=${HBASE_USER} \
.include <bsd.port.pre.mk>
.if ${JAVA_PORT_VERSION:M1.8.*}
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-hbase-annotations-pom.xml
-MVN_JDK18= -DcompileSource=1.8
+JDK18_PROFILE= ,build-with-jdk8
+JDK18_SOURCE= -DcompileSource=1.8
.endif
post-patch:
@@ -64,8 +64,8 @@ post-patch:
${RM} ${WRKSRC}/conf/hbase-env.sh.bak ${WRKSRC}/conf/hbase-env.sh.orig
do-build:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${LOCALBASE}/share/java/maven3/bin/mvn -Dmaven.repo.local=${WRKDIR}/m2 --offline clean install -Prelease,native -DskipTests ${MVN_JDK18}
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${LOCALBASE}/share/java/maven3/bin/mvn -Dmaven.repo.local=${WRKDIR}/m2 --offline install -DskipTests site assembly:single -Prelease,native ${MVN_JDK18}
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${LOCALBASE}/share/java/maven3/bin/mvn -Dmaven.repo.local=${WRKDIR}/m2 --offline clean install -Prelease,native${JDK18_PROFILE} -DskipTests ${JDK18_SOURCE}
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${LOCALBASE}/share/java/maven3/bin/mvn -Dmaven.repo.local=${WRKDIR}/m2 --offline install -DskipTests site assembly:single -Prelease,native${JDK18_PROFILE} ${JDK18_SOURCE}
post-build:
cd ${WRKSRC}/hbase-assembly/target && ${TAR} xf ${PORTNAME}-${PORTVERSION}-bin.tar.gz
diff --git a/databases/hbase/distinfo b/databases/hbase/distinfo
index 6403e41b3782..96942af4d7dd 100644
--- a/databases/hbase/distinfo
+++ b/databases/hbase/distinfo
@@ -1,4 +1,4 @@
-SHA256 (hadoop/hbase-1.1.2-src.tar.gz) = f107753b41786bdfa255d9fb2ba0ca2a3dc57c390a615b6677c8fcee644ddfd7
-SIZE (hadoop/hbase-1.1.2-src.tar.gz) = 15625945
-SHA256 (hadoop/FreeBSD-hbase-1.1.2-maven-repository.tar.gz) = 47a8560697a6716d5551a4facb4d4ad2ca814a5b86d5fdbfdd67cc17cdd25d63
-SIZE (hadoop/FreeBSD-hbase-1.1.2-maven-repository.tar.gz) = 276578582
+SHA256 (hadoop/hbase-1.2.0-src.tar.gz) = 35e4169308bb1ec42f182180f48e1ecabd0066f01577e2a9c1256536620d3857
+SIZE (hadoop/hbase-1.2.0-src.tar.gz) = 15953631
+SHA256 (hadoop/FreeBSD-hbase-1.2.0-maven-repository.tar.gz) = 042d213e8cd02001fe86a5d394ae38784dc2ff0669979c7b65ccde6931670808
+SIZE (hadoop/FreeBSD-hbase-1.2.0-maven-repository.tar.gz) = 271950287
diff --git a/databases/hbase/files/extra-patch-hbase-annotations-pom.xml b/databases/hbase/files/extra-patch-hbase-annotations-pom.xml
deleted file mode 100644
index c4627775b897..000000000000
--- a/databases/hbase/files/extra-patch-hbase-annotations-pom.xml
+++ /dev/null
@@ -1,11 +0,0 @@
---- hbase-annotations/pom.xml.orig 2015-11-19 17:45:45.996448000 +0300
-+++ hbase-annotations/pom.xml 2015-11-19 17:45:58.778797000 +0300
-@@ -35,7 +35,7 @@
- <dependency>
- <groupId>jdk.tools</groupId>
- <artifactId>jdk.tools</artifactId>
-- <version>1.7</version>
-+ <version>1.8</version>
- <scope>system</scope>
- <systemPath>${java.home}/../lib/tools.jar</systemPath>
- </dependency>
diff --git a/databases/hbase/pkg-plist b/databases/hbase/pkg-plist
index 3909a7d57205..9a73e2c33987 100644
--- a/databases/hbase/pkg-plist
+++ b/databases/hbase/pkg-plist
@@ -47,6 +47,7 @@ hbase/hbase-webapps/static/jumping-orca_rotated_12percent.png
hbase/hbase-webapps/thrift/WEB-INF/web.xml
hbase/hbase-webapps/thrift/index.html
hbase/lib/activation-1.1.jar
+hbase/lib/antisamy-1.4.3.jar
hbase/lib/aopalliance-1.0.jar
hbase/lib/apacheds-i18n-2.0.0-M15.jar
hbase/lib/apacheds-kerberos-codec-2.0.0-M15.jar
@@ -54,16 +55,21 @@ hbase/lib/api-asn1-api-1.0.0-M20.jar
hbase/lib/api-util-1.0.0-M20.jar
hbase/lib/asm-3.1.jar
hbase/lib/avro-1.7.4.jar
+hbase/lib/batik-css-1.7.jar
+hbase/lib/batik-ext-1.7.jar
+hbase/lib/batik-util-1.7.jar
+hbase/lib/bsh-core-2.0b4.jar
hbase/lib/commons-beanutils-1.7.0.jar
-hbase/lib/commons-beanutils-core-1.8.0.jar
+hbase/lib/commons-beanutils-core-1.7.0.jar
hbase/lib/commons-cli-1.2.jar
hbase/lib/commons-codec-1.9.jar
-hbase/lib/commons-collections-3.2.1.jar
+hbase/lib/commons-collections-3.2.2.jar
hbase/lib/commons-compress-1.4.1.jar
hbase/lib/commons-configuration-1.6.jar
hbase/lib/commons-daemon-1.0.13.jar
hbase/lib/commons-digester-1.8.jar
hbase/lib/commons-el-1.0.jar
+hbase/lib/commons-fileupload-1.2.jar
hbase/lib/commons-httpclient-3.1.jar
hbase/lib/commons-io-2.4.jar
hbase/lib/commons-lang-2.6.jar
@@ -72,6 +78,7 @@ hbase/lib/commons-math-2.2.jar
hbase/lib/commons-math3-3.1.1.jar
hbase/lib/commons-net-3.1.jar
hbase/lib/disruptor-3.3.0.jar
+hbase/lib/esapi-2.1.0.jar
hbase/lib/findbugs-annotations-1.3.9-1.jar
hbase/lib/guava-12.0.1.jar
hbase/lib/guice-3.0.jar
@@ -82,6 +89,7 @@ hbase/lib/hbase-client-%%PORTVERSION%%.jar
hbase/lib/hbase-common-%%PORTVERSION%%-tests.jar
hbase/lib/hbase-common-%%PORTVERSION%%.jar
hbase/lib/hbase-examples-%%PORTVERSION%%.jar
+hbase/lib/hbase-external-blockcache-%%PORTVERSION%%.jar
hbase/lib/hbase-hadoop-compat-%%PORTVERSION%%.jar
hbase/lib/hbase-hadoop2-compat-%%PORTVERSION%%.jar
hbase/lib/hbase-it-%%PORTVERSION%%-tests.jar
@@ -97,12 +105,12 @@ hbase/lib/hbase-shell-%%PORTVERSION%%.jar
hbase/lib/hbase-thrift-%%PORTVERSION%%.jar
hbase/lib/htrace-core-3.1.0-incubating.jar
hbase/lib/httpclient-4.2.5.jar
-hbase/lib/httpcore-4.1.3.jar
+hbase/lib/httpcore-4.4.1.jar
hbase/lib/jackson-core-asl-1.9.13.jar
hbase/lib/jackson-jaxrs-1.9.13.jar
hbase/lib/jackson-mapper-asl-1.9.13.jar
hbase/lib/jackson-xc-1.9.13.jar
-hbase/lib/jamon-runtime-2.3.1.jar
+hbase/lib/jamon-runtime-2.4.1.jar
hbase/lib/jasper-compiler-5.5.23.jar
hbase/lib/jasper-runtime-5.5.23.jar
hbase/lib/javax.inject-1.jar
@@ -126,13 +134,13 @@ hbase/lib/jsch-0.1.42.jar
hbase/lib/jsp-2.1-6.1.14.jar
hbase/lib/jsp-api-2.1-6.1.14.jar
hbase/lib/jsr305-1.3.9.jar
-hbase/lib/junit-4.11.jar
+hbase/lib/junit-4.12.jar
hbase/lib/leveldbjni-all-1.8.jar
-hbase/lib/libthrift-0.9.0.jar
+hbase/lib/libthrift-0.9.3.jar
hbase/lib/log4j-1.2.17.jar
hbase/lib/metrics-core-2.2.0.jar
hbase/lib/native/libmlockall_agent.so
-hbase/lib/netty-3.2.4.Final.jar
+hbase/lib/nekohtml-1.9.12.jar
hbase/lib/netty-all-4.0.23.Final.jar
hbase/lib/paranamer-2.3.jar
hbase/lib/protobuf-java-2.5.0.jar
@@ -147,6 +155,7 @@ hbase/lib/ruby/hbase/visibility_labels.rb
hbase/lib/ruby/irb/hirb.rb
hbase/lib/ruby/shell.rb
hbase/lib/ruby/shell/commands.rb
+hbase/lib/ruby/shell/commands/abort_procedure.rb
hbase/lib/ruby/shell/commands/add_labels.rb
hbase/lib/ruby/shell/commands/add_peer.rb
hbase/lib/ruby/shell/commands/alter.rb
@@ -203,12 +212,18 @@ hbase/lib/ruby/shell/commands/list_labels.rb
hbase/lib/ruby/shell/commands/list_namespace.rb
hbase/lib/ruby/shell/commands/list_namespace_tables.rb
hbase/lib/ruby/shell/commands/list_peers.rb
+hbase/lib/ruby/shell/commands/list_procedures.rb
hbase/lib/ruby/shell/commands/list_quotas.rb
hbase/lib/ruby/shell/commands/list_replicated_tables.rb
+hbase/lib/ruby/shell/commands/list_security_capabilities.rb
hbase/lib/ruby/shell/commands/list_snapshots.rb
+hbase/lib/ruby/shell/commands/locate_region.rb
hbase/lib/ruby/shell/commands/major_compact.rb
hbase/lib/ruby/shell/commands/merge_region.rb
hbase/lib/ruby/shell/commands/move.rb
+hbase/lib/ruby/shell/commands/normalize.rb
+hbase/lib/ruby/shell/commands/normalizer_enabled.rb
+hbase/lib/ruby/shell/commands/normalizer_switch.rb
hbase/lib/ruby/shell/commands/put.rb
hbase/lib/ruby/shell/commands/remove_peer.rb
hbase/lib/ruby/shell/commands/remove_peer_tableCFs.rb
@@ -243,7 +258,11 @@ hbase/lib/slf4j-api-1.7.7.jar
hbase/lib/slf4j-log4j12-1.7.5.jar
hbase/lib/snappy-java-1.0.4.1.jar
hbase/lib/spymemcached-2.11.6.jar
+hbase/lib/xalan-2.7.0.jar
hbase/lib/xmlenc-0.52.jar
+hbase/lib/xml-apis-1.3.03.jar
+hbase/lib/xml-apis-ext-1.3.04.jar
+hbase/lib/xom-1.2.5.jar
hbase/lib/xz-1.0.jar
hbase/lib/zookeeper-3.4.6.jar
@dir(%%HBASE_USER%%,%%HBASE_GROUP%%,) %%HBASE_RUNDIR%%