aboutsummaryrefslogtreecommitdiff
path: root/databases/hbase
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2015-10-16 18:15:11 +0000
committerSteve Wills <swills@FreeBSD.org>2015-10-16 18:15:11 +0000
commitcecb38bac28d64ac3bb93665e27540d32af02c7e (patch)
treeb90aa46cb6d7c1480fe887554982a317a980cafe /databases/hbase
parent8cfa3d782c6a33c8af1d4bd7fd0c2f14ebcf4d8e (diff)
downloadports-cecb38bac28d64ac3bb93665e27540d32af02c7e.tar.gz
ports-cecb38bac28d64ac3bb93665e27540d32af02c7e.zip
databases/hbase: fix build with OpenJDK8
PR: 203506 Approved by: maintainer timeout (demon, >2 weeks)
Notes
Notes: svn path=/head/; revision=399496
Diffstat (limited to 'databases/hbase')
-rw-r--r--databases/hbase/Makefile9
-rw-r--r--databases/hbase/files/extra-patch-PoolMap.java17
-rw-r--r--databases/hbase/files/extra-patch-pom.xml10
3 files changed, 35 insertions, 1 deletions
diff --git a/databases/hbase/Makefile b/databases/hbase/Makefile
index 0f0fcaa43b74..1e3fd0879101 100644
--- a/databases/hbase/Makefile
+++ b/databases/hbase/Makefile
@@ -52,6 +52,13 @@ PLIST_SUB= HBASE_USER=${HBASE_USER} \
HBASE_RUNDIR=${HBASE_RUNDIR} \
PORTVERSION="${PORTVERSION}"
+.include <bsd.port.pre.mk>
+
+.if ${JAVA_PORT_VERSION:M1.8.*}
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-PoolMap.java \
+ ${FILESDIR}/extra-patch-pom.xml
+.endif
+
post-patch:
${REINPLACE_CMD} -e "s#%%ETCDIR%%#${ETCDIR}#" ${WRKSRC}/conf/hbase-env.sh ${WRKSRC}/bin/hbase
${RM} ${WRKSRC}/conf/hbase-env.sh.bak ${WRKSRC}/conf/hbase-env.sh.orig
@@ -77,4 +84,4 @@ do-install:
${MKDIR} ${STAGEDIR}${HBASE_LOGDIR}
${MKDIR} ${STAGEDIR}${HBASE_RUNDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/databases/hbase/files/extra-patch-PoolMap.java b/databases/hbase/files/extra-patch-PoolMap.java
new file mode 100644
index 000000000000..ee80f39f80a1
--- /dev/null
+++ b/databases/hbase/files/extra-patch-PoolMap.java
@@ -0,0 +1,17 @@
+--- hbase-client/src/main/java/org/apache/hadoop/hbase/util/PoolMap.java.orig 2014-12-16 06:16:53 UTC
++++ hbase-client/src/main/java/org/apache/hadoop/hbase/util/PoolMap.java
+@@ -93,14 +93,6 @@ public class PoolMap<K, V> implements Ma
+ return null;
+ }
+
+- /**
+- * @deprecated Will be removed for Java 8, use {@link #removeValue} instead
+- */
+- @Deprecated
+- public boolean remove(K key, V value) {
+- return removeValue(key, value);
+- }
+-
+ public boolean removeValue(K key, V value) {
+ Pool<V> pool = pools.get(key);
+ boolean res = false;
diff --git a/databases/hbase/files/extra-patch-pom.xml b/databases/hbase/files/extra-patch-pom.xml
new file mode 100644
index 000000000000..ea5679340918
--- /dev/null
+++ b/databases/hbase/files/extra-patch-pom.xml
@@ -0,0 +1,10 @@
+--- pom.xml.orig 2015-10-02 13:51:13.974582000 +0000
++++ pom.xml 2015-10-02 13:51:17.416694000 +0000
+@@ -2064,6 +2064,7 @@
+ <version>2.9.1</version>
+ <configuration>
+ <maxmemory>2048m</maxmemory>
++ <additionalparam>-Xdoclint:none</additionalparam>
+ </configuration>
+ <reportSets>
+ <reportSet>