aboutsummaryrefslogtreecommitdiff
path: root/databases/hsqldb
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2006-02-16 16:06:00 +0000
committerHerve Quiroz <hq@FreeBSD.org>2006-02-16 16:06:00 +0000
commit653b4bf541de5ccf82f0ec8c2a7f3f67fcf10a80 (patch)
tree22c2f6c1a9244f3c01831cb21e6005af798903af /databases/hsqldb
parentdb81573b3ec923f549343edf7c35bb8a7a1e5bfa (diff)
downloadports-653b4bf541de5ccf82f0ec8c2a7f3f67fcf10a80.tar.gz
ports-653b4bf541de5ccf82f0ec8c2a7f3f67fcf10a80.zip
HSQLDB is the leading SQL relational database engine written in Java. It has a
JDBC driver and supports a rich subset of ANSI-92 SQL (BNF tree format) plus SQL 99 and 2003 enhancements. It offers a small (less than 100k in one version for applets), fast database engine which offers both in-memory and disk-based tables and supports embedded and server modes. Additionally, it includes tools such as a minimal web server, in-memory query and management tools (can be run as applets) and a number of demonstration examples. WWW: http://hsqldb.org/ PR: 93320 Submitted by: Michael Winking <mwfp@foldl.net>
Notes
Notes: svn path=/head/; revision=156182
Diffstat (limited to 'databases/hsqldb')
-rw-r--r--databases/hsqldb/Makefile51
-rw-r--r--databases/hsqldb/distinfo3
-rw-r--r--databases/hsqldb/pkg-descr9
3 files changed, 63 insertions, 0 deletions
diff --git a/databases/hsqldb/Makefile b/databases/hsqldb/Makefile
new file mode 100644
index 000000000000..84b2e89f6830
--- /dev/null
+++ b/databases/hsqldb/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: hsqldb
+# Date created: 14 Feb 2006
+# Whom: Michael Winking <mwfp@foldl.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hsqldb
+PORTVERSION= 1.8.0.2
+CATEGORIES= databases java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= hsqldb
+DISTNAME= hsqldb_${PORTVERSION:S/./_/g}
+EXTRACT_SUFX= .zip
+
+MAINTAINER= mwfp@foldl.net
+COMMENT= An embeddable SQL database written in Java
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+USE_ANT= yes
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+BUILD_WRKSRC= ${WRKSRC}/build
+ALL_TARGET= hsqldb hsqljdbc
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar %%JAVAJARDIR%%/hsqljdbc.jar
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= hsqlFindFile.html hsqldb_lic.txt hypersonic_lic.txt guide images
+.endif
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR files to ${JAVAJARDIR}..."
+ @${INSTALL_DATA} ${WRKSRC}/lib/hsqldb.jar \
+ ${JAVAJARDIR}/hsqldb.jar
+ @${INSTALL_DATA} ${WRKSRC}/lib/hsqljdbc.jar \
+ ${JAVAJARDIR}/hsqljdbc.jar
+ @${ECHO_MSG} " [DONE]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/doc && ${FIND} guide images \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
+ @${INSTALL_DATA} ${WRKSRC}/doc/hsqlFindFile.html \
+ ${WRKSRC}/doc/hsqldb_lic.txt \
+ ${WRKSRC}/doc/hypersonic_lic.txt \
+ ${DOCSDIR}/
+ @${ECHO_MSG} " [DONE]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/hsqldb/distinfo b/databases/hsqldb/distinfo
new file mode 100644
index 000000000000..75600e2c2c7d
--- /dev/null
+++ b/databases/hsqldb/distinfo
@@ -0,0 +1,3 @@
+MD5 (hsqldb_1_8_0_2.zip) = c4a70d1fefdc2729a59c3b6b45fc88a3
+SHA256 (hsqldb_1_8_0_2.zip) = f21e932b1cec5fca9f38ee6d880a6a0b3986824c9a78a5497180a597af4ecc55
+SIZE (hsqldb_1_8_0_2.zip) = 3212934
diff --git a/databases/hsqldb/pkg-descr b/databases/hsqldb/pkg-descr
new file mode 100644
index 000000000000..6c3eca089490
--- /dev/null
+++ b/databases/hsqldb/pkg-descr
@@ -0,0 +1,9 @@
+HSQLDB is the leading SQL relational database engine written in Java. It has a
+JDBC driver and supports a rich subset of ANSI-92 SQL (BNF tree format) plus
+SQL 99 and 2003 enhancements. It offers a small (less than 100k in one version
+for applets), fast database engine which offers both in-memory and disk-based
+tables and supports embedded and server modes. Additionally, it includes tools
+such as a minimal web server, in-memory query and management tools (can be run
+as applets) and a number of demonstration examples.
+
+WWW: http://hsqldb.org/