aboutsummaryrefslogtreecommitdiff
path: root/databases/ip4r
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 13:48:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 13:48:25 +0000
commit1604951b3093e548a7245a9a4de33403f76ba72f (patch)
treec4e49df9c764236863400586b044b0f0825c53ed /databases/ip4r
parentf9091fd2dae6e339dde03346a01e24036dd344f1 (diff)
downloadports-1604951b3093e548a7245a9a4de33403f76ba72f.tar.gz
ports-1604951b3093e548a7245a9a4de33403f76ba72f.zip
Convert to USES=pgsql
While here: databases/pg_reorg - stagify databases/iplike - convert to USES=libtool - strip binarie databases/ip4r - strip binaries databases/postgresql-libpgeasy - convert to USES=libtool - strip binaries - stagify databases/postgresql-libpqxx - convert to USES=libtool - strip binaries databases/postgresql-libpqxx3 - convert to USES=libtool - strip binaries
Notes
Notes: svn path=/head/; revision=353002
Diffstat (limited to 'databases/ip4r')
-rw-r--r--databases/ip4r/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/databases/ip4r/Makefile b/databases/ip4r/Makefile
index 7b0cfba56acb..464cc448b146 100644
--- a/databases/ip4r/Makefile
+++ b/databases/ip4r/Makefile
@@ -9,21 +9,20 @@ MASTER_SITES= http://pgfoundry.org/frs/download.php/3380/
MAINTAINER= tobez@FreeBSD.org
COMMENT= IP address and IP range index types for PostgreSQL
-USE_PGSQL= YES
-USE_GMAKE= YES
+USES= gmake pgsql
MAKE_ARGS= USE_PGXS=1
# In order to make this port PREFIX-safe, we override the install target
# and install the three files manually
-NO_STAGE= yes
do-install:
- @${INSTALL} -m ${BINMODE} ${WRKSRC}/ip4r.so ${PREFIX}/lib/postgresql
- @${MKDIR} ${PREFIX}/share/postgresql/contrib
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/postgresql
+ @${INSTALL_LIB} -m ${BINMODE} ${WRKSRC}/ip4r.so ${STAGEDIR}${PREFIX}/lib/postgresql
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/postgresql/contrib
@${INSTALL_DATA} ${WRKSRC}/ip4r.sql \
- ${PREFIX}/share/postgresql/contrib
- @${MKDIR} ${PREFIX}/share/doc/postgresql/contrib
+ ${STAGEDIR}${PREFIX}/share/postgresql/contrib
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/postgresql/contrib
@${INSTALL_DATA} ${WRKSRC}/README.ip4r \
- ${PREFIX}/share/doc/postgresql/contrib
+ ${STAGEDIR}${PREFIX}/share/doc/postgresql/contrib
.include <bsd.port.mk>