aboutsummaryrefslogtreecommitdiff
path: root/databases/ipa_sdb
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-06-08 21:15:02 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-06-08 21:15:02 +0000
commit54f367fc8e68c713c557ed88bdc84f1e21b94da8 (patch)
treedd7415ef023a42305ba4fb5075b576b135052ea0 /databases/ipa_sdb
parent62d00c4e99f2a0ea5f309887e3941a6e4726bda6 (diff)
downloadports-54f367fc8e68c713c557ed88bdc84f1e21b94da8.tar.gz
ports-54f367fc8e68c713c557ed88bdc84f1e21b94da8.zip
- Update to support new options framework.
PR: ports/168751 Submitted by: Andrey Simonenko <simon@comsys.ntu-kpi.kiev.ua> (maintainer)
Notes
Notes: svn path=/head/; revision=298780
Diffstat (limited to 'databases/ipa_sdb')
-rw-r--r--databases/ipa_sdb/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/databases/ipa_sdb/Makefile b/databases/ipa_sdb/Makefile
index 7ccdaa7fd6b5..2cf06ba3e91f 100644
--- a/databases/ipa_sdb/Makefile
+++ b/databases/ipa_sdb/Makefile
@@ -19,26 +19,29 @@ USE_BZIP2= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-OPTIONS= AUTORULES "Enable dynamic rules support" on \
- RULES "Enable static rules support" on \
- LIMITS "Enable limits support" on \
- THRESHOLDS "Enable thresholds support" on
+NO_OPTIONS_SORT= yes
+OPTIONS_DEFINE= AUTORULES RULES LIMITS THRESHOLDS
+OPTIONS_DEFAULT= AUTORULES RULES LIMITS THRESHOLDS
+AUTORULES_DESC= Enable dynamic rules support
+RULES_DESC= Enable static rules support
+LIMITS_DESC= Enable limits support
+THRESHOLDS_DESC= Enable thresholds support
.include <bsd.port.options.mk>
-.if defined(WITHOUT_AUTORULES)
+.if empty(PORT_OPTIONS:MAUTORULES)
CONFIGURE_ARGS+= --disable-autorules
.endif
-.if defined(WITHOUT_RULES)
+.if empty(PORT_OPTIONS:MRULES)
CONFIGURE_ARGS+= --disable-rules
.endif
-.if defined(WITHOUT_LIMITS)
+.if empty(PORT_OPTIONS:MLIMITS)
CONFIGURE_ARGS+= --disable-limits
.endif
-.if defined(WITHOUT_THRESHOLDS)
+.if empty(PORT_OPTIONS:MTHRESHOLDS)
CONFIGURE_ARGS+= --disable-thresholds
.endif