aboutsummaryrefslogtreecommitdiff
path: root/databases/java-mybatis
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-03 21:48:44 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-03 21:48:44 +0000
commit4586d2ad5c8db1208ef17384b5c1df8aa36a3f9e (patch)
treea217c2f6b9317591e25a1528cad83dd0d6c1510b /databases/java-mybatis
parentf7622d1fc81f368c475b5acccae9b33957754f02 (diff)
downloadports-4586d2ad5c8db1208ef17384b5c1df8aa36a3f9e.tar.gz
ports-4586d2ad5c8db1208ef17384b5c1df8aa36a3f9e.zip
Nuke NOPORTDOCS. While, here, correct a couple offenders who label examples
with PORTDOCS. And, fix a couple WITH_foo invocations.
Notes
Notes: svn path=/head/; revision=360463
Diffstat (limited to 'databases/java-mybatis')
-rw-r--r--databases/java-mybatis/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/databases/java-mybatis/Makefile b/databases/java-mybatis/Makefile
index 0a3740c2f5b4..a1f9a7c83b83 100644
--- a/databases/java-mybatis/Makefile
+++ b/databases/java-mybatis/Makefile
@@ -8,14 +8,12 @@ CATEGORIES= databases devel java
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX= java-
DISTFILES= ${PORTNAME}-${PORTVERSION}-bundle${EXTRACT_SUFX}
-.if !defined(NOPORTDOCS)
-DISTFILES+= ${USER_GUIDE}
-EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}-bundle${EXTRACT_SUFX}
-.endif
MAINTAINER= glewis@FreeBSD.org
COMMENT= SQL Mapping Framework
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}-bundle${EXTRACT_SUFX}
+
USE_JAVA= yes
USES= zip
LICENSE= APACHE20
@@ -26,14 +24,16 @@ DEST_JAR_FILE= ${PORTNAME}.jar
USER_GUIDE= MyBatis-${PORTVERSION}-User-Guide.pdf
PLIST_FILES+= %%JAVAJARDIR%%/${DEST_JAR_FILE}
-
-.if !defined(NOPORTDOCS)
PORTDOCS= *
-.endif
+
+OPTIONS_DEFINE= DOCS
+DOCS_DISTFILES= ${USER_GUIDE}
+
+.include <bsd.port.options.mk>
do-install:
@${INSTALL_DATA} ${WRKSRC}/${JAR_FILE} ${STAGEDIR}${JAVAJARDIR}/${DEST_JAR_FILE}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@-${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in LICENSE NOTICE
@${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}