aboutsummaryrefslogtreecommitdiff
path: root/databases/jdbc-oracle11g
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-07-05 17:05:41 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-07-05 17:05:41 +0000
commit7e450076425a0509129b6963729d82423f020801 (patch)
tree8c2f5c559641fed1f173ef02d414114daaaa1f20 /databases/jdbc-oracle11g
parent1e8747ebd223f732f259df03d39eb0c6354697e7 (diff)
downloadports-7e450076425a0509129b6963729d82423f020801.tar.gz
ports-7e450076425a0509129b6963729d82423f020801.zip
new port: databases/jdbc-oracle11g
This is a port of the JDBC driver which is used to access Oracle 11g databases using a database-independant API in Java for use with JDK 1.5. WWW: http://www.oracle.com/technetwork/database/features/jdbc/index-091264.html
Notes
Notes: svn path=/head/; revision=300523
Diffstat (limited to 'databases/jdbc-oracle11g')
-rw-r--r--databases/jdbc-oracle11g/Makefile47
-rw-r--r--databases/jdbc-oracle11g/distinfo2
-rw-r--r--databases/jdbc-oracle11g/pkg-descr4
3 files changed, 53 insertions, 0 deletions
diff --git a/databases/jdbc-oracle11g/Makefile b/databases/jdbc-oracle11g/Makefile
new file mode 100644
index 000000000000..d60145adf2a6
--- /dev/null
+++ b/databases/jdbc-oracle11g/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: jdbc-oracle11g
+# Date created: 29 June 2012
+# Whom: Jason Helfman <jgh@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oracle11g
+PORTVERSION= 11.2.0.3
+CATEGORIES= databases java
+MASTER_SITES= # http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html
+PKGNAMEPREFIX= jdbc-
+DISTNAME= ojdbc5.jar
+EXTRACT_SUFX= # none
+DIST_SUBDIR= oracle11g
+
+MAINTAINER= jgh@FreeBSD.org
+COMMENT= JDBC drivers for Oracle 11g
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+RESTRICTED= Packaging prohibited by Oracle license
+NO_CDROM= Packaging prohibited by Oracle license
+
+PLIST_FILES= %%JAVAJARDIR%%/ojdbc-${PORTVERSION}.jar
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTFILES})
+IGNORE= due to Oracle license restrictions, you must fetch the source\
+distribution manually. Please access\
+http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html\
+(Oracle Database 11g Release 2 (${PORTVERSION} JDBC Drivers) with a web\
+browser and follow the link for the ${DISTFILES}. You will be required to\
+register and log in, but you can create an account on that page. After\
+registration and accepting the Oracle License, download the distribution\
+file, ${DISTFILES}, place into ${DISTDIR}/${DIST_SUBDIR}, and restart\
+installation
+.endif
+
+do-install:
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} ${JAVAJARDIR}/ojdbc-${PORTVERSION}.jar
+
+.include <bsd.port.post.mk>
diff --git a/databases/jdbc-oracle11g/distinfo b/databases/jdbc-oracle11g/distinfo
new file mode 100644
index 000000000000..b18c7fb82147
--- /dev/null
+++ b/databases/jdbc-oracle11g/distinfo
@@ -0,0 +1,2 @@
+SHA256 (oracle11g/ojdbc5.jar) = a2f2c71e1df8198c9dc2faf81c711ea9a01895f3073697c0ebff8946beecb7ce
+SIZE (oracle11g/ojdbc5.jar) = 2095932
diff --git a/databases/jdbc-oracle11g/pkg-descr b/databases/jdbc-oracle11g/pkg-descr
new file mode 100644
index 000000000000..1e884c045bb1
--- /dev/null
+++ b/databases/jdbc-oracle11g/pkg-descr
@@ -0,0 +1,4 @@
+This is a port of the JDBC driver which is used to access Oracle 11g databases
+using a database-independant API in Java for use with JDK 1.5.
+
+WWW: http://www.oracle.com/technetwork/database/features/jdbc/index-091264.html