aboutsummaryrefslogtreecommitdiff
path: root/databases/kyototycoon
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-05-30 14:41:10 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-05-30 14:41:10 +0000
commit8ff3465c7f1671d62ae93c433cebd0e05561cf96 (patch)
tree8751bf254355a0ab4cb4c351cb04398793e0566a /databases/kyototycoon
parent0dafb2a4e28a6acf5ee51b97927b9d87f07509d2 (diff)
downloadports-8ff3465c7f1671d62ae93c433cebd0e05561cf96.tar.gz
ports-8ff3465c7f1671d62ae93c433cebd0e05561cf96.zip
- Add kyototycoon 0.9.56
Kyoto Tycoon is a lightweight database server with auto expiration mechanism, which is useful to handle cache data and persistent data of various applications. Kyoto Tycoon is also a package of network interface to the DBM called Kyoto Cabinet. Though the DBM has high performance and high concurrency, you might bother in case that multiple processes share the same database, or remote processes access the database. Thus, Kyoto Tycoon is provided for concurrent and remote connections to Kyoto Cabinet. Kyoto Tycoon is composed of the server process managing multiple databases and its access library for client applications. The network protocol between the server and clients is HTTP so that you can write client applications and client libraries in almost all popular languages. Both of RESTful-style interface by the GET, HEAD, PUT, DELETE methods and RPC-style inteface by the POST method are supported. The server can handle more than 10 thousand connections at the same time because it uses modern I/O event notification facilities such as "epoll" and "kqueue" of underlying systems. The server supports high availability mechanisms, which are hot backup, update logging, and asynchronous replication. The server can embed Lua, a lightweight script language so that you can define arbitrary operations of the database. WWW: http://fallabs.com/kyototycoon/
Notes
Notes: svn path=/head/; revision=297789
Diffstat (limited to 'databases/kyototycoon')
-rw-r--r--databases/kyototycoon/Makefile53
-rw-r--r--databases/kyototycoon/distinfo2
-rw-r--r--databases/kyototycoon/pkg-descr21
-rw-r--r--databases/kyototycoon/pkg-plist211
4 files changed, 287 insertions, 0 deletions
diff --git a/databases/kyototycoon/Makefile b/databases/kyototycoon/Makefile
new file mode 100644
index 000000000000..e123d267d2c6
--- /dev/null
+++ b/databases/kyototycoon/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: kyototycoon
+# Date created: 2011-10-04
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kyototycoon
+PORTVERSION= 0.9.56
+CATEGORIES= databases
+MASTER_SITES= http://fallabs.com/${PORTNAME}/pkg/ \
+ LOCAL/sunpoet
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= A handy cache/storage server
+
+LIB_DEPENDS= kyotocabinet:${PORTSDIR}/databases/kyotocabinet
+
+CONFIGURE_ARGS= --enable-profile --enable-uyield
+GNU_CONFIGURE= yes
+MAKE_ARGS= PCDIR="${PREFIX}/libdata/pkgconfig"
+MAKE_JOBS_SAFE= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+MAN1= ktremotemgr.1 \
+ ktremotetest.1 \
+ ktserver.1 \
+ kttimedmgr.1 \
+ kttimedtest.1 \
+ ktutilmgr.1 \
+ ktutilserv.1 \
+ ktutiltest.1
+
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/DOCDIR/d' ${WRKSRC}/Makefile.in
+.endif
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${FIND} ${DOCSDIR}/ -type d -exec ${CHMOD} 755 '{}' \;
+ ${FIND} ${DOCSDIR}/ -type f -exec ${CHMOD} 444 '{}' \;
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}/
+.endif
+
+regression-test test: build
+ cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE} check
+
+.include <bsd.port.mk>
diff --git a/databases/kyototycoon/distinfo b/databases/kyototycoon/distinfo
new file mode 100644
index 000000000000..4125b9a528c2
--- /dev/null
+++ b/databases/kyototycoon/distinfo
@@ -0,0 +1,2 @@
+SHA256 (kyototycoon-0.9.56.tar.gz) = 553e4ea83237d9153cc5e17881092cefe0b224687f7ebcc406b061b2f31c75c6
+SIZE (kyototycoon-0.9.56.tar.gz) = 503581
diff --git a/databases/kyototycoon/pkg-descr b/databases/kyototycoon/pkg-descr
new file mode 100644
index 000000000000..b745dd4fc4f5
--- /dev/null
+++ b/databases/kyototycoon/pkg-descr
@@ -0,0 +1,21 @@
+Kyoto Tycoon is a lightweight database server with auto expiration mechanism,
+which is useful to handle cache data and persistent data of various
+applications. Kyoto Tycoon is also a package of network interface to the DBM
+called Kyoto Cabinet. Though the DBM has high performance and high concurrency,
+you might bother in case that multiple processes share the same database, or
+remote processes access the database. Thus, Kyoto Tycoon is provided for
+concurrent and remote connections to Kyoto Cabinet. Kyoto Tycoon is composed of
+the server process managing multiple databases and its access library for client
+applications.
+
+The network protocol between the server and clients is HTTP so that you can
+write client applications and client libraries in almost all popular languages.
+Both of RESTful-style interface by the GET, HEAD, PUT, DELETE methods and
+RPC-style inteface by the POST method are supported. The server can handle more
+than 10 thousand connections at the same time because it uses modern I/O event
+notification facilities such as "epoll" and "kqueue" of underlying systems. The
+server supports high availability mechanisms, which are hot backup, update
+logging, and asynchronous replication. The server can embed Lua, a lightweight
+script language so that you can define arbitrary operations of the database.
+
+WWW: http://fallabs.com/kyototycoon/
diff --git a/databases/kyototycoon/pkg-plist b/databases/kyototycoon/pkg-plist
new file mode 100644
index 000000000000..8c271e1071ef
--- /dev/null
+++ b/databases/kyototycoon/pkg-plist
@@ -0,0 +1,211 @@
+bin/ktremotemgr
+bin/ktremotetest
+bin/ktserver
+bin/kttimedmgr
+bin/kttimedtest
+bin/ktutilmgr
+bin/ktutilserv
+bin/ktutiltest
+include/ktcommon.h
+include/ktdbext.h
+include/kthttp.h
+include/ktplugdb.h
+include/ktplugserv.h
+include/ktremotedb.h
+include/ktrpc.h
+include/ktshlib.h
+include/ktsocket.h
+include/ktthserv.h
+include/kttimeddb.h
+include/ktulog.h
+include/ktutil.h
+lib/libkyototycoon.a
+libdata/pkgconfig/kyototycoon.pc
+libexec/ktplugdbvoid.so
+libexec/ktplugservmemc.so
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/annotated.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/bc_s.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classes.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPClient-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPClient.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer_1_1Logger-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer_1_1Logger.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer_1_1Session-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer_1_1Session.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer_1_1Session_1_1Data-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer_1_1Session_1_1Data.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer_1_1Worker-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer_1_1Worker.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1MapReduce-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1MapReduce.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1MapReduce_1_1ReduceTaskQueue_1_1ReduceTask-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1MapReduce_1_1ReduceTaskQueue_1_1ReduceTask.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1MapReduce_1_1ValueIterator-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1MapReduce_1_1ValueIterator.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1PluggableDB-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1PluggableDB.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1PluggableServer-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1PluggableServer.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1Pollable-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1Pollable.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1Poller-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1Poller.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCClient-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCClient.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer_1_1Logger-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer_1_1Logger.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer_1_1Session-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer_1_1Session.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer_1_1Session_1_1Data-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer_1_1Session_1_1Data.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer_1_1Worker-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer_1_1Worker.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RemoteDB-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RemoteDB.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RemoteDB_1_1Cursor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RemoteDB_1_1Cursor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RemoteDB_1_1Error-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RemoteDB_1_1Error.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ReplicationClient-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ReplicationClient.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ServerSocket-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ServerSocket.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1SharedLibrary-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1SharedLibrary.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1Socket-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1Socket.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer_1_1Logger-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer_1_1Logger.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer_1_1Session-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer_1_1Session.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer_1_1Session_1_1Data-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer_1_1Session_1_1Data.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer_1_1Worker-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer_1_1Worker.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1TimedDB-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1TimedDB.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1TimedDB_1_1Cursor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1TimedDB_1_1Cursor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1TimedDB_1_1UpdateTrigger-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1TimedDB_1_1UpdateTrigger.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1TimedDB_1_1Visitor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1TimedDB_1_1Visitor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1URL-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1URL.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1UpdateLogger-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1UpdateLogger.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1UpdateLogger_1_1Reader-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1UpdateLogger_1_1Reader.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/closed.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/doxygen.css
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/doxygen.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/files.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x62.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x63.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x64.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x65.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x66.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x67.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x68.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x69.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6a.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6b.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6c.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6d.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6e.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6f.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x70.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x71.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x72.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x73.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x74.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x75.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x76.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x77.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x78.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x7e.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_enum.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_eval.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x62.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x63.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x64.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x65.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x66.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x67.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x68.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x69.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x6a.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x6c.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x6d.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x6e.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x6f.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x70.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x71.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x72.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x73.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x74.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x75.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x76.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x77.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x7e.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_vars.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/globals.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/globals_defs.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/hierarchy.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/index.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktcommon_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktdbext_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kthttp_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktplugdb_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktplugserv_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktremotedb_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktrpc_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktshlib_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktsocket_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktthserv_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kttimeddb_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktulog_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktutil_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespacekyototycoon.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespacemembers.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespacemembers_func.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespacemembers_type.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespacemembers_vars.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespaces.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/nav_f.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/nav_h.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/open.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structkyototycoon_1_1RemoteDB_1_1BulkRecord-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structkyototycoon_1_1RemoteDB_1_1BulkRecord.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structkyototycoon_1_1UpdateLogger_1_1FileStatus-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structkyototycoon_1_1UpdateLogger_1_1FileStatus.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/tab_a.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/tab_b.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/tab_h.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/tab_s.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/tabs.css
+%%PORTDOCS%%%%DOCSDIR%%/doc/command.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/common.css
+%%PORTDOCS%%%%DOCSDIR%%/doc/icon16.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/index.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/index.ja.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/luadoc/index.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/luadoc/luadoc.css
+%%PORTDOCS%%%%DOCSDIR%%/doc/luadoc/modules/kyototycoon.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/spex.html
+%%PORTDOCS%%%%DOCSDIR%%/kyototycoon.idl
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/doc/luadoc/modules
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/doc/luadoc
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/doc/api
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/doc
+%%PORTDOCS%%@dirrm %%DOCSDIR%%