aboutsummaryrefslogtreecommitdiff
path: root/databases/leveldb
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-25 16:03:32 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-25 16:03:32 +0000
commit5cb9fafa190a9bdd4d9ebb9713da9232028b00ce (patch)
treec8a818ad147d766c646ee1689cf0f379ca5b9094 /databases/leveldb
parent6c2be351c950221b43167f413a7f53e7480effc0 (diff)
downloadports-5cb9fafa190a9bdd4d9ebb9713da9232028b00ce.tar.gz
ports-5cb9fafa190a9bdd4d9ebb9713da9232028b00ce.zip
- Use -pthread instead of deprecated PTHREAD_LIBS
- Use !${PORT_OPTIONS:Mfoo} instead of empty(PORT_OPTIONS:Mfoo)
Notes
Notes: svn path=/head/; revision=325350
Diffstat (limited to 'databases/leveldb')
-rw-r--r--databases/leveldb/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/databases/leveldb/Makefile b/databases/leveldb/Makefile
index e6e8f357a83c..4c2f12522a63 100644
--- a/databases/leveldb/Makefile
+++ b/databases/leveldb/Makefile
@@ -39,11 +39,11 @@ SNAPPY= 0
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/build_detect_platform
-.if empty(PORT_OPTIONS:MGPERFTOOLS)
+ @${REINPLACE_CMD} -e 's|-lpthread|-pthread|' ${WRKSRC}/build_detect_platform
+.if !${PORT_OPTIONS:MGPERFTOOLS}
@${REINPLACE_CMD} -e 's| -ltcmalloc||' ${WRKSRC}/build_detect_platform
.endif
-.if empty(PORT_OPTIONS:MSNAPPY)
+.if !${PORT_OPTIONS:MSNAPPY}
@${REINPLACE_CMD} -e 's| -DSNAPPY||; s| -lsnappy||' ${WRKSRC}/build_detect_platform
.endif