aboutsummaryrefslogtreecommitdiff
path: root/databases/libcouchbase
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-09-03 06:24:27 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-09-03 06:24:27 +0000
commitab38b3a9b1f9b07c72ec80b982f0bdb667e4dda1 (patch)
tree61f438d87a1ddc269fe1ef9ea531587fbe836c4d /databases/libcouchbase
parente78323aa2566e68c8004c38abd78210fc6f9efa4 (diff)
downloadports-ab38b3a9b1f9b07c72ec80b982f0bdb667e4dda1.tar.gz
ports-ab38b3a9b1f9b07c72ec80b982f0bdb667e4dda1.zip
New port: databases/libcouchbase
This is the C client library for Couchbase. It communicates with the cluster and speaks the relevant protocols necessary to connect to the cluster and execute data operations. https://github.com/couchbase/libcouchbase/ PR: 205377 Submitted by: gebhart@secnetix.de, Sergey Avseyev <sergey.avseyev@gmail.com>
Notes
Notes: svn path=/head/; revision=421281
Diffstat (limited to 'databases/libcouchbase')
-rw-r--r--databases/libcouchbase/Makefile27
-rw-r--r--databases/libcouchbase/distinfo3
-rw-r--r--databases/libcouchbase/files/patch-CMakeLists.txt19
-rw-r--r--databases/libcouchbase/pkg-descr5
-rw-r--r--databases/libcouchbase/pkg-plist88
5 files changed, 142 insertions, 0 deletions
diff --git a/databases/libcouchbase/Makefile b/databases/libcouchbase/Makefile
new file mode 100644
index 000000000000..4c3956568d95
--- /dev/null
+++ b/databases/libcouchbase/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= libcouchbase
+DISTVERSION= 2.6.2
+CATEGORIES= databases
+MASTER_SITES= http://packages.couchbase.com/clients/c/
+
+MAINTAINER= sergey@couchbase.com
+COMMENT= Multithreaded noSQL database (client and library)
+
+LICENSE= APACHE20
+
+LIB_DEPENDS= libevent.so:devel/libevent2 \
+ libev.so:devel/libev \
+ libuv.so:devel/libuv
+
+BUILDDIR= ${WRKDIR}/${DISTNAME}/build
+
+CMAKE_ARGS+= -DLCB_NO_TESTS=1
+
+USES= cmake perl5
+USE_LDCONFIG= yes
+USE_PERL5= build run
+
+MAKE_JOBS_UNSAFE= yes
+
+.include <bsd.port.mk>
diff --git a/databases/libcouchbase/distinfo b/databases/libcouchbase/distinfo
new file mode 100644
index 000000000000..10ea3432ac62
--- /dev/null
+++ b/databases/libcouchbase/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1472883834
+SHA256 (libcouchbase-2.6.2.tar.gz) = 28f9218aea0bd0b390bb8129aa6ac2724b7444c0e0c62e21df8d3aabdb896b18
+SIZE (libcouchbase-2.6.2.tar.gz) = 1118419
diff --git a/databases/libcouchbase/files/patch-CMakeLists.txt b/databases/libcouchbase/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..da30e2e7b71d
--- /dev/null
+++ b/databases/libcouchbase/files/patch-CMakeLists.txt
@@ -0,0 +1,19 @@
+--- CMakeLists.txt.orig 2015-08-27 15:51:35 UTC
++++ CMakeLists.txt
+@@ -371,6 +371,7 @@ INSTALL(DIRECTORY include/libcouchbase $
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+ FILES_MATCHING PATTERN *.h PATTERN *.c)
+
++set(CMAKE_INSTALL_MANDIR "man")
+ INSTALL(DIRECTORY doc/man/ DESTINATION ${CMAKE_INSTALL_MANDIR}/man1 FILES_MATCHING PATTERN *.1)
+ INSTALL(DIRECTORY doc/man/ DESTINATION ${CMAKE_INSTALL_MANDIR}/man4 FILES_MATCHING PATTERN *.4)
+
+@@ -382,7 +383,7 @@ SET(_lcb_manifest "${LCB_GENINFODIR}/MAN
+ # pkg-config stuff goes with installation
+ IF(NOT WIN32)
+ CONFIGURE_FILE(packaging/libcouchbase.pc.in packaging/libcouchbase.pc @ONLY)
+- INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/libcouchbase.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
++ INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/libcouchbase.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}data/pkgconfig)
+ ENDIF()
+
+
diff --git a/databases/libcouchbase/pkg-descr b/databases/libcouchbase/pkg-descr
new file mode 100644
index 000000000000..468fd5f83cce
--- /dev/null
+++ b/databases/libcouchbase/pkg-descr
@@ -0,0 +1,5 @@
+This is the C client library for Couchbase. It communicates with the cluster
+and speaks the relevant protocols necessary to connect to the cluster and
+execute data operations.
+
+https://github.com/couchbase/libcouchbase/
diff --git a/databases/libcouchbase/pkg-plist b/databases/libcouchbase/pkg-plist
new file mode 100644
index 000000000000..4fb37ab4e432
--- /dev/null
+++ b/databases/libcouchbase/pkg-plist
@@ -0,0 +1,88 @@
+bin/cbc
+bin/cbc-admin
+bin/cbc-bucket-create
+bin/cbc-bucket-delete
+bin/cbc-bucket-flush
+bin/cbc-cat
+bin/cbc-connstr
+bin/cbc-create
+bin/cbc-decr
+bin/cbc-hash
+bin/cbc-incr
+bin/cbc-lock
+bin/cbc-mcflush
+bin/cbc-n1ql
+bin/cbc-n1qlback
+bin/cbc-observe
+bin/cbc-observe-seqno
+bin/cbc-pillowfight
+bin/cbc-rm
+bin/cbc-stats
+bin/cbc-strerror
+bin/cbc-touch
+bin/cbc-unlock
+bin/cbc-verbosity
+bin/cbc-version
+bin/cbc-view
+bin/cbc-write-config
+include/libcouchbase/_cxxwrap.h
+include/libcouchbase/api-legacy.h
+include/libcouchbase/api3.h
+include/libcouchbase/assert.h
+include/libcouchbase/cbft.h
+include/libcouchbase/cntl-private.h
+include/libcouchbase/cntl.h
+include/libcouchbase/configuration.h
+include/libcouchbase/couchbase.h
+include/libcouchbase/deprecated.h
+include/libcouchbase/error.h
+include/libcouchbase/http.h
+include/libcouchbase/iops.h
+include/libcouchbase/ixmgmt.h
+include/libcouchbase/kvbuf.h
+include/libcouchbase/libev_io_opts.h
+include/libcouchbase/libevent_io_opts.h
+include/libcouchbase/libuv_io_opts.h
+include/libcouchbase/n1ql.h
+include/libcouchbase/pktfwd.h
+include/libcouchbase/plugins/io/bsdio-inl.c
+include/libcouchbase/plugins/io/libuv/libuv_compat.h
+include/libcouchbase/plugins/io/libuv/plugin-internal.h
+include/libcouchbase/plugins/io/libuv/plugin-libuv.c
+include/libcouchbase/plugins/io/wsaerr-inl.c
+include/libcouchbase/plugins/io/wsaerr.h
+include/libcouchbase/select_io_opts.h
+include/libcouchbase/subdoc.h
+include/libcouchbase/sysdefs.h
+include/libcouchbase/vbucket.h
+include/libcouchbase/views.h
+include/libcouchbase/visibility.h
+lib/libcouchbase.so
+lib/libcouchbase.so.2
+lib/libcouchbase.so.2.0.37
+lib/libcouchbase_libev.so
+lib/libcouchbase_libevent.so
+lib/libcouchbase_libuv.so
+libdata/pkgconfig/libcouchbase.pc
+man/man1/cbc-admin.1.gz
+man/man1/cbc-bucket-create.1.gz
+man/man1/cbc-bucket-delete.1.gz
+man/man1/cbc-cat.1.gz
+man/man1/cbc-connstr.1.gz
+man/man1/cbc-cp.1.gz
+man/man1/cbc-create.1.gz
+man/man1/cbc-dsn.1.gz
+man/man1/cbc-flush.1.gz
+man/man1/cbc-hash.1.gz
+man/man1/cbc-lock.1.gz
+man/man1/cbc-n1qlback.1.gz
+man/man1/cbc-observe.1.gz
+man/man1/cbc-pillowfight.1.gz
+man/man1/cbc-rm.1.gz
+man/man1/cbc-stats.1.gz
+man/man1/cbc-unlock.1.gz
+man/man1/cbc-verbosity.1.gz
+man/man1/cbc-version.1.gz
+man/man1/cbc-view.1.gz
+man/man1/cbc.1.gz
+man/man4/cbcrc.4.gz