aboutsummaryrefslogtreecommitdiff
path: root/databases/libdbi
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-06 16:38:20 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-06 16:38:20 +0000
commit0dfd0799ce7ab7d4e39dd942a4715e8c8a2be908 (patch)
tree3aa3f4851f98ae461bd3bf92e9d2dec9ef5718aa /databases/libdbi
parent67fefc20b9d88bf411a8d64aaacaa6ae81019391 (diff)
downloadports-0dfd0799ce7ab7d4e39dd942a4715e8c8a2be908.tar.gz
ports-0dfd0799ce7ab7d4e39dd942a4715e8c8a2be908.zip
upgrade to 0.6.6
PR: 44961 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=69594
Diffstat (limited to 'databases/libdbi')
-rw-r--r--databases/libdbi/Makefile3
-rw-r--r--databases/libdbi/distinfo2
-rw-r--r--databases/libdbi/files/patch-configure17
-rw-r--r--databases/libdbi/files/patch-src::Makefile.in11
-rw-r--r--databases/libdbi/pkg-comment1
-rw-r--r--databases/libdbi/pkg-plist2
6 files changed, 29 insertions, 7 deletions
diff --git a/databases/libdbi/Makefile b/databases/libdbi/Makefile
index a5540b9c3a92..c2444d1b8c8b 100644
--- a/databases/libdbi/Makefile
+++ b/databases/libdbi/Makefile
@@ -7,7 +7,8 @@
#
PORTNAME= libdbi
-PORTVERSION= 0.6.5
+PORTVERSION= 0.6.6
+PORTCOMMENT= Database Independent Abstraction Layer for C
CATEGORIES= databases devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://linux.ucla.edu/~dap24/%SUBDIR%/
diff --git a/databases/libdbi/distinfo b/databases/libdbi/distinfo
index a15215ffdbc6..581d266a04a2 100644
--- a/databases/libdbi/distinfo
+++ b/databases/libdbi/distinfo
@@ -1 +1 @@
-MD5 (libdbi-0.6.5.tar.gz) = d3f8c027a161f71a9891e2cbb55b78e9
+MD5 (libdbi-0.6.6.tar.gz) = aff0f6c96d6c63c0fe73ba0f39fd22c6
diff --git a/databases/libdbi/files/patch-configure b/databases/libdbi/files/patch-configure
index c696306f3a33..3fa8e5d81bad 100644
--- a/databases/libdbi/files/patch-configure
+++ b/databases/libdbi/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Sat Jun 15 09:45:18 2002
-+++ configure Sat Oct 5 21:05:30 2002
-@@ -5551,6 +5551,7 @@
+--- configure.orig Mon Oct 28 02:01:23 2002
++++ configure Sun Nov 3 09:35:03 2002
+@@ -5412,6 +5412,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -8,3 +8,14 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -5452,8 +5453,8 @@
+ PROFILE="-pg -g -O20 -D__NO_MATH_INLINES -fsigned-char -mv8" ;;
+ *)
+ DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char"
+- CFLAGS="-O20 -D__NO_MATH_INLINES -fsigned-char"
+- PROFILE="-O20 -g -pg -D__NO_MATH_INLINES -fsigned-char" ;;
++ CFLAGS="$CFLAGS -D__NO_MATH_INLINES -fsigned-char"
++ PROFILE="$CFLAGS -g -pg -D__NO_MATH_INLINES -fsigned-char" ;;
+ esac
+ fi
+
diff --git a/databases/libdbi/files/patch-src::Makefile.in b/databases/libdbi/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..40cbc3515dad
--- /dev/null
+++ b/databases/libdbi/files/patch-src::Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Mon Oct 28 02:01:32 2002
++++ src/Makefile.in Sun Nov 3 09:31:37 2002
+@@ -96,7 +96,7 @@
+ libdbi_la_SOURCES = dbi_main.c dbi_result.c dbd_helper.c atoll.c asprintf.c
+ libdbi_la_LDFLAGS = -version-info @LIB_CURRENT@:@LIB_REVISION@:@LIB_AGE@
+
+-CFLAGS = -DDBI_DRIVER_DIR=\"@driverdir@\"
++CFLAGS = @CFLAGS@ -DDBI_DRIVER_DIR=\"@driverdir@\"
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+ CONFIG_CLEAN_FILES =
diff --git a/databases/libdbi/pkg-comment b/databases/libdbi/pkg-comment
deleted file mode 100644
index c39017fb74b2..000000000000
--- a/databases/libdbi/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Database Independent Abstraction Layer for C
diff --git a/databases/libdbi/pkg-plist b/databases/libdbi/pkg-plist
index 614997581e2d..0bcd938cd6ed 100644
--- a/databases/libdbi/pkg-plist
+++ b/databases/libdbi/pkg-plist
@@ -40,4 +40,4 @@ lib/libdbi.so.0
%%PORTDOCS%%@dirrm share/doc/libdbi/driver-guide
%%PORTDOCS%%@dirrm share/doc/libdbi
@dirrm include/dbi
-@dirrm lib/dbd
+@unexec rmdir %D/lib/dbd 2>/dev/null || true