aboutsummaryrefslogtreecommitdiff
path: root/databases/libiodbc
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-04-12 14:26:27 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-04-12 14:26:27 +0000
commitd83bdd571b8ba913a812c211cb34dd8e2067e097 (patch)
tree576c4f70e4519706ea79dfed56e12fca1b98eb6b /databases/libiodbc
parent7c5dd1caed4615370728ab8af9fef64eac58bd39 (diff)
downloadports-d83bdd571b8ba913a812c211cb34dd8e2067e097.tar.gz
ports-d83bdd571b8ba913a812c211cb34dd8e2067e097.zip
Update to 3.52.8.
This commit also tries to clean up the infrastructure a little bit. It compiled fine on 7.4, 8.2, 9.0 and 10 on redports: - Remove iodbc.org from the MASTER_SITES list, it doesn't seem to exist anymore. - Set LICENSE. - Remove USE_GMAKE, it seems to build fine with make(1). - Remove the pthreads-related hacks and seds, as they do not seem to be needed anymore, especially now that only pthreads exists. - Remove the -D_BSD_WCHAR_T_DEFINED and the patch in files/, as libiodbc itself has accounted for _BSD_WCHAR_T_DECLARED since 2003. - Act on the example code based on NOPORTEXAMPLES instead of NOPORTDOCS.
Notes
Notes: svn path=/head/; revision=294734
Diffstat (limited to 'databases/libiodbc')
-rw-r--r--databases/libiodbc/Makefile20
-rw-r--r--databases/libiodbc/distinfo4
-rw-r--r--databases/libiodbc/files/patch-include::sqltypes.h10
-rw-r--r--databases/libiodbc/pkg-plist6
4 files changed, 15 insertions, 25 deletions
diff --git a/databases/libiodbc/Makefile b/databases/libiodbc/Makefile
index 6ccaa29fc6a6..8227e10c00dd 100644
--- a/databases/libiodbc/Makefile
+++ b/databases/libiodbc/Makefile
@@ -6,27 +6,27 @@
#
PORTNAME= libiodbc
-PORTVERSION= 3.52.7
+PORTVERSION= 3.52.8
CATEGORIES= databases
-MASTER_SITES= http://www.iodbc.org/downloads/iODBC/ \
- SF/iodbc/iodbc/${PORTVERSION}
+MASTER_SITES= SF/iodbc/iodbc/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= An ODBC 3.x driver manager, for universal data source access
+LICENSE= BSD LGPL20
+LICENSE_COMB= dual
+LICENSE_FILE_BSD= ${WRKSRC}/LICENSE.BSD
+LICENSE_FILE_LGPL20= ${WRKSRC}/LICENSE.LGPL
+
CONFLICTS= unixODBC-[0-9]*
USE_GNOME= gnomehack pkgconfig
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --with-iodbc-inidir=${ETCDIR}
USE_LDCONFIG= yes
MAN1= iodbc-config.1 iodbctest.1 iodbctestw.1
-CPPFLAGS+= ${PTHREAD_CFLAGS} -D_BSD_WCHAR_T_DEFINED_
-LDFLAGS+= ${PTHREAD_LIBS}
-
.if defined(WITH_GUI)
USE_GNOME+= gtk20
MAN1+= iodbcadm-gtk.1
@@ -38,8 +38,6 @@ PLIST_SUB+= GUI="@comment "
post-patch:
@${REINPLACE_CMD} -e \
- 's|$$CFLAGS -pthread|$$CFLAGS|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
'/^SUBDIRS/s|samples||' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \
's|-ldl||g' ${WRKSRC}/admin/libiodbc.pc.in
@@ -52,8 +50,10 @@ post-install:
.for f in AUTHORS ChangeLog NEWS README
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
-.for f in Makefile iodbctest.c
+.for f in Makefile.sample iodbctest.c
${INSTALL_DATA} ${WRKSRC}/samples/${f} ${EXAMPLESDIR}
.endfor
.endif
diff --git a/databases/libiodbc/distinfo b/databases/libiodbc/distinfo
index 855f593cb86d..769eaf481bb4 100644
--- a/databases/libiodbc/distinfo
+++ b/databases/libiodbc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libiodbc-3.52.7.tar.gz) = d7002cc7e566785f1203f6096dcb49b0aad02a9d9946a8eca5d663ac1a85c0c7
-SIZE (libiodbc-3.52.7.tar.gz) = 1038710
+SHA256 (libiodbc-3.52.8.tar.gz) = 18165501fbdb5ab8c445d07365907b77c0c20887aecf37ed2b88aacd9c59129a
+SIZE (libiodbc-3.52.8.tar.gz) = 1089784
diff --git a/databases/libiodbc/files/patch-include::sqltypes.h b/databases/libiodbc/files/patch-include::sqltypes.h
deleted file mode 100644
index 3c6c0b2a35b6..000000000000
--- a/databases/libiodbc/files/patch-include::sqltypes.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- include/sqltypes.h.orig Sun Oct 7 22:44:49 2007
-+++ include/sqltypes.h Sat Oct 20 01:06:36 2007
-@@ -399,6 +399,7 @@
- defined(_WCHAR_T_DEFINED) || \
- defined(_WCHAR_T_DEFINED_) || \
- defined(_WCHAR_T_DECLARED) || \
-+ defined(__FreeBSD__) || \
- defined(_BSD_WCHAR_T_DEFINED_) || \
- defined(_BSD_WCHAR_T_) || \
- defined(_BSD_CT_RUNE_T_)
diff --git a/databases/libiodbc/pkg-plist b/databases/libiodbc/pkg-plist
index 533c4fe92a6a..230b52d1e64a 100644
--- a/databases/libiodbc/pkg-plist
+++ b/databases/libiodbc/pkg-plist
@@ -36,8 +36,8 @@ libdata/pkgconfig/libiodbc.pc
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%EXAMPLESDIR%%/Makefile
-%%PORTDOCS%%%%EXAMPLESDIR%%/iodbctest.c
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.sample
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/iodbctest.c
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrmtry %%ETCDIR%%