aboutsummaryrefslogtreecommitdiff
path: root/databases/libmswstr
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2021-01-11 21:36:26 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2021-01-11 21:36:26 +0000
commitd40e0f966cd5ac24c1b2283ba9a3689592d94056 (patch)
tree27d1c30cadc9c92248d92dda0e960e5e4658bece /databases/libmswstr
parent03192ebe450fb93a83e87a4df8e3983690787b66 (diff)
downloadports-d40e0f966cd5ac24c1b2283ba9a3689592d94056.tar.gz
ports-d40e0f966cd5ac24c1b2283ba9a3689592d94056.zip
databases/libmswstr: New port, version 0.0.1
Provides functionality that allows using indexes from Microsoft Access databases in JET4 format Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D27955
Notes
Notes: svn path=/head/; revision=561279
Diffstat (limited to 'databases/libmswstr')
-rw-r--r--databases/libmswstr/Makefile22
-rw-r--r--databases/libmswstr/distinfo3
-rw-r--r--databases/libmswstr/files/patch-src_mswstr.c11
-rw-r--r--databases/libmswstr/pkg-descr14
-rw-r--r--databases/libmswstr/pkg-plist7
5 files changed, 57 insertions, 0 deletions
diff --git a/databases/libmswstr/Makefile b/databases/libmswstr/Makefile
new file mode 100644
index 000000000000..5fce36b70f91
--- /dev/null
+++ b/databases/libmswstr/Makefile
@@ -0,0 +1,22 @@
+# Created by: Rainer Hurling <rhurlin@gwdg.de>
+# $FreeBSD$
+
+PORTNAME= libmswstr
+PORTVERSION= 0.0.1
+CATEGORIES= databases
+
+MAINTAINER= rhurlin@FreeBSD.org
+COMMENT= Read and parse mdb file indices
+
+# https://github.com/leecher1337/libmswstr/blob/master/COPYING
+#DISABLE_LICENSES= yes
+USES= autoreconf dos2unix libtool
+DOS2UNIX_FILES= mswstr.c nls.h nlstables.h
+DOS2UNIX_WRKSRC= ${WRKSRC}/src
+USE_GITHUB= yes
+GH_ACCOUNT= leecher1337
+GH_TAGNAME= 5682d51
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/databases/libmswstr/distinfo b/databases/libmswstr/distinfo
new file mode 100644
index 000000000000..47a597de3f90
--- /dev/null
+++ b/databases/libmswstr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1593859309
+SHA256 (leecher1337-libmswstr-0.0.1-5682d51_GH0.tar.gz) = 3113412e52023f4d9e51e6ccb9c24f129939e194ebefb4573b269f96de469fa1
+SIZE (leecher1337-libmswstr-0.0.1-5682d51_GH0.tar.gz) = 249155
diff --git a/databases/libmswstr/files/patch-src_mswstr.c b/databases/libmswstr/files/patch-src_mswstr.c
new file mode 100644
index 000000000000..3d8d2a456afd
--- /dev/null
+++ b/databases/libmswstr/files/patch-src_mswstr.c
@@ -0,0 +1,11 @@
+--- src/mswstr.c.orig 2021-01-08 09:11:21 UTC
++++ src/mswstr.c
+@@ -8,7 +8,7 @@
+
+ #include <stdio.h>
+ #include <assert.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <string.h>
+
+ #include "nls.h"
diff --git a/databases/libmswstr/pkg-descr b/databases/libmswstr/pkg-descr
new file mode 100644
index 000000000000..36c0d07c49f6
--- /dev/null
+++ b/databases/libmswstr/pkg-descr
@@ -0,0 +1,14 @@
+When using Microsoft Jet 4 Databases, index fields are created using
+the DBLCMapStringW function (check MSDN library for documentation of
+this function).
+Jet 4 driver itself loads this function from mswstr.dll on Microsoft
+Windows. The library contains static translation tables (as opposed to
+LCMapStringW API) in order to have consistent translations across all
+Windows Versions.
+
+Libraries that try to read and parse mdb file indices like
+databases/mdbtools should work on every platform and therefore a
+platform independent version of this library is needed. This is an
+attempt to port the library to Posix-systems.
+
+WWW: https://github.com/leecher1337/libmswstr
diff --git a/databases/libmswstr/pkg-plist b/databases/libmswstr/pkg-plist
new file mode 100644
index 000000000000..581f78848f0f
--- /dev/null
+++ b/databases/libmswstr/pkg-plist
@@ -0,0 +1,7 @@
+include/mswstr/mswstr.h
+include/mswstr/winnls.h
+include/mswstr/wintypes.h
+lib/libmswstr.a
+lib/libmswstr.so
+lib/libmswstr.so.0
+lib/libmswstr.so.0.0.1