aboutsummaryrefslogtreecommitdiff
path: root/databases/libodbc++
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2004-05-31 21:29:33 +0000
committerMax Khon <fjoe@FreeBSD.org>2004-05-31 21:29:33 +0000
commit43fc33f849e1dc883a91d89f9c1d2ff8cb4cefa7 (patch)
tree5f300c287c89dc381d1c4d5b3c087d11cda14574 /databases/libodbc++
parent2de67f6591d17ea3d0cb9fbef9046a9e2757f719 (diff)
downloadports-43fc33f849e1dc883a91d89f9c1d2ff8cb4cefa7.tar.gz
ports-43fc33f849e1dc883a91d89f9c1d2ff8cb4cefa7.zip
Revive libodbc++:
- update to 0.2.3 - set MAINTAINER to myself for some time to catch build errors on bento A few options and features from original port are missing (WITH_GUI build, NOPORTDOCS build) but I do not have time for implementing them correctly.
Notes
Notes: svn path=/head/; revision=110559
Diffstat (limited to 'databases/libodbc++')
-rw-r--r--databases/libodbc++/Makefile39
-rw-r--r--databases/libodbc++/distinfo2
-rw-r--r--databases/libodbc++/files/patch-Makefile.in11
-rw-r--r--databases/libodbc++/files/patch-configure10
-rw-r--r--databases/libodbc++/pkg-descr14
-rw-r--r--databases/libodbc++/pkg-plist19
6 files changed, 95 insertions, 0 deletions
diff --git a/databases/libodbc++/Makefile b/databases/libodbc++/Makefile
new file mode 100644
index 000000000000..8901b2d01f40
--- /dev/null
+++ b/databases/libodbc++/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: libodbc++
+# Date created: 26 September 2001
+# Whom: Johann Visagie <wjv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libodbc++
+PORTVERSION= 0.2.3
+CATEGORIES= databases devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= libodbcxx
+
+MAINTAINER= fjoe@FreeBSD.org
+COMMENT= A C++ class library and toolset for ODBC access to data sources
+
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_GNOME= pkgconfig
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-isqlxx
+
+# libodbc++ needs an ODBC driver manager to be installed, and it supports
+# both iODBC and unixODBC. The following variable may be set at build-time
+# to either "iodbc" or "unixodbc", with the latter being the default:
+DRIVER_MANAGER?= unixodbc
+
+.if ${DRIVER_MANAGER} == "iodbc"
+LIB_DEPENDS= iodbc.3:${PORTSDIR}/databases/libiodbc
+CONFIGURE_ARGS+= --with-iodbc=${LOCALBASE}
+.else # assume we're using unixODBC
+LIB_DEPENDS= odbc.1:${PORTSDIR}/databases/unixODBC
+CONFIGURE_ARGS+= --with-odbc=${LOCALBASE}
+.endif
+
+PORTDOCS= INSTALL progref
+
+.include <bsd.port.mk>
diff --git a/databases/libodbc++/distinfo b/databases/libodbc++/distinfo
new file mode 100644
index 000000000000..37de260a947f
--- /dev/null
+++ b/databases/libodbc++/distinfo
@@ -0,0 +1,2 @@
+MD5 (libodbc++-0.2.3.tar.gz) = 92cb6171e5235324c710d89cd271eff9
+SIZE (libodbc++-0.2.3.tar.gz) = 450097
diff --git a/databases/libodbc++/files/patch-Makefile.in b/databases/libodbc++/files/patch-Makefile.in
new file mode 100644
index 000000000000..36d200f087e6
--- /dev/null
+++ b/databases/libodbc++/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Thu May 13 04:22:06 2004
++++ Makefile.in Thu May 13 04:22:20 2004
+@@ -140,7 +140,7 @@
+
+ ACLOCAL_AMFLAGS = -I m4
+
+-pkgconfdir = $(libdir)/pkgconfig
++pkgconfdir = $(prefix)/libdata/pkgconfig
+ pkgconf_DATA = libodbc++.pc
+ subdir = .
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/databases/libodbc++/files/patch-configure b/databases/libodbc++/files/patch-configure
new file mode 100644
index 000000000000..dd407ff71cca
--- /dev/null
+++ b/databases/libodbc++/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Thu May 13 04:19:50 2004
++++ configure Thu May 13 04:19:29 2004
+@@ -8007,6 +8007,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/databases/libodbc++/pkg-descr b/databases/libodbc++/pkg-descr
new file mode 100644
index 000000000000..9a3c6d37439d
--- /dev/null
+++ b/databases/libodbc++/pkg-descr
@@ -0,0 +1,14 @@
+Libodbc++ aims to be a complete C++ development environment for data source
+(typically SQL database) access. It exists in the form of a class library
+and a set of tools. Libodbc++ currently provides a subset of the JDBC 2.0
+specification functionality.
+
+Libodbc++ runs on top of ODBC, i.e. it needs to be compiled with support for
+an ODBC driver manager. It currently supports either iODBC or unixODBC.
+This port allows the user to select which driver manager to use via a
+build-time variable definition - see the comments in the Makefile for further
+details.
+
+WWW: http://orcane.net/freeodbc++/
+
+-- Johann Visagie <wjv@FreeBSD.org>
diff --git a/databases/libodbc++/pkg-plist b/databases/libodbc++/pkg-plist
new file mode 100644
index 000000000000..a575ea35acb2
--- /dev/null
+++ b/databases/libodbc++/pkg-plist
@@ -0,0 +1,19 @@
+bin/isql++
+include/odbc++/callablestatement.h
+include/odbc++/config.h
+include/odbc++/connection.h
+include/odbc++/databasemetadata.h
+include/odbc++/drivermanager.h
+include/odbc++/errorhandler.h
+include/odbc++/preparedstatement.h
+include/odbc++/resultset.h
+include/odbc++/resultsetmetadata.h
+include/odbc++/setup.h
+include/odbc++/statement.h
+include/odbc++/threads.h
+include/odbc++/types.h
+lib/libodbc++.a
+lib/libodbc++.so
+lib/libodbc++.so.4
+libdata/pkgconfig/libodbc++.pc
+@dirrm include/odbc++