aboutsummaryrefslogtreecommitdiff
path: root/databases/libodbc++
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-09 17:43:11 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-09 17:43:11 +0000
commit9e5632dd661f75b5801706e55659a4da501e49b5 (patch)
tree1a0770d8cc1771f94f7777b9a986bb87029c35d9 /databases/libodbc++
parent90c653ebbfee158880bc5fc4eb15ad057288510a (diff)
downloadports-9e5632dd661f75b5801706e55659a4da501e49b5.tar.gz
ports-9e5632dd661f75b5801706e55659a4da501e49b5.zip
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port. Ports that set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of the included version. To restore previous behavior, use the new macro, USE_INC_LIBTOOL_VER. Both macros accept the same argument: a libtool version. For example, to use the ports version of libtool-1.5, add the following to your Makefile: USE_LIBTOOL_VER= 15 To use the included version of libtool with extra hacks provided by libtool-1.5, add the following to your Makefile: USE_INC_LIBTOOL_VER= 15 With this change, ports that had to add additional libtool hacks to prevent .la files from being installed or to fix certain threading issues can now delete those hacks (after appropriate testing, of course). PR: 63944 Based on work by:eik and marcus Approved by: ade (autotools maintainer) Tested by: kris on pointyhat Bound to be hidden problems: You bet
Notes
Notes: svn path=/head/; revision=113296
Diffstat (limited to 'databases/libodbc++')
-rw-r--r--databases/libodbc++/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/databases/libodbc++/Makefile b/databases/libodbc++/Makefile
index 2a0863f2d223..60813f8844ad 100644
--- a/databases/libodbc++/Makefile
+++ b/databases/libodbc++/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= fjoe@FreeBSD.org
COMMENT= A C++ class library and toolset for ODBC access to data sources
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_GNOME= pkgconfig
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}