aboutsummaryrefslogtreecommitdiff
path: root/databases/libzbxpgsql/Makefile
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2016-08-16 07:57:21 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2016-08-16 07:57:21 +0000
commit84ccc77177a78de2964ab214da06eedad69cd318 (patch)
tree7138b38cc9992db741c1971204c30d97bb80a072 /databases/libzbxpgsql/Makefile
parentf294d399f74b0d2f55adb4bffdb835eecb0c2365 (diff)
downloadports-84ccc77177a78de2964ab214da06eedad69cd318.tar.gz
ports-84ccc77177a78de2964ab214da06eedad69cd318.zip
Notes
Diffstat (limited to 'databases/libzbxpgsql/Makefile')
-rw-r--r--databases/libzbxpgsql/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/databases/libzbxpgsql/Makefile b/databases/libzbxpgsql/Makefile
new file mode 100644
index 000000000000..adca647e839a
--- /dev/null
+++ b/databases/libzbxpgsql/Makefile
@@ -0,0 +1,32 @@
+# Created by: Martin Waschbuesch <martin@waschbuesch.de>
+# $FreeBSD$
+
+PORTNAME= libzbxpgsql
+PORTVERSION= 1.0.0
+DISTVERSIONPREFIX= v
+CATEGORIES= databases
+
+MAINTAINER= martin@waschbuesch.de
+COMMENT= Zabbix agent module for comprehensive monitoring of PostgreSQL servers
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${NONEXISTENT}:net-mgmt/zabbix3-agent:patch
+RUN_DEPENDS= ${LOCALBASE}/sbin/zabbix_agentd:net-mgmt/zabbix3-agent
+
+USE_GITHUB= yes
+GH_ACCOUNT= cavaliercoder
+
+USES= autoreconf gmake libtool pgsql
+GNU_CONFIGURE= yes
+GET_ZBX_WRKSRC= cd ${.CURDIR:H:H}/net-mgmt/zabbix3-agent && make -V WRKSRC
+CONFIGURE_ARGS= --with-zabbix=$$(${GET_ZBX_WRKSRC})
+
+USE_LDCONFIG= yes
+
+do-install:
+ ${INSTALL_LIB} ${WRKSRC}/src/.libs/libzbxpgsql.so ${STAGEDIR}${PREFIX}/lib/libzbxpgsql.so
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_MAN} ${WRKSRC}/template_postgresql_server.xml ${STAGEDIR}${EXAMPLESDIR}/template_postgresql_server.xml
+
+.include <bsd.port.mk>