aboutsummaryrefslogtreecommitdiff
path: root/databases/libzdb
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-02-29 00:30:41 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-02-29 00:30:41 +0000
commite052def96729ae55cd7019b2eb08ff53144827b2 (patch)
treedd40d0cd1f7990a3b487e379a85f77cfb058b495 /databases/libzdb
parentad1a381f5ab347e7bd1d39b62705fb3715c4da8d (diff)
downloadports-e052def96729ae55cd7019b2eb08ff53144827b2.tar.gz
ports-e052def96729ae55cd7019b2eb08ff53144827b2.zip
Fix the port's configure script to properly detect SQLite3.
This has been broken since r397227 ("Upgrade to 3.1"): the port's build system passes -ldl when trying to detect SQLite3. Since this will always fail on FreeBSD, SQLite3 support will always be disabled as well. PR: 203424 MFH: 2016Q1
Notes
Notes: svn path=/head/; revision=409792
Diffstat (limited to 'databases/libzdb')
-rw-r--r--databases/libzdb/Makefile3
-rw-r--r--databases/libzdb/files/patch-configure51
2 files changed, 53 insertions, 1 deletions
diff --git a/databases/libzdb/Makefile b/databases/libzdb/Makefile
index d5d5426e71df..6f90e698ebff 100644
--- a/databases/libzdb/Makefile
+++ b/databases/libzdb/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libzdb
PORTVERSION= 3.1
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://www.tildeslash.com/libzdb/dist/
@@ -28,7 +29,7 @@ MYSQL_CONFIGURE_OFF= --without-mysql
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-postgresql=${LOCALBASE}/bin/pg_config
PGSQL_CONFIGURE_OFF= --without-postgresql
-SQLITE_USE= sqlite=3
+SQLITE_USES= sqlite
SQLITE_CONFIGURE_ON= --with-sqlite=${LOCALBASE}
SQLITE_CONFIGURE_OFF= --without-sqlite
SSL_USE= openssl=yes
diff --git a/databases/libzdb/files/patch-configure b/databases/libzdb/files/patch-configure
new file mode 100644
index 000000000000..6e03482f5679
--- /dev/null
+++ b/databases/libzdb/files/patch-configure
@@ -0,0 +1,51 @@
+Stop passing -dl when trying to detect SQLite3's presence.
+
+If we don't, the configuration tests will fail and SQLite3 support will always
+be disabled.
+--- configure.orig 2015-08-31 12:55:11 UTC
++++ configure
+@@ -16834,7 +16834,7 @@ for ac_lib in '' sqlite3; do
+ ac_res="none required"
+ else
+ ac_res=-l$ac_lib
+- LIBS="-l$ac_lib -ldl $ac_func_search_save_LIBS"
++ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
+ fi
+ if ac_fn_c_try_link "$LINENO"; then :
+ ac_cv_search_sqlite3_open=$ac_res
+@@ -16900,7 +16900,7 @@ for ac_lib in '' sqlite3; do
+ ac_res="none required"
+ else
+ ac_res=-l$ac_lib
+- LIBS="-l$ac_lib -ldl $ac_func_search_save_LIBS"
++ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
+ fi
+ if ac_fn_c_try_link "$LINENO"; then :
+ ac_cv_search_sqlite3_open=$ac_res
+@@ -17031,7 +17031,7 @@ for ac_lib in '' sqlite3; do
+ ac_res="none required"
+ else
+ ac_res=-l$ac_lib
+- LIBS="-l$ac_lib -ldl $ac_func_search_save_LIBS"
++ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
+ fi
+ if ac_fn_c_try_link "$LINENO"; then :
+ ac_cv_search_sqlite3_soft_heap_limit=$ac_res
+@@ -17089,7 +17089,7 @@ for ac_lib in '' sqlite3; do
+ ac_res="none required"
+ else
+ ac_res=-l$ac_lib
+- LIBS="-l$ac_lib -ldl $ac_func_search_save_LIBS"
++ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
+ fi
+ if ac_fn_c_try_link "$LINENO"; then :
+ ac_cv_search_sqlite3_soft_heap_limit64=$ac_res
+@@ -17147,7 +17147,7 @@ for ac_lib in '' sqlite3; do
+ ac_res="none required"
+ else
+ ac_res=-l$ac_lib
+- LIBS="-l$ac_lib -ldl $ac_func_search_save_LIBS"
++ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
+ fi
+ if ac_fn_c_try_link "$LINENO"; then :
+ ac_cv_search_sqlite3_errstr=$ac_res