aboutsummaryrefslogtreecommitdiff
path: root/databases/libzdb
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-04-20 23:08:34 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-04-20 23:08:34 +0000
commitfce7c8290b1151e6ba3fd34055d40935d66abfce (patch)
treed5d3a2da06b0bf5ca3058de85fe2f30b21cce5bc /databases/libzdb
parent6a0beb045ac0cf7c5a3f0cced968cfd32c2bb8d5 (diff)
downloadports-fce7c8290b1151e6ba3fd34055d40935d66abfce.tar.gz
ports-fce7c8290b1151e6ba3fd34055d40935d66abfce.zip
Fix build on powerpc
PR: 237200 Submitted by: pkubaj
Notes
Notes: svn path=/head/; revision=499489
Diffstat (limited to 'databases/libzdb')
-rw-r--r--databases/libzdb/Makefile13
-rw-r--r--databases/libzdb/files/patch-test-zdbpp.cpp7
2 files changed, 18 insertions, 2 deletions
diff --git a/databases/libzdb/Makefile b/databases/libzdb/Makefile
index a0f74ed155c3..9541c889f355 100644
--- a/databases/libzdb/Makefile
+++ b/databases/libzdb/Makefile
@@ -12,7 +12,7 @@ COMMENT= Thread-safe connection pool library
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake libtool localbase pathfix
+USES= compiler:c11 gmake libtool localbase pathfix
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
@@ -29,7 +29,16 @@ PGSQL_CONFIGURE_WITH= postgresql=${LOCALBASE}/bin/pg_config
PGSQL_USES= pgsql
SQLITE_CONFIGURE_WITH= sqlite=${LOCALBASE}
SQLITE_USES= sqlite
-SSL_CONFIGURE_ENABLE= openssl=${OPENSSLBASE}
SSL_USES= ssl
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSSL}
+.if ${SSL_DEFAULT} == base
+CONFIGURE_ARGS+= --enable-openssl
+.else
+CONFIGURE_ARGS+= --enable-openssl=${OPENSSLBASE}
+.endif
+.endif
+
.include <bsd.port.mk>
diff --git a/databases/libzdb/files/patch-test-zdbpp.cpp b/databases/libzdb/files/patch-test-zdbpp.cpp
new file mode 100644
index 000000000000..7ba8bf27809e
--- /dev/null
+++ b/databases/libzdb/files/patch-test-zdbpp.cpp
@@ -0,0 +1,7 @@
+--- test/zdbpp.cpp.orig 2019-04-03 23:00:49 UTC
++++ test/zdbpp.cpp
+@@ -1,3 +1,4 @@
++#include <cassert>
+ #include <iostream>
+ #include <string>
+ #include <map>